Serveur NAS [Résolu/Fermé]

Signaler
Messages postés
3752
Date d'inscription
mercredi 17 novembre 2004
Statut
Membre
Dernière intervention
22 novembre 2020
-
Messages postés
29447
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
27 novembre 2020
-
Bonjour à tous,

Je dois me connecter sur un NAS Synology en Ipsec L2TP qui se trouve pas chez moi et je n'y arrive malheureusement pas avec Ubuntu. Ce qui me chagrine c'est que si je prend le portable de mon épouse après y avoir suivi la procédure (modif base de registre) ça marche du tonnerre.

J'ai bien cherché sur le net, j'ai bien trouvé des tutos mais rien ne fonctionne je n'arrive toujours pas :-(

Merci aux personnes qui pourraient m'aider à résoudre ce problème, merci aussi de me parler en langage terrien car même si ça fait 10 ans que j'utilise Ubuntu (avec des écarts sur d'autres distributions) je ne suis qu'un utilisateur basique.




10 réponses

Messages postés
29447
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
27 novembre 2020
6 983
Bonjour,

As-tu essayé de suivre ce tutoriel ?
https://www.randomhacks.co.uk/how-to-connect-ubuntu-client-to-synology-pptp-vpn-server/

Bonne chance
Messages postés
3752
Date d'inscription
mercredi 17 novembre 2004
Statut
Membre
Dernière intervention
22 novembre 2020
459
Bonjour mamiemando,

Non je n'ai pas essayé avec ce tutoriel. Sitôt ma garde terminée j'essaie et je te tiens au courant.

Merci
Messages postés
29447
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
27 novembre 2020
6 983
Ok :-)
Messages postés
3752
Date d'inscription
mercredi 17 novembre 2004
Statut
Membre
Dernière intervention
22 novembre 2020
459
Bonsoir,

Cette façon de faire pourrait certainement très bien fonctionner mais comme je ne suis pas administrateur du NAS je ne peux pas tester.

Une autre idée peut être

Merci
Messages postés
29447
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
27 novembre 2020
6 983
J'imagine que ledit administrateur a déjà installé le serveur et que tu peux donc directement tester avec le client si ça marche ?

Peut-être que comprendre comment ça marche sous windows avec ton épouse permettrait de déterminer la marche à suivre sous linux, peux-tu nous détailler précisément ce qu'elle a fait (quel logiciel, etc...).

Le but du jeu ici c'est de trouver un client linux qui fait la même chose que son client windows et de le paramétrer de manière similaire, car le serveur n'a pas de raison de les traiter différemment.

Bonne chance
Messages postés
3752
Date d'inscription
mercredi 17 novembre 2004
Statut
Membre
Dernière intervention
22 novembre 2020
459
Oui tu imagines très bien et l'administrateur ne veut rien entendre ....

J'ai reçu une marche à suivre (de l'admin pour Windows et OS X) pour installer un VPN Ipsec L2TP que j'ai testé sur le portable de mon épouse après avoir essayé en vain de l'installer sur mon ordinateur.

Je te mets la marche à suivre que j'ai reçue

Procédure de configuration d'un serveur L2TP/IPsec derrière un périphérique NAT-T

Pour créer et configurer la valeur de Registre AssumeUDPEncapsulationContextOnSendRule procédez comme suit :

1. Ouvrez une session sur l'ordinateur client Windows en tant qu'utilisateur membre du groupe Administrateurs.

2. Cliquez sur Démarrer, pointez sur Tous les programmes, cliquez sur Accessoires, sur Exécuter, tapez regedit, puis cliquez sur OK.

(Si la boîte de dialogue Contrôle de compte d'utilisateur est affichée à l'écran et qu'elle vous demande d'élever votre jeton d'administrateur, cliquez sur Continuer.)

3. Recherchez la sous-clé de Registre suivante et cliquez dessus :

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\PolicyAgent

4. Dans le menu Edition, pointez sur Nouveau, puis cliquez sur Valeur DWORD 32 bits.

5. Tapez : AssumeUDPEncapsulationContextOnSendRule, puis appuyez sur ENTRÉE.

6. Cliquez avec le bouton droit sur AssumeUDPEncapsulationContextOnSendRule, puis cliquez sur Modifier.

7. Dans la zone Données de la valeur, tapez la valeur : 2 (La valeur 2 configure Windows de sorte qu'il puisse établir des associations de sécurité lorsque le serveur et l'ordinateur client VPN Windows Vista ou Windows Server 2008 se situent derrière des périphériques NAT.)

8. Cliquez sur OK, puis quittez l'Éditeur du Registre.

9. Redémarrez l'ordinateur.


Ensuite:<ital>

Connexion VPN Windows 7
1. Ouvrir connexions et partages dans le panneau de configuration
  • Allez dans le menu Windows, ensuite Contrôle Panneau
  • Cliquez sur Réseau et Internet
  • Cliquez sur Réseau et Centre de Partage


2. Cliquez Configurer une nouvelle connexion ou un réseau

3. Choisissez Se connecter à une place de travail

4. Cliquez sur Utiliser ma connexion Internet (VPN)

5. Dans le champ Adresse Internet, saisissez xxxxxxxxxxxxxxxxxxxx
Dans le champ Nom de destination, taper une description.
Cochez Ne pas se connecter maintenant puis cliquez sur Continuer

6. Entrez votre identifiant et votre mot de passe; laissez le nom de domaine vide.

7. Cliquez Créez et ensuite Fermez

8. Ouvrir Propriétés de connexion VPN
  • Dans Centre Réseau et Partage, cliquez sur Modifier les paramètres de la carte adaptateur
  • Faites un clic-droit sur votre nouvelle connexion et cliquez Propriétés
  • Sous l'onglet Sécurité, cliquez paramètres avancé


Sélectionner : utiliser une clé prépartagée pour l'authentification et entrer la clé de cryptage.
Clé de cryptage : xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
Attention cette clef doit rester confidentiel c'est elle qui garantit l'accès à notre réseau.
Ensuite ok pour terminer.


Sécuriser, sauver, tenir, protéger, maîtriser.
95% des problèmes informatique se situent entre le clavier et la chaise
Messages postés
29447
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
27 novembre 2020
6 983
À la lumière de ces informations, ceci est peut-être plus adapté :
http://bailey.st/blog/2011/07/14/connecting-to-a-l2tpipsec-vpn-from-ubuntu-desktop/

Bonne chance
Messages postés
3752
Date d'inscription
mercredi 17 novembre 2004
Statut
Membre
Dernière intervention
22 novembre 2020
459
Merci pour le lien mais je n'arrive pas à me connecter ..... dommage
Messages postés
3752
Date d'inscription
mercredi 17 novembre 2004
Statut
Membre
Dernière intervention
22 novembre 2020
459
C'est tout bon j'ai réussi à me connecter sur le lien que tu m'a proposé.

C'est du reste le dernier tuto que j'ai essayé et je n'arrive toujours pas me connecter à ce maudit serveur VPN ....

Je te mets le message d'erreur que j'obtiens

nov. 25 22:31:10.738 ipsec_setup: Stopping Openswan IPsec...
nov. 25 22:31:12.545 xl2tpd[3565]: death_handler: Fatal signal 15 received
nov. 25 22:31:12.545 Stopping xl2tpd: xl2tpd.
nov. 25 22:31:12.579 ipsec_setup: Starting Openswan IPsec U2.6.38/K3.19.0-33-generic...
nov. 25 22:31:13.058 ipsec__plutorun: Starting Pluto subsystem...
nov. 25 22:31:13.071 ipsec__plutorun: adjusting ipsec.d to /etc/ipsec.d
nov. 25 22:31:13.081 recvref[30]: Protocol not available
nov. 25 22:31:13.081 xl2tpd[4496]: This binary does not support kernel L2TP.
nov. 25 22:31:13.081 Starting xl2tpd: xl2tpd.
nov. 25 22:31:13.081 xl2tpd[4499]: xl2tpd version xl2tpd-1.3.6 started on ------- -Inspiron-1520 PID:4499
nov. 25 22:31:13.082 xl2tpd[4499]: Written by Mark Spencer, Copyright (C) 1998, Adtran, Inc.
nov. 25 22:31:13.082 xl2tpd[4499]: Forked by Scott Balmos and David Stipp, (C) 2001
nov. 25 22:31:13.082 xl2tpd[4499]: Inherited by Jeff McAdams, (C) 2002
nov. 25 22:31:13.082 xl2tpd[4499]: Forked again by Xelerance (www.xelerance.com) (C) 2006
nov. 25 22:31:13.083 xl2tpd[4499]: Listening on IP address 0.0.0.0, port 1701
nov. 25 22:31:13.110 ipsec__plutorun: 002 added connection description "xxxx"
nov. 25 22:32:30.710 Last command timed out
nov. 25 22:32:30.755 xl2tpd[4499]: death_handler: Fatal signal 15 received
nov. 25 22:32:30.755 Stopping xl2tpd: xl2tpd.
nov. 25 22:32:30.779 ipsec_setup: Stopping Openswan IPsec...

Deux choses me gênent un peu (je les ai mis en gras et en italique), as-tu peut-être une autre idée.

Merci encore de tes renseignements.

Messages postés
29447
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
27 novembre 2020
6 983
J'aurais dû lire les commentaires, il semblerait que ce tutoriel ne marche plus pour les noyaux récents :-(. Désinstalle le paquet correspondant.

Essayons une autre approche qui semble utiliser des paquets plus standards :
https://www.youtube.com/watch?v=DoYVkapRUno

Bonne chance
Messages postés
3752
Date d'inscription
mercredi 17 novembre 2004
Statut
Membre
Dernière intervention
22 novembre 2020
459
Merci mamiemando mais rien de rien ça ne fonctionne toujours pas :-(

J'ai même demandé à une amie anglaise de me traduire la vidéo car mon anglais est ce qu'il est :-)

Du reste il me semble que cette procédure est valable pour se connecter sur un poste avec une distribution Ubuntu serveur ... enfin il me semble.

J'ai vu cet après-midi l'administrateur du NAS pendant ma garde et je lui ai exposé mon problème, il va voir si il peut avec le responsable réseau installer un autre protocole beaucoup mieux reconnu par GNU/Linux afin que je puisse me connecter.

Merci encore de ta disponibilité et je vais le mettre en résolu.
Messages postés
29447
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
27 novembre 2020
6 983
Ok, quand tu seras parvenu à tout faire marcher, n'hésite pas à venir nous dire comment ton et ton admin avez procédé.