Vsftpd/utilisateurs virtuels

Résolu
Bonjour,

sachant que je n'ai pas de SELINUX sur mon serveur linux, qu'elle est la solution de ce problème ??


1 réponse

  1. Modérateur
    Bonjour,

    Ici l'erreur vient du serveur, qui n'a pas les droits (où /home/www/halal n'existe pas ?)

    Si tu installes proftpd, la configuration par défaut permet d'avoir un accès ftp pour chaque utilisateur de la machine, positionné dans son home (et sans possibilité d'en sortir).

    Bonne chance
    0
    1. oui le /home/www/hala1 n'existe pas parce que hala1 est un utilisateur virtuel et son dossier est le /var/www/hala1
      0
    2. en fait j'ai trouvé que j'ai dans mon vsftpd.conf la ligne local_root=/home/www/$USER j là remplacé par local_root=/var/www/$USER et tous a bien marché :) merci pour votre aide.
      0
    3. Modérateur
      Merci pour ton retour, bonne continuation !
      0