GRUB : problème de dualboot W10 et Linux [Résolu/Fermé]

Signaler
Messages postés
13
Date d'inscription
jeudi 24 septembre 2015
Statut
Membre
Dernière intervention
9 décembre 2015
-
 cerise -
Bonjour,

J'ai très récemment intallé Linux en dualboot avec Windows10 sur mon ASUS UX303 avec disque dur SSD (SAMSUNG EVO).
Le problème est qu'au démarrage, je ne tombe pas sur le grub traditionnel avec le sélectionneur de boot mais un écran noir avec:

grub>

Au dessus il est écrit que la touche TAB me permet d'afficher toutes les fonctions utilisables dans ce GRUB.

J'en ai donc parlé aux professeurs d'informatique qui sont dans mon école d'ingénieur, mais on ne parvient à résoudre le problème.

Quelqu'un a t-il une idée du problème?

J'ai tenté le boot-repair sans succès. Voici le fichier qui a été généré, avec le détail de mes disques: https://paste2.org/L4mADNdj
Aidez-moi s'il vous plait, c'est très usant de traîner sur ce problème..

PS: je parviens à démarrer sur Linux en écrivant:
grub > root=(hd0,gpt6)
grub > configfile /boot/grub/grub.cfg

Ceci vient de mes profs d'informatique. On a donc compris que ces deux lignes de codes ne se font pas par le GRUB et je dois donc moi même aller chercher le grub.cfg (qui doit être mal placé?). C'est en faisant cette manip que j'arrive au selectionneur de boot et donc choisir Linux.

Merci à vous pour votre lecture/aide !

12 réponses

Messages postés
6191
Date d'inscription
vendredi 13 juillet 2001
Statut
Contributeur
Dernière intervention
6 janvier 2018
667
Bonjour
A mon avis le plus simple serait de supprimer linux et de le réinstaller en faisant bien attention au départ de mettre le grub sur /dev/sda.
Avec gparted tu peux voir tes partitions



--
Bonjour,
C'est toi qui a désactivé le montage de la partition efi dans /etc/fstab ?
Ligne 399 du rapport boot-info.
Je ne sais pas si ça a son importance mais tu pourrais essayer de la réactiver avec le live pour voir.

Tu as vu la suggestion de réparation de boot-repair ?

Les fichiers de démarrage de [L'OS actuellement utilisé - elementary OS Freya] sont loin du début du disque. Votre BIOS pourrait ne pas les détecter. Vous voudrez peut-être re-essayer après avoir créé une partition /boot (EXT4, >200MB, en début de disque). Cela peut être réalisé via des outils tels que gParted. Puis sélectionnez cette partition via l'option [Partition /boot séparée :] de [Réparateur de démarrage]. (http://doc.ubuntu-fr.org/tutoriel/partition_boot)
Ouais je sais, parvenir à loger une partition en début de disque ça va pas être chose facile : réduction de partition avec déplacement des données, ça va prendre des plombes et c'est pas sans risque surtout que sda2 est la partition de recovery.

Note : Est-ce que ElementaryOS est au top au niveau du support de l'uefi ? je me le demande car ce n'est que très peu de temps avant la sortie de Freya que le support de l'uefi a été annoncé... A ta place je me tournerais plutôt vers ubuntu ou une de ses dérivées qui supporte l'uefi depuis longtemps maintenant.
Slu

Que renvoie la commande "set" dans grub rescue ?

grub>set
Messages postés
13
Date d'inscription
jeudi 24 septembre 2015
Statut
Membre
Dernière intervention
9 décembre 2015

Bonjour à tous,

Tout premièrement, merci à vous pour votre réponse rapide!

Alors je viens de réinstaller Linux en insistant bien sur le fait que le GRUB soit installé sur /dev/sda mais j'ai toujours le même problème..

En ce qui concerne la création du fichier, en début du disque, je ne m'y connais pas grandement.. Puis-je créer ce fichier à partir d'un espace de disque dur non alloué? Car il me reste encore de la place. Puis-je donc créer un tel espace avec cet espace pour ensuite, dans le réparateur de démarrage, l'indiquer comme partition de démarrage?

Mes profs ne pensaient pas que ce soit un problème d'Elementary OS car cela dérive de Unbuntu (la version 4 il me semble mais je ne suis pas certain). Donc je ne pensais pas que ce soit lié à EO.

Alors je viens tout juste de faire set dans le Grub Rescue et j'obtiens:

grub > set
cmdpath=(hd0,gpt1)/EFI/GRUB
color_highlight=black/light-gray
color_normal=light-gray/black
feature_200_final=y
feature_all_video_module=y
feature_chaineloader_bpb=y
feature_default_font_path=y
feature_menuentry_id=y
feature_menuentry_options=y_
feature_nativedisk_cmd=y
feature_ntldr=y
feature_platform_search_hint=y
feature_timeout_style=y
grub_cpu=x86_64
grub_platform=efi
lang=
locale_dir=
net_default_ip=(null)
net_default_max=(null)
net_default_serveur=
pager=
prefix=(hd0,gpt1)/EFI/ubuntu
pxe_default_serveur
root=hd0,gpt1
secondary_locale_dir=

Je ne sais pas quoi en penser. Je viens de me renseigner sur le fait que le GRUB soit en EFI (désolé si le vocabulaire utilisé n'est pas correct, je suis très novice), mais je n'aboutis pas à la solution magique.

Peut-être devrais-je donc essayer Ubuntu.. (même si j'étais tombé amoureux du Elementary OS ! Si je peux le conserver, j'en serai très content!)

Un grand grand merci à vous pour votre aide !!

Jason Mahé
Il aurait été intéressant que tu testes une autre distribution. Car ni set ni boot-info ne révèlent le moindre problème, si ce n'est la réparation "merdique" de boot-repair.

Et refais un boot-info (depuis un live-cd) auparavant pour qu'on voie si quelque chose apparaît dans ce mode.
Messages postés
13
Date d'inscription
jeudi 24 septembre 2015
Statut
Membre
Dernière intervention
9 décembre 2015

Voici ce que le boot-info en live-USB donne :
https://paste2.org/Np0GE5Ij

J'essaierai prochainement d'installer Ubuntu. J'ai l'impression de ne pas avoir le choix de lâcher EO.
Re,

Pour moi, il y a plusieurs pistes à ton problèmes :

- Le fichier grub
=================== sda7/etc/default/grub :
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=

Il est étrangement vide. On s'attendrait à trouver d'autres entrées, notamment la sélection de l'os par défaut.

- La position de grub
La commande set renvoie ceci :
prefix=(hd0,gpt1)/EFI/ubuntu 

Or, la partition de montage s'appelle en principe grub.
Bref, c'est probablement EO qui semble être à l'origine de problème. C'est comme si il y avait un pataquès entre la programmation de grub (pour ubuntu) et les choix de EO (qui crée un dossier grub).

Le plus simple est essayer une autre distribution. Fais déjà l'essai de modifier grub ainsi et tente d'afficher le menu

set prefix=(hd0,gpt1) /boot/grub
insmod normal
normal
Messages postés
13
Date d'inscription
jeudi 24 septembre 2015
Statut
Membre
Dernière intervention
9 décembre 2015

Bonjour,
Un grand merci pour votre analyse très détaillée ! Je vais donc essayer de renommer le fichier et sinon j'instellerai Ubuntu.

Je vous tiens au courant !
Merci pour votre aide.
Essaie aussi d'éditer le fichier /etc/default/grub et tu remplaces le contenu par

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""


Tu enregistres, puis un
 sudo update-grub
pour valider le tout.
Messages postés
13
Date d'inscription
jeudi 24 septembre 2015
Statut
Membre
Dernière intervention
9 décembre 2015

Bonjour,

Je peine à modifier le fichier car il est suprotégé. J'ai essayé de m'accorder des droits à partir de chmod (on a vu ça en cours hier) mais je ne parviens pas à y arriver.

Je vais essayer d'installer Ubuntu à la place et je vous tiens au courant. Si Ubuntu fonctionne, je resterai dessus je pense.
Je peine à modifier le fichier car il est suprotégé.J'ai essayé de m'accorder des droits à partir de chmod (on a vu ça en cours hier) mais je ne parviens pas à y arriver.

A partir de ta session eOS, tu l'ouvres avec la commande :
sudo scratch etc/default/grub
et tu pourras le modifier à ta convenance. Il me semble que par défaut scratch sauvegarde automatiquement à chaque frappe clavier donc même pas besoin de sauvegarder...
Ou bien tu lances le navigateur de fichiers en mode root :
sudo files

Ensuite, tu recherches le fichier /etc/default/grub, tu cliques dessus et il sera automatiquement ouvert avec les droits root...

Note : évite de modifier les droits d'un fichier système si tu ne veux pas casser ton système.
Messages postés
13
Date d'inscription
jeudi 24 septembre 2015
Statut
Membre
Dernière intervention
9 décembre 2015

Je ne parviens pas à atteindre EOS depuis que je l'ai réinstallé.
En faisant les deux lignes suivantes, ça ne fonctionne plus:
root=(hd0,gpt6)
configfile = /boot/grub/grub.cfg

Je pense que la réinstallation de EOS à été faite sur une partition d'un autre nom mais je ne parviens pas à trouver où.

J'ai donc essayé vos conseils sur le live-USB mais il ne connait pas scratch et j'imagine que pour que votre aide fonctionne, il faut je me trouve directement dans le répertoire où se trouve mon système Linux.

Ainsi, dois-je faire vos manipulations à partir de EOS installé uniquement (et non sous live-USB) ? Et scratch necessite-t'il une installation?

Merci à vous !
>
Messages postés
13
Date d'inscription
jeudi 24 septembre 2015
Statut
Membre
Dernière intervention
9 décembre 2015

Scratch est l'éditeur de texte par défaut d'eOS.(je croyais que tu connaissais)
Tu peux faire la manip à partir d'un live usb. Je vais essayer de faire simple.
1 - lance Files en user et affiche le contenu de la partition eOS de cette manière elle sera montée automatiquement. Lorsque c'est fait ferme Files. (le but c'était seulement de monter la partition sans taper de ligne de commande sinon tu ne la verras pas dans l'étape suivante)
2 - Ouvre le terminal et tape
sudo files
(on ouvre Files en mode root maintenant) cherche ta partition eOS dans /media si elle n'est pas affichée dans le volet de gauche. Quand tu l'as trouvée cherche le fichier etc/default/grub et clique dessus, il sera édité en root. Fais tes modifs.

Attention à chaque fois que tu fais une réinstallation, tu fous un peu plus de bazar dans la partition EFI, tu dois avoir de plus en plus d'entrées là-dedans, ça va pas être coton pour faire le ménage là-dedans.
Il te faudrait ikewdu pour démêler tout ça, mais ça fait un moment qu'il n'est pas passé...

EOS est une superbe distro, c'est incontestable et j'admire son esthétique mais je me méfie de sa gestion de l'uefi. Elle a beau être dérivée d'Ubuntu, ses concepteurs ont mis beaucoup de temps avant d'annoncer le support uefi (il n'était pas disponible dans les versions beta), donc ça n'a pas dû être si simple que ça. Il n'y a pas une grosse équipe de dev comme chez Canonical derrière tout ça.
Apparemment t'es pas le seul :
http://forum.elementaryos-fr.org/topic/1734-r%C3%A9solu-boot-elementaryos/?hl=uefi#entry12341
Messages postés
13
Date d'inscription
jeudi 24 septembre 2015
Statut
Membre
Dernière intervention
9 décembre 2015

Bonjour jn55.

Merci pour votre réponse très détaillée ! J'ai essayé de suivre votre procédure mais je ne parviens à effectuer le <sudo files> car il me sort que la commande files n'a pas été trouvée.

Cependant, en lisant votre lien, je remarque que la personne qui a eu ce problème a réussi à résoudre le problème en réinstaller en "legacy" puis avec un boot-repair. Comment réinstaller EOS en "legacy"? Je cherche des infos sur le net mais je me perds un peu. Peut-être que cette alternative peut résoudre efficacement mon problème.

Je vous remercie tous pour vos réponses ! C'est très agréable de se sentir aidé, un grand grand merci !
Si j'en crois ton dernier boot-info, tu es passé de gpt6 à gpt7
Messages postés
13
Date d'inscription
jeudi 24 septembre 2015
Statut
Membre
Dernière intervention
9 décembre 2015

Sauf qu'entre-temps j'ai essayé Ubuntu et là je suis retourné sur EOS (je n'accroche pas à Ubuntu). Donc ça a encore changé.. Mais j'ai lu ensuite que ça mettait le bazar dans mes partitions.. Et là je regrette un peu. Je n'ai pas pensé à ça...

Déjà, une fois le problème d'EOS résolu, je me pencherai sur celui-ci histoire de faire un peu le ménage pour avoir des partitions saines.

Un grand merci !
Tu dis ceci :

Sauf qu'entre-temps j'ai essayé Ubuntu et là je suis retourné sur EOS (je n'accroche pas à Ubuntu).


Tu n'as pas dit si grub fonctionnait ou non avec ubuntu... ça aurait aidé.

De même, tu n'as pas précisé ce que donnait la réécriture du fichier grub... ça aurait peut-être pu suffire.

Quoi qu'il en soit, le fait que grub cherche le fichier grub.cfg dans un dossier /ubuntu n'a pas de sens. Je pense aussi que c'est un bug de EO.
Messages postés
13
Date d'inscription
jeudi 24 septembre 2015
Statut
Membre
Dernière intervention
9 décembre 2015

C'est exact.
Le GRUB fonctionnait effectivement sous Ubuntu. Cependant je trouvais ça dommage de devoir quitter EOS pour un problème de GRUB alors qu'il fonctionnait très bien quand on faisait 2 lignes de codes..

Je n'arrive pas à ré-écrire sur le fichiers GRUB. Je l'ai précisé plus haut. EOS ne comprends pas <sudo files>..

Je suis d'accord.. J'espère tout de même réussir à installer EOS c'était le but initial.
>
Messages postés
13
Date d'inscription
jeudi 24 septembre 2015
Statut
Membre
Dernière intervention
9 décembre 2015

Si grub fonctionnait correctement avec ubuntu, ça aurait été plus simple de garder ubuntu et d'installer le bureau pantheon !
http://tuxdiary.com/2015/06/27/install-pantheon-desktop-ubuntu/
C'est vraiment pas compliqué... Ça ne sera pas de l'eOS pur jus mais ça en aura l'exacte apparence et un fonctionnement identique.

Quant à installer eOS en mode legacy alors que Win10 est en mode efi... Je déconseille. La situation est déjà assez embrouillée comme ça. Si ubuntu fonctionne, garde-le.
Messages postés
13
Date d'inscription
jeudi 24 septembre 2015
Statut
Membre
Dernière intervention
9 décembre 2015

Ok, je vais faire comme ça dans ce cas. Merci beaucoup ! Je vous donne de mes nouvelles lorsque ça fonctionnera.
Cependant je trouvais ça dommage de devoir quitter EOS pour un problème de GRUB

Tu es forcé de rester en uefi /gpt pour la compatibilité avec ton Windows. Quant à EOS, tu peux aussi tenter de l'installer en remplaçant grub par refind, ce que pas mal d'utilisateurs d'Ubuntu font depuis un moment. Il est visiblement plus facile à paramétrer.
Messages postés
13
Date d'inscription
jeudi 24 septembre 2015
Statut
Membre
Dernière intervention
9 décembre 2015

Alors, j'ai installé ubuntu puis j'ai essayé d'installer le Pantheon desktop. L'installation a bien été effectuée jusqu'au bout mais je n'arrive pas à trouver comment utiliser cette version desktop. En effet, lorsque je ferme ma session, je n'ai pas le choix du desktop comme il est écrit sur le net.

Avez-vous une idée du problème?

Merci pour votre aide. Si j'arrive à obtenir le bureau Pantheon, cela me conviendra parfaitement !!
Salut,
http://doc.ubuntu-fr.org/lightdm#selectionner_son_environnement_graphique_prefere

S'il est installé sans erreur, il n'y a aucune raison pour que tu ne le trouves pas à l'écran de connexion...
Messages postés
13
Date d'inscription
jeudi 24 septembre 2015
Statut
Membre
Dernière intervention
9 décembre 2015

YES YES YES !!!

Le GRUB d'Elementary OS fonctionne enfin !!

Alors comme vous l'avez remarqué, je suis passé sous Ubuntu. Puis en essayant d'installer le Pantheon desktop c'est devenu le bazar alors que ça parait pourtant très simple. Déterminé, je décide aujourd'hui de retourner sur EOS.

Ainsi je ressors mes cours sur Linux et arrive enfin à modifier les droits d'accès avec chmod. Ainsi, sous les conseils de cab, je modifie le fichier grub dans etc/default.
Sauf que ça ne marche toujours pas au redémarrage.. Aïe Aïe Aïe.. Je désespère.. Mais je rééssaie un Repair-Boot rapidement.. Et là: CA FONCTIONNE !!

Ainsi, cab a identifié le problème: le fichier etc/default/grub.txt était vide.

Par conséquent, pour tout ceux qui ont ce problème, je résume.

Modifier le contenu du fichier etc/default/grub.txt par :
GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

Puis, vous faites un Boot-Repair.

Vous redémarrez et tout est OK !!

Un grand merci à vous tous! Sans vous, je n'aurais pas été loin avec mon GRUB merdique!

MERCI !
"CQFD". Un simple sudo update-grub aurait suffit après la modification du fichier grub.
Hello

Also have had issues to install elementary OS freya on my new ASUS X556U in dual boot windows10/eOS. this windows version is older than july 29, 2016.

I first followed theese steps (found there : https://itsfoss.com/guide-install-elementary-os-luna/) :

- create a live USB of Elementary OS Freya and let the usb key in its port

- defrag windows

- note the memory reserved to Windows (C ?) and to the Data (D?) in order not to make an error in the future partition step
- restart windows
- when it is loading press F2 to access the BIOS (it seems that F1, 10, 11, 12 can work on others PC)
- in the Security tab disable "secure boot"
- in the Boot tab enable "Launch CSM" and "Launch PXE opROM policy" (wich in the right column refers to "control the execution of legacy opROM")
- press F10 to save and exit
- restart and when it is loading press AND HOLD Esc.
- choice to start with USB device (or the mark of the usb key) but not the EFI one
- I did what itsfoss wrote about partitions with a few differences :

--> I didn't delete one device but changed the existing data device from 600000 to 200000 Mo in order to create free space.

--> Then I added a 20000 Mo "/" logical beginning ext4 partition (root), a 12000 Mo logical beginning swap area (12 Go is my 6Go RAMx2) (swap), a 100 Mo BIOS boot partition (grub) and a "/home" rest-of-the-free-space Mo logical beginning ext4 partition (home).

- and followed instructions until a note asked me to restart the system.
- wich refused to start another OS that windows.

Then I fell into research about grub, boot-repair and sudo apt-get during 3 hours.

Next https://forum.ubuntu-fr.org/viewtopic.php?pid=20542461#p20542461 saved my mind.

- I followed its instructions :
- start with windows (I didn't have any other choice anyway)
- right click the window logo in the left bottom corner
- search the "settings"
- find "update and security"
- select "recovery" and "restart now"
- choice the device option with "EFI" in the name (first choice in my case)
- follow the steps on the screens .
- at the partitions steps you will see a new partition on the top of the list called "efi" which is the grub of Windows. So our first grub (BIOS boot partition) does'nt serve anymore i guess. But im not sure and did'nt delete it. For the others partitions the names "/" and "/home" of my ext4 partitions had disappeared in my list so i named them again and checked the "format the partition" box for both.
- the rest of the steps is well known now

THAT WORKS FOR ME !!

(sorry for the translate)