Problème démarrage, Minimal Bash-like, Ubuntu [Résolu/Fermé]

Signaler
Messages postés
6
Date d'inscription
samedi 31 janvier 2009
Statut
Membre
Dernière intervention
3 février 2009
-
Messages postés
1
Date d'inscription
vendredi 30 décembre 2011
Statut
Membre
Dernière intervention
30 décembre 2011
-
Bonjour à tous,

Premièrement, j'ai windows Vista 32bits installé en dual boot avec Ubuntu 8.10.
Et alors gros problème ce matin en allumant mon ordi : je découvre que le choix de partitions pour le boot ne s'affiche pas mais que le message d'erreur "[ Minimal BASH-like line editing is supported. For the first word, TAB lists possible command completions. Anywhere eles TAB lists the possible completions of a device/filename. ]" le remplace.
Inutile de vous dire que j'ai cherché dans tous les recoins du web pour résoudre mon problème, car le mien est très spécifique.

Histoire de vous aider à comprendre (peut-être facultative) : Hier, sur une de mes partitions vista, j'ai appliqué un formatage. Le problème vient peut-être de là, étant donné que lorsque je me suis fait installé Ubuntu en Dual boot avec vista (à partir d'un cd live que je n'ai pas avec moi), la personne qui me la installé a pris un bout de cette partition pour libérer de l'espace mémoire vive pour ubuntu (ou un truc du genre...). Mais après le formatage, j'ai bien vu que ce petit bout de partition y était encore, dont normalement aucun problème, je n'ai pas formaté celui-ci.

Bref, j'ai un gros problème pour booter, j'ai essayé plein de manip mais les sudo,ls... ainsi que les parenthèse ne marche pas avec mon minimal bash-like !
Donc j'ai du me restreindre à un "find /boot/grub/menu.lst" qui est la seule commande qui m'a donné un résultat avec de l'espoir, elle me retourne : hd(0,0)
Bien sur comme je ne peux pas utiliser les parenthèses sous le minimal bash-like, impossible de l'exploiter...

Je vious prie donc de pourvoir m'aider sur ce problème, au moins de pouvoir booter sur vista, où j'ai pas mal de trucs à faire...
Merci d'avance...

7 réponses

Messages postés
6
Date d'inscription
samedi 31 janvier 2009
Statut
Membre
Dernière intervention
3 février 2009
23
Je met à jour mon problème, étant donné que personne peut m'aider, des informations complémentaires vous seront peut-être utiles :

Donc, je ne peux pas quitter le grub (la commande "quit" n'est pas reconnue).
quand je tape :
"find /boot/grub/menu.lst ou find /sbin/init", cela me retourne : "(hd0,0)"
Etant donné que je ne peux pas écrire de parenthèses (déjà pourriez-vous m'aider sur ce problème ??), j'ai tenté en vain :
"root[hd0,0]
setup[hd0]"
Cela me retourne l'erreur 11 : "unrecognized device string"
Evidemment si les parenthèses ne marchent pas, peut-être que c'est logique...

Du coup je suis complémentement bloqué car l'utilisation de mon grub n'est pas la même que tous les autres...

Aidez-moi s'il vous plait...
11
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 59483 internautes nous ont dit merci ce mois-ci

Messages postés
6
Date d'inscription
samedi 31 janvier 2009
Statut
Membre
Dernière intervention
3 février 2009
23
Si au moins vous pouviez me dire comment booter sur Vista, cela m'arrangerait vraiment vraiment beaucoup... Merci !
Messages postés
6
Date d'inscription
samedi 31 janvier 2009
Statut
Membre
Dernière intervention
3 février 2009
23
Oui effectivement ce super grub disk est le truc à avoir sous la main quand on a un dual boot comme le mien !
J'ai réussi à réparer mon grub grâce à lui, merci beaucoup youplaboum, pas d'hésitation à avoir super grub est vraiment super !
autre possibilite... si les partitions sont ok mais le demarrage (mbr non) et que tu as le grub bash like avec "grub>"
comme tu avais bien indique
tu tapes
find /boot/grub/stage1
ca retourne un truc du genre (hd0,x)
il suffit ensuite de taper
root (hd0,x)
puis setup (hd0)
et enfin taper
reboot

la ca redemmarre
teste avec XP et kubuntu 8.10
Messages postés
1
Date d'inscription
vendredi 30 décembre 2011
Statut
Membre
Dernière intervention
30 décembre 2011

Salut , j ai le même prob mais quand je lancer la commande find /boot/grub/stage1
Il retourne : file not found
please if someone can help ,i m waiting !!
Merci d'avance
tu as le cd de vista ?
sinon avec supergrubdisk
Messages postés
2
Date d'inscription
vendredi 11 décembre 2009
Statut
Membre
Dernière intervention
7 octobre 2014
1
Salut tlm,

Ce problème est suite à une mise a jour. Pour ca il y a un super tuto suivez ce lien:

http://forum.ubuntu-fr.org/viewtopic.php?id=363640
Messages postés
6
Date d'inscription
samedi 31 janvier 2009
Statut
Membre
Dernière intervention
3 février 2009
23
J'ai un cd de vista mais il me supprime toutes mes données et réinstaller vista par dessus, j'aimerais éviter ça. Par contre j'y avais pensé pour supprimer la partition Ubuntu, mais impossible de le faire avec ce CD.
Tu peux me donner plus d'explication sur supergrubdisk ? Que dois-je faire ?
juste pour info, je ne sais pas pour vista mais xp possede une console de recuperation qui permet de restaurer le boot. de memoire les commandes sont fixboot et fixmbr

https://www.supergrubdisk.org/
personnellement je n'ai pas encore eu l'occasion de le tester :)