Excel si valeur supérieur alors ou " "

[Résolu/Fermé]
Signaler
-
Messages postés
34
Date d'inscription
jeudi 25 juin 2015
Statut
Membre
Dernière intervention
18 novembre 2015
-
Bonjour,

je cherche à faire une formule qui comprend un si. La formule de base est celle-ci: =SI(AL15>AM15;"Oui";"Non"). Elle est très simple, mais c'est juste que quand une ou deux des cellules sont sans données, la formule donne "Non" et je voudrais plutôt qu'elle reste sans données. Je veux faire la moyenne de la série de données après, Est-ce possible dans la même formule ou je le fais en deux opérations.

Merci d'avance
A voir également:

2 réponses

Messages postés
34
Date d'inscription
jeudi 25 juin 2015
Statut
Membre
Dernière intervention
18 novembre 2015
2
Bonjour,

pour votre première question, vous pouvez insérer une deuxième conditionnelle dans la formule, ce qui donnerait:

=SI(ET(AL15<>"",AM15<>""),SI(AL15>AM15,"Oui","Non"),"")

Pour votre deuxième question, je ne suis pas sûr de comprendre ce que vous voulez faire exactement.

Messages postés
34
Date d'inscription
jeudi 25 juin 2015
Statut
Membre
Dernière intervention
18 novembre 2015
2 > Kary
Pourtant l'exemple que je vous ai donné de mon côté fait exactement ce que vous me dites.. je pourrais vous joindre le fichier
Voici un exemple pour mes lignes de données. https://drive.google.com/file/d/0B67XbSI4HbzkeFFVUFo5SVpNVE0/view?usp=sharing
Messages postés
34
Date d'inscription
jeudi 25 juin 2015
Statut
Membre
Dernière intervention
18 novembre 2015
2
Kary, si tu veux que je t'aide plus, va dans mon profil et écris moi ton adresse courriel en privé, je vais pouvoir regarder ton fichier directement.

Pat
Merci beaucoup :) J'ai réglé tout mes problèmes.
Messages postés
34
Date d'inscription
jeudi 25 juin 2015
Statut
Membre
Dernière intervention
18 novembre 2015
2
Wow, j'aimerais ça pouvoir régler tous mes problèmes si vite! :-)
Je blague..
Messages postés
16523
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
28 septembre 2021
3 228
Bonjour
remplacer
=si (ou(estvide(AL15);estvide(AM15));"";SI(AL15.....etc

autre manière
=Si(NON(OU(ESTVIDE(AL15);ESTVIDE(AM151)));SI(AL15>AM15,"Oui","Non"),"")
ou encore
si(NBVAL(AL15:AM15)>1;SI(AL15>AM15,"Oui","Non"),"")

Michel
Messages postés
589
Date d'inscription
mardi 7 avril 2015
Statut
Membre
Dernière intervention
23 juillet 2015
56 > Kary
Ta formule est bonne, si tu as une case avec un oui dans la zone AL111:AL191.

Cela fera 1/1 * 100 = 100

Le résultat est exact, merci de préciser le résultat escompté.
>
Messages postés
589
Date d'inscription
mardi 7 avril 2015
Statut
Membre
Dernière intervention
23 juillet 2015

Ça ne fonctionne pas, il faudrait que je puisse mettre plusieurs critères (oui, non) dans la deuxième partie de la formule. Je crois que "*" considère les formules comme n'étant pas des espaces blancs. J'ai environ 30 oui et 16 non et ça me donne une moyenne de 29%. C'est sur que c'est pas ce que je recherche.
Messages postés
16523
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
28 septembre 2021
3 228 > Kary
autre possibilité par formule matricielle (maquette à adapter)
=SI(NB(B1:B11)>0;MOYENNE(SI(A1:A11="oui";B1:B11));0)
Formule à valider par « ctrl+maj+entrée » (et non directement par « entrée »), le curseur clignotant dans la barre de formule
>
Messages postés
16523
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
28 septembre 2021

Je ne sais pas si c'est moi qui ne comprend pas bien mais la formule ne marche pas. Merci quand même. :)
Messages postés
16523
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
28 septembre 2021
3 228 > Kary
pourtant, je l'avais testé avec succès