Excel si valeur supérieur alors ou " "

Résolu/Fermé
Kary - 3 juil. 2015 à 21:46
DevAxia Messages postés 34 Date d'inscription jeudi 25 juin 2015 Statut Membre Dernière intervention 18 novembre 2015 - 8 juil. 2015 à 19:39
Bonjour,

je cherche à faire une formule qui comprend un si. La formule de base est celle-ci: =SI(AL15>AM15;"Oui";"Non"). Elle est très simple, mais c'est juste que quand une ou deux des cellules sont sans données, la formule donne "Non" et je voudrais plutôt qu'elle reste sans données. Je veux faire la moyenne de la série de données après, Est-ce possible dans la même formule ou je le fais en deux opérations.

Merci d'avance
A voir également:

2 réponses

DevAxia Messages postés 34 Date d'inscription jeudi 25 juin 2015 Statut Membre Dernière intervention 18 novembre 2015 2
3 juil. 2015 à 23:08
Bonjour,

pour votre première question, vous pouvez insérer une deuxième conditionnelle dans la formule, ce qui donnerait:

=SI(ET(AL15<>"",AM15<>""),SI(AL15>AM15,"Oui","Non"),"")

Pour votre deuxième question, je ne suis pas sûr de comprendre ce que vous voulez faire exactement.

0
Bonjour, ce n'est pas encore ce que je cherche. Dans le cas de votre formule, quand il y a un zéro, il le considère comme étant sans données et quand il n'y a pas de données et que je voudrais un cellule vide comme réponse, il m'indique un non.
Est-ce que vous auriez d'autres idées?
0
DevAxia Messages postés 34 Date d'inscription jeudi 25 juin 2015 Statut Membre Dernière intervention 18 novembre 2015 2 > Kary
6 juil. 2015 à 15:14
Pourtant l'exemple que je vous ai donné de mon côté fait exactement ce que vous me dites.. je pourrais vous joindre le fichier
0
Voici un exemple pour mes lignes de données. https://drive.google.com/file/d/0B67XbSI4HbzkeFFVUFo5SVpNVE0/view?usp=sharing
0
DevAxia Messages postés 34 Date d'inscription jeudi 25 juin 2015 Statut Membre Dernière intervention 18 novembre 2015 2
8 juil. 2015 à 04:38
Kary, si tu veux que je t'aide plus, va dans mon profil et écris moi ton adresse courriel en privé, je vais pouvoir regarder ton fichier directement.

Pat
0
Merci beaucoup :) J'ai réglé tout mes problèmes.
0
michel_m Messages postés 16578 Date d'inscription lundi 12 septembre 2005 Statut Contributeur Dernière intervention 28 septembre 2022 3 278
Modifié par michel_m le 6/07/2015 à 15:12
Bonjour
remplacer
=si (ou(estvide(AL15);estvide(AM15));"";SI(AL15.....etc

autre manière
=Si(NON(OU(ESTVIDE(AL15);ESTVIDE(AM151)));SI(AL15>AM15,"Oui","Non"),"")
ou encore
si(NBVAL(AL15:AM15)>1;SI(AL15>AM15,"Oui","Non"),"")

Michel
0
michel_m Messages postés 16578 Date d'inscription lundi 12 septembre 2005 Statut Contributeur Dernière intervention 28 septembre 2022 3 278
Modifié par michel_m le 6/07/2015 à 15:17
Excusez moi de vous avoir déranger
0
Kary > michel_m Messages postés 16578 Date d'inscription lundi 12 septembre 2005 Statut Contributeur Dernière intervention 28 septembre 2022
6 juil. 2015 à 15:29
Vous ne dérangez pas du tout. Vos deux formules marche parfaitement :)
Merci de votre aide :)
0
Merci :) C'est super!

J'essaie de faire la moyenne de ces données mais la formule que j'utilise semble considérer ces espaces blanc. Auriez-vous une idée comment la modifier?

=NB.SI(AL111:AL191;"oui")/NB.SI(AL111:AL191;"*")*100
0
Excel-worker Messages postés 589 Date d'inscription mardi 7 avril 2015 Statut Membre Dernière intervention 23 juillet 2015 58 > Kary
Modifié par Excel-worker le 6/07/2015 à 15:46
Ta formule est bonne, si tu as une case avec un oui dans la zone AL111:AL191.

Cela fera 1/1 * 100 = 100

Le résultat est exact, merci de préciser le résultat escompté.
0
Kary > Excel-worker Messages postés 589 Date d'inscription mardi 7 avril 2015 Statut Membre Dernière intervention 23 juillet 2015
6 juil. 2015 à 15:57
Ça ne fonctionne pas, il faudrait que je puisse mettre plusieurs critères (oui, non) dans la deuxième partie de la formule. Je crois que "*" considère les formules comme n'étant pas des espaces blancs. J'ai environ 30 oui et 16 non et ça me donne une moyenne de 29%. C'est sur que c'est pas ce que je recherche.
0