Passage qwerty vers azerty Centos 7 [Résolu/Fermé]

Signaler
-
Messages postés
29702
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
7 avril 2021
-
Bonjour à tous,

Je viens de télécharger une vm, virtualbox de centos 7.1, et j'ai un problème de conversion du clavier.

J'ai suivi quelques tutos sur internet mais rien n'a changé.

La vie était vraiment plus facile avant, il a fallu qu'ils compliquent les choses au lieu de les simplifier. Avec keyboard.conf tout était réglé.

BREF...

De ce que j'ai compris, il faut modifier le fichier /etc/locale.conf à l'aide de la commande localectl.

voici les commandes tapées:
localectl list-locales | grep fr
localectl set-locale LANG=fr_FR.utf8

voici le contenu des fichier de conf (copiés à la main parce que j'ai pas installé les vb tools)

/etc/locale.conf:
LANG=fr_FR.utf8

fichier /etc/X11/xorg.conf.d/00-keyboard.conf :
Section "InputClass"
Identifier "system-keyboard"
MatchIsKeyboard "on"
Option "XkbLayout" "fr"

fichier /etc/vconsole.conf:
KEYMAP=fr
FONT=latarcyrheb-sun16


Pourriez vous m'aider?

Merci d'avance à tous. j'ai vraiment besoin de cette modif pour continuer.



A voir également:

1 réponse

Messages postés
29702
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
7 avril 2021
7 066
Tu peux basculer en clavier français avec les commandes suivantes :
- En mode texte, depuis un terminal root :
loadkeys fr

- En mode graphique :
setxkbmap -layout fr


Pour configurer le "layout" de manière persistante, cela dépend de la distribution. En mode graphique ton interface graphique permet généralement de le régler facilement sans avoir à réfléchir à quel fichier modifier. En mode texte j'imagine que ceci répond à ton besoin :
https://www.centos.org/docs/5/html/5.1/Deployment_Guide/s2-sysconfig-kybd.html

Bonne chance
4
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
10
Date d'inscription
samedi 13 juin 2015
Statut
Membre
Dernière intervention
4 août 2015
>
Messages postés
29702
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
7 avril 2021

Salut à tous,

PROBLEME RESOLU...

Merci à toi mamiendo, j'ai suivi le forum du lien que tu as mis. C'est la partie la partie où on dit de désactiver selinux puis de lancer la commande system-config-keyboard.

-> en choisissant fr, j'ai le même problème que celui qui répond après,
-> par contre en choisissant latin-9 : miracle : azerty!!!!!!!

du coup en faisant un cat des fichiers de conf j'ai ceci :

keymaps automatiquement modifié à fr-latin9 ,
dans le fichier /etc/X11/xorg.conf.d/00-keyboard.conf on a 2 nouvelle lignes qui sont apparues :
-> Option "XkbModel" "pc-105"
-> Option "XkbVariant" "latin9"

Donc voilà... Merci à tous pour votre soutient!!
Messages postés
10
Date d'inscription
samedi 13 juin 2015
Statut
Membre
Dernière intervention
4 août 2015
>
Messages postés
10
Date d'inscription
samedi 13 juin 2015
Statut
Membre
Dernière intervention
4 août 2015

pfff, j'ai parlé un peu trop vite,

après un init 6, je me retrouve avec le clavier qwerty, mais les fichiers de conf sont restés intacts. je suis obligé de retaper system-config-keyboard et choisir latin-9 pour repasser en azerty.


Ce que j'avais oublé de metionner aussi c'est que lorsque je choisis l'option latin-9 j'ai en retour:
KDSKBENT : Invalid argument
failed to bind 41 to value 53277.

donc problème résolu à moitié, je dirais peut-être.
Messages postés
29702
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
7 avril 2021
7 066
Dans
/etc/X11/xorg.conf.d/00-keyboard.conf
tu ne peux pas configurer un layout français ?

Option "XkbLayout" "fr" 


Bonne chance
Messages postés
10
Date d'inscription
samedi 13 juin 2015
Statut
Membre
Dernière intervention
4 août 2015
>
Messages postés
29702
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
7 avril 2021

Salut,

l'option "XkbLayout" "fr" y est déjà. les options que j'ai indiqué dans mon précédent messages sont en plus de ce qu'il y avait déjà dont cette option.

En résumé:

cat /etc/X11/xorg.conf.d/00-keyboard.conf :
Section "InputClass"
Identifier "system-keyboard"
MatchIsKeyboard "on"
Option "XkbLayout" "fr"
Option "XkbModel" "pc-105"
Option "XkbVariant" "latin9"
Messages postés
29702
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
7 avril 2021
7 066
De toute façon normalement tu définis le layout en mode graphique à deux endroits, peu importe xorg :
- en configurant ton gestionnaire de connexion (gdm, kdm, lightdm...) via le panneau de configuration de ton interface graphique (requiert des droits root)
- en configurant une fois identifié l'agencement de clavier que tu souhaites privilégier (toujours via le panneau de configuration) (droits utilisateurs).