Fonction SI à plusieurs conditions avec inférieur et supérieur [Résolu/Fermé]

Signaler
-
 Camcam -
Bonjour,

Je rencontre quelques problèmes avec une formule Excel.

Je souhaiterai que :
- Si AA2 est inférieur à 1, alors 1
- Si AA2 est compris entre 1 et 5 inclus, alors 2
- Si AA2 est compris entre 6 et 10 inclus, alors 3
- Si AA2 est supérieur à 10, alors 4

Qu'est ce qui ne va pas dans ma formule ?

=SI(AA2<1;1;SI(ET(AA2>=1;AA2<=5);2;SI(ET(AA2<=6;AA2<=10);3;SI(AA2>10;4))))

Excel a l'air de bien vouloir fonctionner pour me sortir les 1 et le 4 mais c'est pour les 2 et 3 que cela ne marche pas...

Merci pour votre aide !!

1 réponse

Messages postés
12829
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
13 novembre 2020
2 062
Bonjour

Tu peux simplifier ta formule déjà :
=SI(AA2<1;1;SI(AA2<=5;2;SI(AA2<=10;3;4)))

Cdlmnt
Via
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60511 internautes nous ont dit merci ce mois-ci

Pourquoi faire compliqué quand on peut faire simple ?
Merci, c'est nickel !