Liste déroulante et fonction si

[Fermé]
Signaler
-
Messages postés
13114
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
14 octobre 2021
-
Bonjour,

J'aimerai faire un formule SI en fonction d'une liste déroulante. Je m'explique , il y a trois champs dans ma liste déroulante et en fonction du champ choisi, la note sera de 0, 5 ou 10.
Ma formule fonctionne sans mettre de liste déroulante mais plus quand je mets ma liste déroulante.

Savez-vous m'aider?
A voir également:

2 réponses

Messages postés
26226
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
15 octobre 2021
6 085
Bonjour
pouvez vous en dire plus,
qu'y a t'il dans la liste déroulante, dans quelle cellule?
vous voulez quels résutats et où?
à vous lire
crdlmnt
Bonjour,

La liste déroulante se situe en A1 et contient : pertinent, très pertinent et pas pertinent. En B1, j'ai ma formule si A1 "pertinent" alors 2,5, si A1 pas pertinent alors 0 et si A1 très pertinent alors 5. Cette formule fonctionne sans la liste déroulante mais pas avec...

Merci!
Messages postés
26226
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
15 octobre 2021
6 085
Re
si la formule ne fonctionne pas qu'avec la liste déroulante, c'est probablement que les textes ne sont pas inscrits rigoureusement de la même façon dans la formule et dans les références de la liste

plusieurs remèdes

le plus sur: remplacer dans la formule les textes par les adresses de cellules qui contiennent les mots de référence

sinon, soit copier les mots de référence et les coller dans la formule , ou l'inverse.

crdlmnt
.
Messages postés
13114
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
14 octobre 2021
2 261
Bonjour

Avec par exemple comme choix dans la liste déroulante en D1 : non fait, correct et parfait la formule :
=SI(D1="non fait";0;SI(D1="correct";5;SI(D1="parfait";10;"")))
renvoie bien les notes associés

Vérifier que les chaines sont identiques dans ta liste déroulante et dans ta formule (souvent un espace en plus, invisible au premier regard fait la différence)

Cdlmnt
Via

"L'imagination est plus importante que le savoir." A. Einstein