Somme.si quantité depuis une date [Résolu/Fermé]

Signaler
Messages postés
3
Date d'inscription
vendredi 27 février 2015
Statut
Membre
Dernière intervention
8 avril 2015
-
Messages postés
3
Date d'inscription
vendredi 27 février 2015
Statut
Membre
Dernière intervention
8 avril 2015
-
Bonsoir,
Je cherche à calculer le nombre de produit vendus depuis une date :
Ma base contient :
Colonne A - la plage des dates (jj/mm/aaaa)
Colonne B - Le nom de produit (ceinture, boucle, passant...)
Colonne C - La quantité du produit vendu à la date de la colonne A
Je souhaite faire ressortir le nombre de (ceinture par ex) vendues depuis le 10 octobre de l'année N.
COMMENT FAIRE???
Je sais faire : SOMME.SI($A$3:$A$40;">="&A16;$C$3:$C$40). Ce qui m'indique la somme de produits vendus depuis le 10 octobre.
SOMME.SI($B$3:$B$40;B3;$C$3:$C$12). La somme de ceintures vendues.
Mais comment faire pour calculer la somme de ceinture vendues depuis le 10 octobre????.
J'ai essayé somme.si et, sommeprod...
Bref, je suis arrivée à mon seuil de compétence. L'un de vous pourrait-il m'aider??
D'avance merci, et bonne nuit!!!

1 réponse

Messages postés
12795
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
29 octobre 2020
2 050
Bonjour

Depuis la version 2007 tu as justement la fonction SOMME.SI.ENS pour cela qui permet plusieurs critères
Attention sa syntaxe est inverse de celle de SOMME.SI il faut nommer la plage-somme en 1er, puis la plage du 1er critère et le 1ere critère, la plage du 2nd et le 2nd etc)
Ce qui dans ton cas devrait donner quelque chose comme :
=SOMME.SI.ENS($C$3:$C$40;$A$3:$A$40;">="&A16;$B$3:$B$40;"ceinture")

Mais tu peux aussi le faire avec SOMME PROD :
=SOMMEPROD(($A$3:$A$40>=A16)*($B$3:$B$40="ceinture")*($C$3:$C$40))

Cdlmnt
Messages postés
3
Date d'inscription
vendredi 27 février 2015
Statut
Membre
Dernière intervention
8 avril 2015

SUPER. J'avais essayé somme.si.ens mais en combinant mes deux premières écritures à la suite. Ça ne pouvait pas fonctionner... Bref, un grand merci.
Excellent week-end.