Erreur access denied for user 'root'@'localhost' (using password

Résolu/Fermé
animostab
Messages postés
2829
Date d'inscription
jeudi 10 mars 2005
Statut
Membre
Dernière intervention
11 novembre 2019
- 11 nov. 2014 à 16:09
animostab
Messages postés
2829
Date d'inscription
jeudi 10 mars 2005
Statut
Membre
Dernière intervention
11 novembre 2019
- 12 nov. 2014 à 18:07
Bonjour
je viens de changer de machine windows 8.1 et j'ai installé easyphp 14.1vc11 64 bits

j'ai donc importer ma base avec phpmyadmin pas de souci

avec ce code

<?php
$hote = '127.0.0.1';
$base = 'clownrobsql';
$user = 'root';
$pass = 'sql321';
$db = mysql_connect($hote, $user, $pass) or die (mysql_error ());
$ret = mysql_select_db($base, $db) or die ( 'echec de la connexion:' .mysql_error ());
?>


j'ai une erreur
Warning: mysql_connect(): Access denied for user 'root'@'localhost' (using password: YES) in C:\Users\michel vuillamy\Documents\clownphp\include\bdconnect.inc.php on line 6

impossible de me connecter a ma bdd (avec mysqli pareil c'est meme pire ca m'envoie vers un 404)

sans le mot de passe c'est la même erreur avec password : NO)

pourtant je suis allé dans phpmyadmin / clownrobsql / privilèges
root 127.0.0.1 mis le mot de passe "sql321"

si j'essaie de mettre les privilèges sans mot de passe je n'y arrive pas
ca se remet toujours avec le mot de passe

toutes pages de mon site en local avec include sans BDD fonctionnent parfaitement

ca m'a fait tourner en bourrique pendant 6 heures

j'ai l'impression que ca viens de phpmyadmin sql ou win 8

auriez vous une solution ?

3 réponses

animostab
Messages postés
2829
Date d'inscription
jeudi 10 mars 2005
Statut
Membre
Dernière intervention
11 novembre 2019
717
Modifié par animostab le 12/11/2014 à 15:39
Un petit up SVP merci

pour l'erreur 404 avec mysqli c'est normal (un script que j'avais fait qui envoie bouler si rien ne s'affiche issu de la BDD comme c'est de l'identation page-1, page-2 etc pour eviter les "page-1000")


Un petit merci vaut mieux qu'une grande ignorance !
Donc si votre sujet est résolu une réponse avec merci c'est pas de refus.
0
prosthetiks
Messages postés
1189
Date d'inscription
dimanche 7 octobre 2007
Statut
Membre
Dernière intervention
12 juin 2020
430
12 nov. 2014 à 16:43
Tu as essayé de passer par la console pour setter les privilèges/password ?
https://dev.mysql.com/doc/refman/8.0/en/grant.html
0
animostab
Messages postés
2829
Date d'inscription
jeudi 10 mars 2005
Statut
Membre
Dernière intervention
11 novembre 2019
717
12 nov. 2014 à 17:21
Si tu pouvais m'expliquer en détail je suis un noob en configuration de base de données et la le lien que tu me donnes m'embrouille plus qu'autre chose

0
prosthetiks
Messages postés
1189
Date d'inscription
dimanche 7 octobre 2007
Statut
Membre
Dernière intervention
12 juin 2020
430
12 nov. 2014 à 17:29
Je peux t'aider sur Skype d'ici 1 bonne heure, je suis en séance.
mon pseudo est le même qu'ici
0
animostab
Messages postés
2829
Date d'inscription
jeudi 10 mars 2005
Statut
Membre
Dernière intervention
11 novembre 2019
717
12 nov. 2014 à 17:37
ok j'install skype pa encore fait sur ma nouvelle machine
0
prosthetiks
Messages postés
1189
Date d'inscription
dimanche 7 octobre 2007
Statut
Membre
Dernière intervention
12 juin 2020
430
12 nov. 2014 à 17:37
Tu peux aussi installer team viewer au cas où, on en aura p-e besoin.
0
animostab
Messages postés
2829
Date d'inscription
jeudi 10 mars 2005
Statut
Membre
Dernière intervention
11 novembre 2019
717
12 nov. 2014 à 17:46
ok
0
animostab
Messages postés
2829
Date d'inscription
jeudi 10 mars 2005
Statut
Membre
Dernière intervention
11 novembre 2019
717
12 nov. 2014 à 18:07
c fait installé
0