Affichage d'une valeur en fonction de 3 ordres de priorité

Résolu/Fermé
tititoto77
Messages postés
4
Date d'inscription
mardi 4 novembre 2014
Statut
Membre
Dernière intervention
7 novembre 2014
- 4 nov. 2014 à 16:50
Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
- 7 nov. 2014 à 11:28
Bonjour,

Etant novice sur excel...je souhaiterai vous demander votre aide concernant cette problématique
En effet, j'aimerai afficher la cellule D mais selon des ordres de priorité comme voici

si A=12/01 , B="" , C="" , D=12/01
si A=12/01 , B=13/01 , C="" , D=13/01
si A=12/01 , B="" , C=14/01 , D=14/01
si A=12/01 , B=13/01 , C=14/01 , D=14/01


Pourriez vous m'aider?
merci d'avance..

3 réponses

Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 252
4 nov. 2014 à 17:45
Bonjour

En supposant vu le libellé que vos données sont des textes

votre tableau permet de placer une solution simple, mais elle ne correspond peut être pas à tous les cas de figure
Version simple donc:
=SI(C1="14/01";C1;SI(B1="13/01";B1;SI(A1="12/01";A1;"")))

et la solution tous cas de figures

=SI(ET(A1="12/01";B1="";C1="");"12/01";SI(ET(A1="12/01";B1="13/01";C1="");"13/01";SI(OU(ET(A1="12/01";B1="";C1="14/01");ET(A1="12/01";B1="13/01";C1="14/01"));14/01;"")))
0
Mike-31
Messages postés
17941
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
13 mai 2022
4 938
4 nov. 2014 à 17:50
Bonjour,

et pourquoi ne pas faire

=MAX(A2:C2)
et incrémenter vers le bas
0
Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 252
4 nov. 2014 à 18:08
Mike (salut l'ami)
je crois que sauf format spécial, il n'est pas possible d'afficher sur Excel une fraction du genre 14/01 (du moins restons franc, je ne sais pas faire)
j'en ai donc conclu que c'était du texte.
Bien amicalement
0
Mike-31
Messages postés
17941
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
13 mai 2022
4 938
4 nov. 2014 à 18:18
Salut Vaucluse,

Pour ma part j'ai interprété les données comme date 12/01 pour 12 janvier, parce qu'une fraction avec 01
mais peut être as tu raison ! enfin attendons le retour de tititoto
0
tititoto77
Messages postés
4
Date d'inscription
mardi 4 novembre 2014
Statut
Membre
Dernière intervention
7 novembre 2014

6 nov. 2014 à 14:30
Bonjour,

Je m'excuse pour le retard..j'ai essayé vos solutions et j'ai essayé de l'adapter à ma situation, ce qui a donné

=SI(ET(A1=DATE;B1="";C1="");"A1";SI(ET(A1=DATE;B1=DATE;C1="");B1;SI(OU(ET(A1=DATE;B1="";C1=DATE);ET(A1=DATE;B1=DATE;C1=DATE));C1;"")))

cependant cela ne fonctionne pas....de plus ce qu'il faut savoir est qu'il y a une rechercheV sur la cellule C1, la cellule affiche par defaut 00/01/00...donc mettre C1=DATE, je ne sais pas si c'est la bonne solution...

Pour la solution =MAX(A2:C2), cela marche bien cependant les date B1 ou C1 peuvent etre inférieur à A1, :s ce que je souhaite c'est vrai donner cette ordre de priorité ou
A1=valeur B1= "" C1=00/01/00 => D1 = A1
A1=valeur B1= valeur C1=00/01/00 => D1 = B1
A1=valeur B1= valeur C1=valeur => D1 = C1
A1="" B1 = "" C1= valeur => D1 = C1
0
Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 252
6 nov. 2014 à 14:48
Bonjour
Si C1 est 00/01/00 (c'est bien de tout savoir!!),ce n'est pas =C1 qu'il faut écrire, mais C1=0 car pour Excel ,cet affichage est le 0 en format date.
Par ailleurs à quoi correspond DATE que vous placez dans votre formule

crdlmnt
0
tititoto77
Messages postés
4
Date d'inscription
mardi 4 novembre 2014
Statut
Membre
Dernière intervention
7 novembre 2014

6 nov. 2014 à 15:51
Oui je m'excuse pour cette imprécision...pour l'écriture "Date", je voulais simplement spécifier, la présence d'une date quelconque..
0
Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 252
6 nov. 2014 à 17:43
Alors; excel ne prendra pas en considération une date si vous inscrivez par exemple:
=SI(A1=6/11/74;.... ect..
>Donc

soit vous placez la date dans une cellule hors champ, par exemple Z1 et vous écrivez:
=SI(A1=Z1;....etc

soit vous placez la valeur numérique qu'"Excel attribue à la date (à voir en formatant en format standard une cellule date
pour aujourd'hui par exemple 41949

ou encore vous écrivez dans la formule la date (pour aujourd'hui)
=SI(A1=DATE(2014;11;6);...etc

crdlmnt

crdlmnt
0
tititoto77
Messages postés
4
Date d'inscription
mardi 4 novembre 2014
Statut
Membre
Dernière intervention
7 novembre 2014

7 nov. 2014 à 11:07
Merci Vaucluse cela fonctionne!

J'ai copier les 3 colonnes en format date sur 3 autres colonnes en format standard, par la suite j'ai appliqué

La cellule $AA1 = $A1
La cellule $AB1 = $B1
La cellule $AC1 = $C1
La cellule $D1 = $AD1

Puis sur la cellule

AD1 = SI(ET(A1=AA1;AB1=0;AC1=0);AA1;SI(ET(A1=AA1;B1=AB1;AC1=0);AB1;SI(OU(ET(A1=AA1;AB1=0;C1=AC1);ET(A1=AA1;B1=AB1;C1=AC1));AC1;"")))

En tt cas, je voulais vous faire mes sincères remerciement pour votre précieuse aide!

Merci encore!!!
0
Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 252
7 nov. 2014 à 11:28
Ok pas de quoi
je passe le sujet en résolu
Bonne route
crdlmnt
0