Lien catégorie+valeur = affichage auto valeur sur autre feuille [Résolu/Fermé]

Signaler
Messages postés
2
Date d'inscription
mardi 28 octobre 2014
Statut
Membre
Dernière intervention
28 octobre 2014
-
Messages postés
2
Date d'inscription
mardi 28 octobre 2014
Statut
Membre
Dernière intervention
28 octobre 2014
-
Bonjour à tous,

Je rencontre des difficultés dans l'élaboration de mon tableau de trésorerie et j'aurais besoin de votre aide :

Mon classeur dispose de plusieurs feuilles :
1. LES FEUILLES "MOIS" : Les douze premières feuilles correspondent aux dépenses et recettes de chaque mois de l'année
2. LA FEUILLE "COMPTE" : La dernière feuille rassemble tous les frais de chaque mois répartis en catégories.

Mon problème :
Je voudrais qu'à chaque fois que je rentre une dépense dans les feuilles "MOIS", cette dépense s'affiche automatique dans la feuille "COMPTE", en respectant le mois et la catégorie correspondante...

J'espère être claire...
Pouvez-vous s'il vous plait me donner une formule me permettant d'exécuter cette fonction ?

Ci-joint, deux images des deux types de feuilles :



Merci beaucoup par avance pour votre aide !

3 réponses

Messages postés
13026
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
13 juin 2021
2 201
Bonjour

A condition que les feuilles soient nommées avec les noms des mois

En B6 du récap la formule
=SOMME.SI(INDIRECT(B$5 &"!C5:C100");$A6;INDIRECT(B$5 &"!D5:D100"))
Cdlmnt
Messages postés
26064
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
4 juin 2021
5 956
Bonjour
et que doit il se passer si vous avez plusieurs fois la catégorie en ligne dans les feuilles MOIS

S'il faut faire le cumul, vous avez une solution pour la feuille récapitulative
pour avoir une formule simple,
1°) nommer vos 12 feuilles avec le même nom (rigoureusement) que les titres de colonne mensuelle du récap (et sans blanc ni tiret dans le nom)

2°) entrez en B6 cette formule

=SOMME.SI(INDIRECT(B$5&"!C:C")$A6;INDIRECT(B$5&"!D:D"))

et s'il faut cumuler crédit et débit deux options:
==SOMME.SI(INDIRECT(B$5&"!C:C");$A6;INDIRECT(B$5&"!E:E"))-SOMME.SI(INDIRECT(B$5&"!C:C");$A6;INDIRECT(B$5&"!D:D"))

ou

=SOMMEPROD((INDIRECT(B$5&"!C5:C500")=$A6)*(INDIRECT(B$5"!E5:E500")-INDIRECT(B$5&"!D5:D500")))


respectez bien tous les signes
tirez la formule dans tout le tableau
Elle donnera les débits en négatifs.

Note: le code SOMMEPROD exige que les champs soient indiqués avec les N° de lignes (d'ou le 5 et le 500)

Bien entendu, il faut que les rubriques en C des feuilles mois soient inscrites de la même façon que la feuille récapitulative
Pour cela, vous pouvez placer un menu déroulant en C, basé sur la liste A6:A17 du récap, champ qu'il faudra nommer pour placer la validation.

crdlmnt



=

Errare humanum est, perseverare diabolicum
Messages postés
2
Date d'inscription
mardi 28 octobre 2014
Statut
Membre
Dernière intervention
28 octobre 2014

Merci beaucoup beaucoup beaucoup !! Ca fonctionne parfaitement et grâce à vous je vais pouvoir utiliser mon tableau de façon optimale !

Merci encore !