Problème de dépendances dpkg...

Résolu/Fermé
Ubuntunien Messages postés 436 Date d'inscription mardi 26 février 2013 Statut Membre Dernière intervention 4 mars 2019 - 12 oct. 2014 à 15:44
Ubuntunien Messages postés 436 Date d'inscription mardi 26 février 2013 Statut Membre Dernière intervention 4 mars 2019 - 18 oct. 2014 à 15:26
Bonjour,

Ex-Ubuntunien, j'étais encore hier sous windows, et ça faisait un bon moment que je voulais remettre GNU/Linux sur mon vieux... Non, très vieux coucou, un Continental Edison dont on a changé la carte mère, avec son AMD Duron de 945 Mhz si j'en crois mon écran de boot (N'oublions pas ses 250 Mégas de RAM ! ). J'ai le PC le moins puissant du monde. Enfin bref, je viens d'installer Debian 7.6.0 et j'ai comme un problème internet. Je dispose d'une clé USB Wi-Fi toute neuve achetée sur ebay, avec ses drivers et tout et tout. Seulement, difficile d'installer des pilotes windows sur Linux, donc je cherche sur Internet et je trouve un paquet, ndiswrapper, qui me permettrait de réaliser ceci ! Mais comment installer un paquet .deb sans connexion internet, me disais-je ? Par la console bien sûr !

Alors, j'ouvre le Terminal, je me met en tant que root et j'entre :

dpkg -i ndiswrapper-utils-1.9_1.57-1_i386.deb ( Paquet que j'ai téléchargé via un autre PC).

Et là... C'est le drame : Il me signale un problème de dépendances qui empêche sa configuration.

Quelqu'un pourrait m'aider S.V.P. ? C'est urgent, j'ai besoin de cet ordinateur rapidement !

2 réponses

Flachy Joe Messages postés 2103 Date d'inscription jeudi 16 septembre 2004 Statut Membre Dernière intervention 21 novembre 2023 260
Modifié par Flachy Joe le 12/10/2014 à 16:01
Salut,
Tu peux te référer à cette doc, qui est valable pour debian aussi
http://doc.ubuntu-fr.org/tutoriel/comment_ajouter_des_paquets_sans_internet

Sinon tu peux aussi regarder les dépendances de ton paquet sur https://packages.debian.org/wheezy/ndiswrapper-utils-1.9
et les dépendances des dépendances, etc...
Pour télécharger tout ce dont tu as besoin.
;-) Flachy Joe ;-)
Ubuntunien Messages postés 436 Date d'inscription mardi 26 février 2013 Statut Membre Dernière intervention 4 mars 2019 26
12 oct. 2014 à 16:14
Et je dois télécharger les dépendances de dpkg où ? Je crois que ce sont les dépendances de dpkg qu'il manque. Merci d'avoir répondu si vite :)
0
zipe31 Messages postés 36402 Date d'inscription dimanche 7 novembre 2010 Statut Contributeur Dernière intervention 27 janvier 2021 6 412
12 oct. 2014 à 16:19
Salut,

Et si tu commençais par nous donner les références exactes de ta clé wifi ?
Ubuntunien Messages postés 436 Date d'inscription mardi 26 février 2013 Statut Membre Dernière intervention 4 mars 2019 26
12 oct. 2014 à 16:27
Salut, alors attends, je vais chercher après mon emballage ;)
0
Ubuntunien Messages postés 436 Date d'inscription mardi 26 février 2013 Statut Membre Dernière intervention 4 mars 2019 26
12 oct. 2014 à 16:42
Sur l'emballage, il y a juste marqué : USB 2.0 WIRELESS 802.IIN
Donc j'ai été regardé dans les paramètres sur mon PC avec Win 8 et j'ai trouvé ça :
USB\VID_148F&PID_7601&REV_0000
USB\VID_148F&PID_7601
Cela te suffit ?
0
zipe31 Messages postés 36402 Date d'inscription dimanche 7 novembre 2010 Statut Contributeur Dernière intervention 27 janvier 2021 6 412
12 oct. 2014 à 16:53
Tiens, suis ces instructions pour installer ta clé :
http://ubuntuforums.org/showthread.php?t=2206873&s=329ec334543527db43b4156e73b53940&p=12936176#post12936176
0
Ubuntunien Messages postés 436 Date d'inscription mardi 26 février 2013 Statut Membre Dernière intervention 4 mars 2019 26
12 oct. 2014 à 17:06
Et non... Cela ne marche pas. J'ai essayé de remplacer sudo par apt-get et d'arranger un peu les commandes, rien n'y fait. Déjà, il ne sait pas ce qu'est sudo, mon terminal. La première commande ne fonctionne pas non plus, il me dis qu'il ne trouve pas les 2 paquets.

Et aucune autre commande ne fonctionne (il ne les connaît pas, sauf modprobe, mais là il me dit qu'il ne trouve pas le module mt7601Usta).
0
zipe31 Messages postés 36402 Date d'inscription dimanche 7 novembre 2010 Statut Contributeur Dernière intervention 27 janvier 2021 6 412
12 oct. 2014 à 17:13
Déjà il faut que le PC soit connecté en filiaire (RJ45).
Ensuite effectivement, sudo n'est pas installé nativement sous Debian.
Donc, il suffit de passer en root :
su - <Entrée>
mot de passe root


Puis de taper les commandes suivantes :
apt-get update
apt-get upgrade


Puis on enchaîne avec :
apt-get install --reinstall linux-headers-generic build-essential


Tu télécharges le paquet à https://www.mediatek.com/products/broadbandWifi/mt7601
Tu l'extrais comme suggéré dans le tuto, puis tu suis le reste du tutorial.
0