Erreur ISPConfig : création de nouveau site impossible

Bonsoir,

Je vais vous présenter rapidement mon problème :
J'essaye de créer un nouveau site avec ispconfig mais le site n'est pas accessible, et le répertoire du site (/var/www/clients/client0/webX) n'est pas créé.
J'ai déjà créé un premier site qui lui fonctionne.

Je vous c/c mes derniers logs d'erreur d'apache si ça peut vous être utile :

[Tue Jun 17 14:15:15 2014] [notice] caught SIGTERM, shutting down
Failed loading /usr/lib/php5/20100525/xcache.so: /usr/lib/php5/20100525/xcache.so: cannot open shared object file: No such file or directory
[Tue Jun 17 14:15:18 2014] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Tue Jun 17 14:15:18 2014] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
[Tue Jun 17 14:15:18 2014] [notice] Digest: generating secret for digest authentication ...
[Tue Jun 17 14:15:18 2014] [notice] Digest: done
[Tue Jun 17 14:15:18 2014] [error] python_init: Python version mismatch, expected '2.7.2+', found '2.7.3'.
[Tue Jun 17 14:15:18 2014] [error] python_init: Python executable found '/usr/bin/python'.
[Tue Jun 17 14:15:18 2014] [error] python_init: Python path being used '/usr/lib/python2.7/:/usr/lib/python2.7/plat-linux2:/usr/lib/python2.7/lib-tk:/usr/lib/python2.7/lib-old:/usr/lib/python2.7/lib-dynload'.
[Tue Jun 17 14:15:18 2014] [notice] mod_python: Creating 8 session mutexes based on 10 max processes and 0 max threads.
[Tue Jun 17 14:15:18 2014] [notice] mod_python: using mutex_directory /tmp
[Tue Jun 17 14:15:19 2014] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Tue Jun 17 14:15:19 2014] [notice] Apache/2.2.22 (Debian) DAV/2 mod_fcgid/2.3.6 PHP/5.5.12-1~dotdeb.1 mod_python/3.3.1 Python/2.7.3 mod_ssl/2.2.22 OpenSSL/1.0.1e configured -- resuming normal operations
Failed loading /usr/lib/php5/20100525/xcache.so: /usr/lib/php5/20100525/xcache.so: cannot open shared object file: No such file or directory
Failed loading /usr/lib/php5/20100525/xcache.so: /usr/lib/php5/20100525/xcache.so: cannot open shared object file: No such file or directory
Failed loading /usr/lib/php5/20100525/xcache.so: /usr/lib/php5/20100525/xcache.so: cannot open shared object file: No such file or directory
Failed loading /usr/lib/php5/20100525/xcache.so: /usr/lib/php5/20100525/xcache.so: cannot open shared object file: No such file or directory
Failed loading /usr/lib/php5/20100525/xcache.so: /usr/lib/php5/20100525/xcache.so: cannot open shared object file: No such file or directory
Failed loading /usr/lib/php5/20100525/xcache.so: /usr/lib/php5/20100525/xcache.so: cannot open shared object file: No such file or directory

Merci si vous m'apporter vos lumières !

8 réponses

  1. Contributeur
    As tu installe xcache récemment ?
    Sur les logs, il n'a pas l'air en grande forme..
    0
    1. Normalement il est correctement installer, je vais retenter de l'installer pour voir si ça fait quelque chose ^^
      0
      1. Je vois le problème, le script va chercher xcache au mauvais endroit car il n'est pas dans le dossier 20100525 mais dans le dossier 20121212
        Comment puis-je corriger ça, sachant que toutes les extensions php se trouvent dans "20121212" ?
        0
        1. Contributeur
          C'est quoi comme OS et chez quel prestataire ?
          0
          1. C'est Debian 7, chez pulseheberg
            0
            1. Le problème avec xcache est résolu, mais ispconfig ne crée toujours pas le répertoire du site
              0
              1. Bien sûr que je l'ai ai suivies ^^
                En réalité j'ai réussi à créer une fois un site, il y a environ 2 semaines je pense.
                Ce site en question fonctionne et est accessible .
                Mais ISPConfig ne veut pas créer de nouveau site, et aucune erreur ne s'affiche lors de la création, tout se déroule normalement, et lorsque que je parcours les dossier d'ispconfig je ne trouve pas le répertoire du site fraîchement crée, je trouve seulement celui du premier.
                0
            2. Contributeur
              As tu crée un utilisateur par site ?
              Tes dossiers ont ils les bons droits ?
              0
              1. > Un utilisateur par site ? on ne peut pas avoir plusieurs sites par user ispconfig ?
                > Mon dossier www ainsi que ses sous-dossiers son tous en 777
                0
                1. J'ai tout suivi, et réinstallé ispconfig deux fois ...
                  j'ai tout mis en 777 provisoirement, car cette histoire m'énervait. Quels droit dois-je plutôt mettre ?
                  0
                2. Contributeur
                  Chmod 755 sur les dossiers
                  Chmod 644 sur les fichiers
                  Chmod 400 sur certains php de config (cf doc cms)

                  --
                  0
                3. ok, merci ^_^
                  Par contre ispconfig ne marche toujours pas :/
                  0