Page index d'un site wordpress introuvable [Résolu/Fermé]

Signaler
-
 chisato -
Bonjour,


Je travaille sur un site wordpress, je cherche à faire des modifications sur la première page de mon site qui apparaît lorsque je saisis l'url (donc la page index.php) mais je ne trouve pas son fichier dans le répertoire de mon thème (et même dans les autres répertoires), aucun fichier ne correspond à elle.

Je ne comprends où elle est donc passée, pouvez-vous m'aider svp ?

Merci.


2 réponses

Messages postés
23004
Date d'inscription
samedi 22 octobre 2005
Statut
Modérateur
Dernière intervention
14 octobre 2020
2 120
cette page n'est pas dans le thème installé, mais générée par WP ;)
Merci pour votre réponse.
Oui, mais comment je peux la récupérer ?
Messages postés
1811
Date d'inscription
vendredi 28 janvier 2011
Statut
Membre
Dernière intervention
31 décembre 2018
255
Bonsoir,

En fait il est plus pratique d'avoir une page index dans ton theme WP. Meme s'il elle n'est pas indispensable car WP te permet de designer une page comme page d'accueil, elle évite dans la configuration initiale d'avoir une page blanche a la connexion.

l'index.php d'un theme contient l'affichage par default de la page d'accueil quand le theme est activé, avant toute config dans wordpress. En général on y trouve la loop des post.

Pour t'en créer une il suffit de créer un fichier index.php à la racine de ton theme, et de mettre en tete de code
<?php
/**
 * Description: Default Index template
 */
get_header(); ?>


et en bas de code

<?php get_footer(); ?>


entre les 2 tu integres ton code HTML / PHP

Tu peux tout simplement copier le index.php d'un des themes fournis avec wordpress. L'affichage sera un peu foireux car le CSS / HTML ne sera pas en accord avec ton theme, mais ca te donne une base

Voila voila
Ecrit et assumé par Inspiring - copyright 2009-2013
Merci bcp pour votre éclaircissement, cependant le problème n'est toujours pas résolu : La page index.php existe bien à la racine de mon thème mais ce n'est pas elle qui s'affiche lorsque je saisis l'url de mon site, c'est une toute autre page que je ne trouve pas !
Messages postés
1811
Date d'inscription
vendredi 28 janvier 2011
Statut
Membre
Dernière intervention
31 décembre 2018
255
Voir dans ce cas au niveau du tableau de bord > reglages > lecture si une page précise n'a pas été définie comme page d'accueil.

Si non, le probleme est ailleurs et là je n'ai pas assez d'éléments pour apporter une réponse
Oui, j'ai déjà vu ça mais ça n'a pas aidé.
Mais j'ai résolu maintenant le problème, le fichier que je cherchais s'appelais "splash.html". Il est directement situé sous la racine.
Merci en tout cas !