Formule excel de soustraction selon condition

[Résolu/Fermé]
Signaler
Messages postés
5
Date d'inscription
jeudi 6 mars 2014
Statut
Membre
Dernière intervention
6 mars 2014
-
Messages postés
26209
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
3 octobre 2021
-
Bonsoir à tous,

Cela fait 5h que je test tout sans réussir à régler ce problème de soustraction sous condition.

Je souhaite comparer d'une année sur l'autre l'évolution en euros du montant de mes achats chez mes fournisseurs.

J'ai ainsi la colonne A et B pour 2012 et la colonne C et D pour 2013 et en E l'évolution 2013

A B C D E
2012 2012 2013 2013 2013
Nom du fournisseur Montant Nom du fournisseur Montant Evolution
Fournisseur1 100 Fournisseur2 200 -200
Fournisseur2 400 Fournisseur5 150 aucune

Je cherche à soustraire les valeurs des colonnes B et D soit B-D avec comme lien le nom des fournisseurs des colonnes A et C. Dans cet exemple le seul fournisseur de la colonne C présent dans la colonne A est Fournisseur2, mais pas toujours sur la même ligne (un fournisseur de 2013 n'est pas forcément fournisseur en 2012).

Avec un =Somme.Si(A:A;C1...) ou un =NB.SI(A:A;C1) je peux établir le lien sur le nom du fournisseur. Mais comment ensuite calculer E par la soustraction la colonne B-D ? Dans l'exemple 400-200 par le lien sur la valeur Fournisseur2, mais en ligne 1 et 2.

Merci de votre aide précieuse.

2 réponses

Messages postés
54768
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
3 octobre 2021
16 652
Bonjour.

Un fichier Excel avec un exemple chiffré aurait été plus pratique que la série de données que tu as essayé de taper dans ton message ...
Va dans https://www.cjoint.com/ pour créer le lien, que tu reviendras coller ici.

Est-ce que chaque fournisseur n'apparait qu'une seul fois dans chaque colonne ?

En attendant je te propose cette méthode, qui utilise ta fonction SOMME.SI :
Formule à saisir dans E3 et à recopier vers le bas
=SOMME.SI($C:$C;C3;$D:$D)-SOMME.SI($A:$A;C3;$B:$B)
Messages postés
5
Date d'inscription
jeudi 6 mars 2014
Statut
Membre
Dernière intervention
6 mars 2014

Bonjour Raymond,

Merci infiniment de tes conseils ! Chaque fournisseur n'apparaît qu'une seule fois dans chaque colonne. Voici le lien :

https://www.cjoint.com/?DCgqcvC5rgg

Avec mes remerciements :-)
Messages postés
26209
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
3 octobre 2021
6 075
Bonjour
et pourtant ça à l'air de fonctionner
la formule en I5 donne -409,75 ce qui correspond bien à Alessi soit G5 -C6 pour les colonnes ht?
vérifié aussi en I8 pour Are+WHY
Alors qu'attendez vous de la formule?
crdlmnt
Messages postés
5
Date d'inscription
jeudi 6 mars 2014
Statut
Membre
Dernière intervention
6 mars 2014

Merci de vôtre aide Vaucluse, mais bizarre, quand je mets =SOMME.SI($E:$E;E6;$G:$G)-SOMME.SI($A:$A;E6;$C:$C) dans I5 j'ai -17050,74 et effectivement je veux votre résultat :-((
Bien à vous
Messages postés
26209
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
3 octobre 2021
6 075
Ben tiens, si vous mettez dans I5 une somme basée sur E6, vous aurez le résulltat qui correspond au nom écrit en E6 pas celui de E5
Messages postés
5
Date d'inscription
jeudi 6 mars 2014
Statut
Membre
Dernière intervention
6 mars 2014

merci beaucoup de votre aide vaucluse, je suis nul :-((, j'ai honte... Un grand merci à vous et Raymond
Messages postés
26209
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
3 octobre 2021
6 075
"Errare humanum est" 
comme dit ma signature!
Bonne route
je passe le sujet en résolu
crdlmnt