Recherchev Sur Plusieurs Colonnes

Résolu/Fermé
tictac847
Messages postés
26
Date d'inscription
mercredi 5 octobre 2011
Statut
Membre
Dernière intervention
24 décembre 2013
- 24 déc. 2013 à 11:24
tictac847
Messages postés
26
Date d'inscription
mercredi 5 octobre 2011
Statut
Membre
Dernière intervention
24 décembre 2013
- 24 déc. 2013 à 17:24
Bonjour,

Voici mon problème:
J'ai dans mon fichier des feuilles de suivi de factures pour chaque mois de l'années et une feuille de paiement pour retracer tous les paiements effectuer.

Dans la feuilles de paiement, chaque paiement peut couvrir jusqu'a 6 factures.
Dans les feuilles mensuel, j'ai une cellule reference paiement dans laquelles j'ai mis une recherchev sur 20 colonnes qui va chercher la reference de la facture et ramener la reference du paiement.

Pour remplir, les references de facturation j'ai utiliser 2 validation de donnée.
La 1ere pour les mois et la Deuxieme est un indirect() qui va chercher les valeur par rapport au mois sélectionner lors de la 1ere validation.

Mon problème est que j'obtiens une erreur dans la cellules recherechev()

je vous joint un fichier pour plus de clarté.
https://www.cjoint.com/c/CLylxsC2r4T

Merci



A voir également:

4 réponses

michel_m
Messages postés
16577
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
22 août 2022
3 278
Modifié par michel_m le 24/12/2013 à 12:04
Bonjour,

Pas trop compris ce que tu voulais faire

mais peut-^tre
=SI(NB.SI(Table56436[Facture A];$D8)=0;"N°inconnu";INDEX(Table56436;EQUIV($D8;Table56436[Facture A];0);1))

nota= rechercheV, la valeur de référence doit être la + à gauche du tableau... sinon il faut imbriquer la fonction EQUIV dans la fonction INDEX et vérifier la présence de la ref.

Michel
1