Recherchev Sur Plusieurs Colonnes

[Résolu/Fermé]
Signaler
Messages postés
26
Date d'inscription
mercredi 5 octobre 2011
Statut
Membre
Dernière intervention
24 décembre 2013
-
Messages postés
26
Date d'inscription
mercredi 5 octobre 2011
Statut
Membre
Dernière intervention
24 décembre 2013
-
Bonjour,

Voici mon problème:
J'ai dans mon fichier des feuilles de suivi de factures pour chaque mois de l'années et une feuille de paiement pour retracer tous les paiements effectuer.

Dans la feuilles de paiement, chaque paiement peut couvrir jusqu'a 6 factures.
Dans les feuilles mensuel, j'ai une cellule reference paiement dans laquelles j'ai mis une recherchev sur 20 colonnes qui va chercher la reference de la facture et ramener la reference du paiement.

Pour remplir, les references de facturation j'ai utiliser 2 validation de donnée.
La 1ere pour les mois et la Deuxieme est un indirect() qui va chercher les valeur par rapport au mois sélectionner lors de la 1ere validation.

Mon problème est que j'obtiens une erreur dans la cellules recherechev()

je vous joint un fichier pour plus de clarté.
https://www.cjoint.com/c/CLylxsC2r4T

Merci



A voir également:

4 réponses

Messages postés
16523
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
28 septembre 2021
3 228
Bonjour,

Pas trop compris ce que tu voulais faire

mais peut-^tre
=SI(NB.SI(Table56436[Facture A];$D8)=0;"N°inconnu";INDEX(Table56436;EQUIV($D8;Table56436[Facture A];0);1))

nota= rechercheV, la valeur de référence doit être la + à gauche du tableau... sinon il faut imbriquer la fonction EQUIV dans la fonction INDEX et vérifier la présence de la ref.

Michel
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41713 internautes nous ont dit merci ce mois-ci

Messages postés
3529
Date d'inscription
jeudi 6 août 2009
Statut
Membre
Dernière intervention
24 juin 2021
1 970
Bonjour, ce sujet m'intéresse, je voudrais aussi qu'une recherchev recherche dans plusieurs colonnes. Si tu as une solution proposée, fais-moi signe!

Bonnes fêtes
Messages postés
26
Date d'inscription
mercredi 5 octobre 2011
Statut
Membre
Dernière intervention
24 décembre 2013

Ca marche, tyranausor.
Des que j'en sais plus je te fais signe.

Bonnes fêtes à toi aussi.
Messages postés
26
Date d'inscription
mercredi 5 octobre 2011
Statut
Membre
Dernière intervention
24 décembre 2013

Bonjour Michel,

Ca marche, c'est exactement ce que je cherchais à faire.

Merci pour ton aide.

Tyranosaur, c'est claire pour toi aussi?
Messages postés
26
Date d'inscription
mercredi 5 octobre 2011
Statut
Membre
Dernière intervention
24 décembre 2013

Oups, j'ai parler trop vite.

Ca marche seulement pour la 1ere colonne. c'est a dire la facture A.
J'ai besoin que ca marche même lorsque j'insère les données dans les facture B C D E et F
Messages postés
13112
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
14 octobre 2021
2 260
Bonjour tictac

Il faut bâtir une formule à partir de celle de Michel, qui englobe tous les cas :
=SIERREUR(INDEX(Table56436;EQUIV($D8;Table56436[Facture A];0);1);SIERREUR(INDEX(Table56436;EQUIV($D8;Table56436[Facture B];0);1); etc .... et en terminant par ;"n° inconnu" et en fermant autant de parenthèses que d'ouvertes

Cdlmnt
Messages postés
26
Date d'inscription
mercredi 5 octobre 2011
Statut
Membre
Dernière intervention
24 décembre 2013

Bonjour via55;

Ca marche nickel.

Merci et bonnes fêtes.