Comparer 2 colonnes Excel [Résolu/Fermé]

Signaler
Messages postés
526
Date d'inscription
mardi 11 mai 2010
Statut
Membre
Dernière intervention
16 février 2019
-
Messages postés
5476
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
18 mai 2020
-
Bonjour,

J'ai 2 feuilles contenant des numéros de SIREN, dans l'une j'en ai 3000, dans l'autre 800.

Je voudrais comparer les 2 feuilles pour connaitre les numéros de SIREN communs aux 2 fichiers.

J'ai copié les numéros de SIREN (triés du plus petit au plus grand) dans une nouvelle feuille
Fichier 1 en A
Fichier 2 en B
Comparaison en C

La formule
=SI(A2=B2; OK; "")

ne fonctionne pas. De plus si j'ai un décalage ça s'arrêtera de fonctionner.

Avez vous une meilleure technique (type RECHERCHEV je pense)

Merci


2 réponses

Messages postés
526
Date d'inscription
mardi 11 mai 2010
Statut
Membre
Dernière intervention
16 février 2019
48
C'est bon j'ai résolu mon pb en utilisant RECHERCHEV

=RECHERCHEV([@[N° SIREN2]]; [N° SIREN];1; FAUX)

Messages postés
5476
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
18 mai 2020
437
Bonjour

Le code ne sont pas obligatoirement sur la même ligne donc

=SI(NB.SI($A$1:$A$30;B1)>=1;1;0)

compare si le code en colonne B se trouve en colonne A
si oui met 1 si non met 0