Mes cellules ne se valident pas sauf par un double clic [Résolu/Fermé]

Signaler
Messages postés
4
Date d'inscription
lundi 23 septembre 2013
Statut
Membre
Dernière intervention
23 septembre 2013
-
Messages postés
4
Date d'inscription
lundi 23 septembre 2013
Statut
Membre
Dernière intervention
23 septembre 2013
-
Bonjour,


Je rencontre un problème pour valider les cellules de mon fichier excel, je suis obligée de faire un double clic et entrée (le chiffre de ma cellule passe alors de gauche vers la droite) malgré que le calcul automatique soit bien activé et au format nombre . J'ai fait plus recherche sur internet mais aucunes solutions.

J'espère que vous allez pouvoir m'aider.

Cdlt

4 réponses

Messages postés
25998
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
2 mai 2021
5 906
Re
voyez dans les options avancés, je pense que le séparateur de décimales ne doit pas être la virgule, car tout fonctionne lorsqu'on entre un nombre sans décimale.
Option avancées / Utiliser (ou non ) les séparateurs système
voyez si la virgule est le séparateur, sinon modifiez la en décochant la case "utiliser... ou alors , écrivez vos nombres avec le séparateur sélectionné.
Crdlmnt .

3
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
4
Date d'inscription
lundi 23 septembre 2013
Statut
Membre
Dernière intervention
23 septembre 2013

Impeccable!!! cela fonctionne avec la manipulation du copier coller addition. Merci pour votre aide.

cordialement
Messages postés
25998
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
2 mai 2021
5 906
Bonjour
vérifier ceci ci dessous à tout hasard et sinon, mettez sur http//:www.cjoint.com un modèle de votre problème.
A vérifier:
Dans les options Exccel, (Options avancées) décochez si besoin:
"Étendre les formules et format aux plages de données"
A + Crdlmnt


Messages postés
4
Date d'inscription
lundi 23 septembre 2013
Statut
Membre
Dernière intervention
23 septembre 2013

Rien ne change en décochant cette option.

Ci joint un extrait du fichier.

https://www.cjoint.com/?3Ixm27F84tV
Messages postés
4
Date d'inscription
lundi 23 septembre 2013
Statut
Membre
Dernière intervention
23 septembre 2013

cela n'y change rien, le problème est toujours la
Messages postés
25998
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
2 mai 2021
5 906
Et pourtant quand je prend votre fichier, les sommes ne donnent que des 0, mais lorsque je vais dans les options:
je décoche "utiliser les séparateurs système"
je place la virgule dans "Séparateur de décimale"

Et là ça fonctionne, mais à condition de retaper les valeurs qui sinon restent du texte!

Si vous ne voulez pas retaper les valeurs après la manip séparateur:
copier une cellule vide
sélectionnez le champ des valeurs et clic droit / collage spécial / Addition.

crdlmnt
Messages postés
25998
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
2 mai 2021
5 906
PS attention vos valeurs en C17 et C18 comportent un blanc entre le 1 et le 9 qui correspond ^peut être à un séparateur de millier.
Même punition avec l'option séparateur ou, dans le clic droit / format /nombre décocher "utiliser le séparateur de millier)
Retaper les nombres ou supprimez les blancs/(le collage, là, ne fonctionne pas)
Votre fichier modifié:
https://www.cjoint.com/?CIxo2zHkEcT
crdlmnt