EXCEL Faire le calcul si case non vide [Résolu/Fermé]

Signaler
Messages postés
5
Date d'inscription
dimanche 17 novembre 2013
Statut
Membre
Dernière intervention
17 novembre 2013
-
 xx -
Bonjour,

Je souhaiterai faire la soustraction de deux dates seulement si les cellules sont non vide.
Si une cellule est vide je souhaiterai obtenir une cellule vide en resultat.

La formule que j utilise est =NB.JOURS.OUVRES(A1;A2)

Exemple en A1 jai le 03/10/13 en A2 j'ai le 05/10/13 en A3 j'obtient 2.
Si en A1 j'ai 03/10/13 mais qu en A2 je n'ai pas de date je souhaiterai avoir une cellule vide.

Merci par avance de vos réponses.

3 réponses

Messages postés
5513
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
29 septembre 2020
488
Bonjour

une solution

=SI(OU(A1="";A2="");"";NB.JOURS.OUVRES(A1;A2)) 


5
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60769 internautes nous ont dit merci ce mois-ci

Messages postés
5513
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
29 septembre 2020
488
La sera toujours un A
Il sera toujours à la fin
sera-t-il en A1 et en B1
Messages postés
5
Date d'inscription
dimanche 17 novembre 2013
Statut
Membre
Dernière intervention
17 novembre 2013

En fait je cherche un moyen d'integrer la date dans la cellule mais que le calcul ne se fasse pas comme si la case ete vide.
Messages postés
5513
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
29 septembre 2020
488
avec contrôle des lettres majuscules de A à Z et minuscules de a à z en A1 et A2

=SI(OU(ET(CODE(DROITE(A2;1))>=65;CODE(DROITE(A2;1))<=90);ET(CODE(DROITE(A2;1))>=97;CODE(DROITE(A2;1))<=122));"";SI(OU(ET(CODE(DROITE(A1;1))>=65;CODE(DROITE(A1;1))<=90);ET(CODE(DROITE(A1;1))>=97;CODE(DROITE(A1;1))<=122));"";NB.JOURS.OUVRES(A1;A2)))
Messages postés
5
Date d'inscription
dimanche 17 novembre 2013
Statut
Membre
Dernière intervention
17 novembre 2013

Merci beaucoup pour toutes tes explications.

Bonne soirée.
merci d'avoir partagé pour éviter une perte de temps .. !!
Messages postés
12723
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
30 septembre 2020
2 028
Bonjour

=si(A2="";"";NB.JOURS.OUVRES(A1;A2) )


Cdlmnt

Bonjour,
Ta formule sera du genre :
=si(or(IsEmpty(A1);IsEmpty(A2));taFormule)

ou encore :
=si(or(IsEmpty(A1);IsEmpty(A2));taFormule;"")

Attention aux parenthèses!!!