EXCEL Faire le calcul si case non vide

Résolu/Fermé
TITI66MATH Messages postés 5 Date d'inscription dimanche 17 novembre 2013 Statut Membre Dernière intervention 17 novembre 2013 - 17 nov. 2013 à 15:49
 xx - 30 mars 2017 à 14:34
Bonjour,

Je souhaiterai faire la soustraction de deux dates seulement si les cellules sont non vide.
Si une cellule est vide je souhaiterai obtenir une cellule vide en resultat.

La formule que j utilise est =NB.JOURS.OUVRES(A1;A2)

Exemple en A1 jai le 03/10/13 en A2 j'ai le 05/10/13 en A3 j'obtient 2.
Si en A1 j'ai 03/10/13 mais qu en A2 je n'ai pas de date je souhaiterai avoir une cellule vide.

Merci par avance de vos réponses.
A voir également:

3 réponses

PHILOU10120 Messages postés 6374 Date d'inscription lundi 16 avril 2012 Statut Contributeur Dernière intervention 28 mai 2024 801
Modifié le 13 déc. 2018 à 10:54
Bonjour

une solution

=SI(OU(A1="";A2="");"";NB.JOURS.OUVRES(A1;A2)) 


6
TITI66MATH Messages postés 5 Date d'inscription dimanche 17 novembre 2013 Statut Membre Dernière intervention 17 novembre 2013
17 nov. 2013 à 16:15
Merci beaucoup.
Ta formule marche nickel.

Par contre je souhaiterai aussi que le calcul ne se fasse pas si la date contient la lettre A

Exemple: en A1 j ai 10/12/13 et en B1 j'ai 12/12/13A. Je voudrai avoir comme resultat en C1 une case vide.

Merci.
0
TITI66MATH Messages postés 5 Date d'inscription dimanche 17 novembre 2013 Statut Membre Dernière intervention 17 novembre 2013
17 nov. 2013 à 16:16
Merci à tous pour vos reponses.
0