Recherchev ou methode plus rapide...

Fermé
Signaler
Messages postés
4
Date d'inscription
lundi 24 mars 2008
Statut
Membre
Dernière intervention
5 juin 2013
-
Messages postés
17676
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
26 novembre 2021
-
Bonjour,

J'ai un fichier excel qui comporte 102 onglet (001-100 facture, Inventaire et Liste) sur chaque facture j'ai un liste ou je peux choisir l'article que je vend. Dans mon inventaire j'ai environ 400 articles. J'aimerais trouver une facon rapide pour addition mes articles de mes facture pour venir deduire mon inventaire.

POur l'instant je fait =recherchev(...001...)+recherchev(...002...)+recherchev(...003...) mais j'ai pas envie de copier 100 la formule existe-t-il une autre formule ?

Merci


2 réponses

Messages postés
590
Date d'inscription
dimanche 3 avril 2011
Statut
Membre
Dernière intervention
18 octobre 2014
194
Bonjour,
je ne pense pas que tu dois chercher dans une formule, mais a mon avis a gérer autrement 102 onglets alors qu'avec un onglet facture ou tes articles serons deduis automatiquement et ou la feuil sera enregistrer, un onglet inventaire ou tu aura la vente du jour, semaine et mois et année, et un onglet ou ta base de donnée des article avec valeur et quantité serons inscrit.

marc
Messages postés
17676
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
26 novembre 2021
4 844
Salut,

Il y a un moyen détourné, dans chaque onglet tu réserves une cellule à une adresse fixe exemple G1 dans la quelle tu écris une formule avec SOMMEPROD ou SOMME.SI.ENS qui fait référence au critère qui se trouve sur ta feuille exemple nommée Récap cellule H1

=SOMMEPROD((A1:A20=Feuil1!H1)*(B1:B20))

une fois que tu auras copié la formule sur toutes tes feuilles, sur la feuille Récap il suffit de faire le total avec cette formule

=SOMME(Feuil1:Feuil100!G1)

la feuille Récap doit être soit en première ou dernière position, parce que cette formule additionnera toutes les cellule G1 des feuilles entre la feuille nommée Feuil1 et Feuil100

si tu as besoin d'un exemple crée un fichier de quelques onglets et quelques lignes que tu peux joindre avec ce lien

https://www.cjoint.com/