Dénombrer le nb d'hommes ou de femmes selon leur tranche d'âge.

Résolu/Fermé
g@zelle - 30 mai 2013 à 10:39
g@zelle
Messages postés
100
Date d'inscription
samedi 20 avril 2013
Statut
Membre
Dernière intervention
10 avril 2020
- 30 mai 2013 à 16:57
Bonjour,

Je souhaiterais savoir comment faire pour dénombrer selon si ce sont des hommes ou des femmes selon une tranche d'âge.

Je suis arrivée à avoir le nombre de personne (hommes et femmes) selon la tranche d'âge, mais je ne sais pas quelle formule est appropriée pour avoir maintenant le nombre de femmes et d'hommes selon leur tranche d'âge, ci-joint le fichier, pour que vous ayez une meilleures visibilité de mon souhait.

Merci de votre aide.


http://cjoint.com/?0EEkHqbPmIm

3 réponses

zlavtok
Messages postés
469
Date d'inscription
jeudi 24 janvier 2013
Statut
Membre
Dernière intervention
25 octobre 2013
109
30 mai 2013 à 11:21
Salut,

Je n'ai pas pu regardé ton fichier cause de restrictions sur mon lieu de travail mais je viens de faire un test et avec la commande NB.SI.ENS(plage critère1;critère1;plage critère 2; critère 2) ça devrait marcher.


Bonne chance.
0
Bonjour zlavtok,

Je te remercie pour ta réponse, j'ai eu la solution.
0
tontong
Messages postés
2514
Date d'inscription
mercredi 3 février 2010
Statut
Membre
Dernière intervention
25 mai 2022
1 024
30 mai 2013 à 11:28
Bonjour,
Il suffit d'ajouter la condition H ou F dans la formule en H5 =SOMME(SI(($C$4:$C$43>=G5)*($C$4:$C$43<G6);1;0))
donc en I5 =SOMME(SI(($C$4:$C$43>=G5)*($C$4:$C$43<G6)*($D$4:$D$43="H");1;0))
en J5 =SOMME(SI(($C$4:$C$43>=G5)*($C$4:$C$43<G6)*($D$4:$D$43="F");1;0))
toujours en matricielle validée avec CTRL+SHIFT+Enter

On pourrait aussi utiliser SommeProd, exemple pour la dernière formule:
=SOMMEPROD(($C$4:$C$43>=G5)*($C$4:$C$43<G6)*($D$4:$D$43="F")) validée par Enter seulement
0
Bonjour tontong,

C'est trop génial, ta formule, je te remercie. Toute nouvelle sur le forum, je ne sais pas si je peux à la suite de cette résolution poser une autre question.

Mais j'aimerai savoir, comment superposer 2 graphiques de pyramides des âge ? Voudrais-tu bien m'aider ?
0
zlavtok
Messages postés
469
Date d'inscription
jeudi 24 janvier 2013
Statut
Membre
Dernière intervention
25 octobre 2013
109
30 mai 2013 à 16:29
Salut

Pour faire ça il faut que tu sélectionne tes colonnes et que tu crée un hystogramme.
Dans les source de donnée tu mets ensuite en Etiquette de l'axe horizontal l'age et en entrée de légende une entrée homme avec en source la colonne avec le nombre d'homme par tranche d'age et une autre entrée femme avec en source la colonne avec le nombre de femme par tranche d'age.
0
g@zelle
Messages postés
100
Date d'inscription
samedi 20 avril 2013
Statut
Membre
Dernière intervention
10 avril 2020
1
30 mai 2013 à 16:57
je te remercie pour ta réponse, j'ai eu la solution.

Merci
0