QOS sur 2950 [Résolu/Fermé]

Signaler
Messages postés
11
Date d'inscription
jeudi 16 février 2012
Statut
Membre
Dernière intervention
11 juillet 2014
-
Messages postés
11
Date d'inscription
jeudi 16 février 2012
Statut
Membre
Dernière intervention
11 juillet 2014
-
Bonjour à tous,

J'ai un soucis avec la QOS sur un 2950.
Mon adresse ip est 192.168.0.1

Voici ce que j'ai mis :

ip access-list standard MON-ACL
permit 192.168.0.1
!
class-map match-all MA-CLASS
match access-group name MON-ACL
!
policy-map MA-POLICY
class MA-CLASS
set dscp cs6
!
interface FastEthernet0/x
description mon_port
switchport mode access
service-policy input MA-POLICY


Mais lorsque je souhaite voir si l'acl est appliqué, j'ai toujours 0 packet :

2950#sh policy-map interface
FastEthernet0/x

Service-policy input: MA-POLICY

Class-map: MA-CLASS (match-all)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: access-group name MON-ACL

Class-map: class-default (match-any)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any
0 packets, 0 bytes
5 minute rate 0 bps

Avez vous une idée ?

Merci d'avance pour vos lumières

4 réponses

Messages postés
788
Date d'inscription
mercredi 2 novembre 2011
Statut
Membre
Dernière intervention
17 mai 2014
98
Si tu sniffes le traffic sortant est-il bien marqué avec CS6 ?
sh policy-map interface ne fonctionne pas sur un switch comme sur un routeur, tu ne verras jamais les hit counts. il faut utiliser sh mls qos interface x/x
Un 2950 ne fait pas de Qos par défaut donc il faudra aussi peut être rajouter la commande mls qos pour activer la Qos sur le switch pour que cela fonctionne.
Messages postés
11
Date d'inscription
jeudi 16 février 2012
Statut
Membre
Dernière intervention
11 juillet 2014

Je ne peux pas sniffer pour l'instant, le switch est sur un autre site (à moins que vous avez une méthode pour sniffer à distance ?).
Lorsque je fais un sh mls qos interface 0/x, j'ai ce résultat :
FastEthernet0/x
Attached policy-map for Ingress: MA-POLICY
trust state: trust cos
trust mode: trust cos
trust enabled flag: ena
COS override: dis
default COS: 0
DSCP Mutation Map: Default DSCP Mutation Map
Trust device: none
qos mode: port-based


J'ai bien activer la qos :
Router#sh mls qos
QoS is enabled
QoS ip packet dscp rewrite is enabled


Mais je ne suis toujours pas sûre que mes flux soient marqués.

Salut,

Si il y a un routeur en amont de ce switch et que le traffic marqué va vers ce routeur alors vous pouvez mettre une policy en input qui compte les paquets selon le dscp ou bien sniffer l'interface du routeur avec EPC et exporter le dump.

Alain
Messages postés
11
Date d'inscription
jeudi 16 février 2012
Statut
Membre
Dernière intervention
11 juillet 2014

RE,

Merci pour votre aide. Donc, je n'ai pas de routeur derrière (Trunck vers un proxy puis switch sur lequel j'ai pas la main) et je ne possède pas EPC.
Par contre, j'ai pu me rendre sur le site et j'ai sniffé le traffic avec Wireshark, et mes flux sont bien marqués ! Dommage qu'il n'y ai pas la possibilité sur un 2950 de faire comme sur un routeur un sh policy-map interface.

En tout cas merci de vos réponses et @ bientôt.