Erreur valeur fonction MOYENNE.SI.ENS

[Résolu/Fermé]
Signaler
Messages postés
59
Date d'inscription
mardi 2 avril 2013
Statut
Membre
Dernière intervention
15 octobre 2019
-
Messages postés
59
Date d'inscription
mardi 2 avril 2013
Statut
Membre
Dernière intervention
15 octobre 2019
-
Bonjour,
j'ai un problème je dois faire un moyenne conditionnelle mais j'obtient une erreur de valeur
https://www.cjoint.com/?CDAoZxogstt
et je ne sais pas d'ou ça peut venir on m'a proposé de vérifier le format de cellule tout parait correcte mais l'erreur est tjrs la . j'ai besoin de votre aide .
merci

3 réponses

Messages postés
24205
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
24 octobre 2021
6 938
Bonjour,

les plages doivent avoir la même taille :
=SOMME.SI.ENS($E$3:$E$2018;$D$3:$D$2018;$D$2026;$C$3:$C$2018;$E$2026)
et non :
=SOMME.SI.ENS($E$3:$E$2018;$D$3:$D$2018;$D$2026;$C$2:$C$2018;$E$2026)

Mais pour faire ça fait plutôt un TCD (Tableau Croisé Dynamique) :
https://www.cjoint.com/?CDApqSKpcOU
Aucune formule, juste un rafraichissement si tes données évolues.

eric
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41989 internautes nous ont dit merci ce mois-ci

Messages postés
12257
Date d'inscription
jeudi 15 mai 2008
Statut
Modérateur
Dernière intervention
3 septembre 2021
2 655
Bonjour,

Comme ça à la louche, sans regarder de trop près, je vois 2 pitites erreurs :
=SOMME.SI.ENS(E3:E2018;C2:C2018;1;D2:D2018;VENDREDI)
1- Pourquoi E3:E2018 alors que les 2 autres plages (C et D) commencent en C2 et D2?
2- VENDREDI entre guillemets, ce sera mieux.
Soit :
=SOMME.SI.ENS(E3:E2018;C3:C2018;1;D3:D2018;"VENDREDI")

Cordialement,
Franck P
Messages postés
59
Date d'inscription
mardi 2 avril 2013
Statut
Membre
Dernière intervention
15 octobre 2019

Bonjour,
je vous remercie tous pour vos réponses ça m'aide beaucoup je ne suis pas habituer à travailler avec des fonctions excel maintenant j'apprend grâce à vous .mais j'ai juste une dernière question j'effectue le calcul pour l'ensemble des données mais j'obtiens deux lignes avec une erreur de type #DIV/0 j'ai essayé plusieurs fois de la corrigé mais je n'arrive pas .
voila le fichier https://www.cjoint.com/?CDCmw3sIDzb
Merci
Messages postés
24205
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
24 octobre 2021
6 938
Bonjour,

tu as des "mardi " au lieu de "mardi" dans données!C:C pour les 1 et 2

eric
Messages postés
59
Date d'inscription
mardi 2 avril 2013
Statut
Membre
Dernière intervention
15 octobre 2019

ok merci bcp eric j'ai corrigé l'erreur mnt tt est parfait

***MERCI***