Nombre de mots identiques [Résolu/Fermé]

Signaler
-
Messages postés
25323
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
29 septembre 2020
-
Bonjour,

J'aurai besoin de votre aide.
Cela fait plus d'une heure que je me prend la tete avec EXCEL la je suis a bout :p

Je voulais savoir, comment puis je faire pour compter le meme nombre de mots qui apparaissent dans une cellule

exemple :

Dans ma case j'ai un long texte ou apparait le mot "rugby" plusieurs fois, quelle formule me permet de savoir combien de fois apparait le mot "rugby"

Merci d'avance

4 réponses

Messages postés
2364
Date d'inscription
mercredi 3 février 2010
Statut
Membre
Dernière intervention
31 août 2020
873
Bonjour,
Essayez:
=NBCAR(SUBSTITUE(A1;"rugby";"rugby|"))-NBCAR(A1)
On ajoute un caractère " exotique" comme "|" chaque fois que l'on rencontre le mot "rugby" et on compte la différence de nombre de caractères entre les deux chaînes.
2
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60769 internautes nous ont dit merci ce mois-ci

Merci beaucoup tontong ca a marché :)
enfin
Messages postés
25323
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
29 septembre 2020
5 499
Bien joué là tontong, chapeau
Messages postés
25323
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
29 septembre 2020
5 499
Bonjour
je crains que ce ne soit pas possible sans macro, ou alors au prix de manipulations que je n'ose même pas vous proposer
crdlmnt
Merci a tous tontong m'a donné la réponse :) la formule est parfaite !!
Encore merci a tous d'avoir pris du temps pour me repondre aussi rapidement
Messages postés
9084
Date d'inscription
jeudi 18 septembre 2008
Statut
Membre
Dernière intervention
28 mai 2018
120
Exemple : =NB.SI(C1:C14;"rugby")


C1:C14 = la colonne de recherche
il faut que tu indiques ton numéro de colonnes de début et de fin à la paace
merci jfqld,

Dérniere requete pour ma part, les mots que je dois comptais sont dans une meme case (A2) et non une colonne :/