Compter le nombre de fois ou apparaît un mot dans une cellule [Résolu/Fermé]

Signaler
-
Messages postés
52180
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
31 août 2020
-
Bonjour,
J'ai une colonne avec plusieurs cellules remplies. Chaque cellule contient du texte libre. Je souhaiterais compter le nombre de fois où apparaît un certain mot dans chacune des cellules.
Exple: La 1ère cellule contient: "2 voitures jaune, 1 garage", la 2nde cellule contient "3 châteaux, 1 jardin et 1 pomme jaune" -> je souhaiterais compter le nombre de mot "jaune" dans ces deux cellules, le résultat étant 2.

Quelqu'un a-t-il la solution?
merci d'avance,
Ynck

8 réponses

Messages postés
17187
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
31 août 2020
4 197
Salut,

Avec ce genre de formule en utilisant le joker *
exemple pour surveiller la plage A1:A10


=NB.SI(A1:A10;"*jaune*")

A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
9
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 61272 internautes nous ont dit merci ce mois-ci

Euh... C'est moi ou bien cette fonction ne fonctionne pas dans Excel Mac 2011 ?
Merci ;)
Messages postés
52180
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
31 août 2020
13 959 > Billboquet
Consulte l'Aide pour la syntaxe de la fonction SOMME.SI et pour l'utilisation du joker *
Messages postés
17187
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
31 août 2020
4 197
Re,

Alors il faut changer de formule et passer avec une matricielle

exemple tes saisies sont en A1:A15 et le mot recherché en G1

= SOMME(NBCAR(A1:A15)-NBCAR(SUBSTITUE(A1:A15;G1;"")))/NBCAR(G1)

cette formule matricielle doit être confirmée en cliquant en même temps sur 3 touches du clavier Ctrl, Shift et Entrée
si tu fais bien la formule se placera entre {}
Messages postés
4694
Date d'inscription
mardi 9 janvier 2007
Statut
Contributeur sécurité
Dernière intervention
25 juin 2019
883
Bonjour,

Exactement, Mike aura été plus rapide ;)

Voici un peu de doc sur le fonctionnement de cette formule :
https://support.office.com/fr-fr/article/compter-le-nombre-d-occurrences-d-une-valeur-aa1f3067-05c9-44e4-b141-f75bb9bb89bd?ocmsassetID=HP010070480&CorrelationId=27bedce8-f9da-4d24-aa1f-30da647ac25e&ui=fr-FR&rs=fr-FR&ad=FR

J'ai envoyé un ange pour te protéger mais ... il est revenu me dire qu'il ne pouvait veiller sur un autre
Messages postés
25248
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
29 août 2020
5 428
Bonjour
Pour faire simple si j'ai bien compris
Avec NB.SI pour aller chercher le mot dans une cellule de référence:
si jaune en G1:

=NB.SI(A1:A15;"*"&G1&"*") donne le résultat.

crdlmnt
merci Mike pour ta réponse rapide.
Par contre il faut vraiment écrire le mot, on ne peut pas aller chercher le contenu dans une autre cellule de référence...
cdlt,
Ynck
Messages postés
52180
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
31 août 2020
13 959
ça, tu ne l'avais pas précisé ... on ne peut pas tout deviner !
merci à tous, ça résout mon pb et en plus j'ai deux infos complémentaires:
- le nb de cellule ou le mot apparaît (qu'il apparaisse 1 fois ou plusieurs fois à l'intérieur d'une même cellule, le résultat est 1)
- le nb d'apparition total du mot en prenant en compte les multiples au sein d'une même cellule

nickel ! vous êtes trop fort !
Bonjour à tous,

Ce thread est très intéressant.
Savez-vous comment procéder lorsqu'on cherche les occurrences cumulées de plusieurs mots dans une cellule?
Par exemple:
en B2: cuivre, zinc, or, fer, viande, blé, gaz, textile, composants électroniques
en G1: cuivre
en G2: zinc
en G3: fer

Je cherche une formule ou une matrice qui permettrait de donner le nombre total (somme) d'occurrences de cuivre, zinc et fer en B2.

Des suggestions?

Merci d'avance.
Messages postés
17187
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
31 août 2020
4 197
Bonjour,

Tu aurais dû ouvrir ta propre discussion et ne pas relancer celle ci ancienne et en statut résolu

pour le cuivre en G1 =NB.SI(A1:A15;"*cuivre*")
G2 =NB.SI(A1:A15;"*zinc*") etc ...

par contre si tu veux tester qu'une cellule exemple A1 G1 =NB.SI(A1;"*cuivre*")

et si tu veux mettre le critère à comptabiliser dans une cellule exemple en F1 tu saisis cuivre

G1 =NB.SI(A1:A15;"*cuivre*") =NB.SI(A1:A15;"*"&F1&"*")


A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.