Addition d'heure supérieure à 24 au format hh:mm

Résolu/Fermé
Signaler
Messages postés
61
Date d'inscription
vendredi 26 octobre 2012
Statut
Membre
Dernière intervention
17 avril 2015
-
Messages postés
16547
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
19 janvier 2022
-
Bonjour à tous,

Après de multiple recherche et de multiple essaie...je sèche !
Je m'en remet donc à votre savoir.

Alors voici le soucis.

J'ai un tableau XLS, dans ma colonne E (fusionné avec la F) j'y note des heures.
Ces heures correspondes à des temps d'arrêt d'une machine pour le mois



Mon travail :

-Je dois cumulé les temps d'arrêt de chaque mois (Ex: pour le mois de Mars = Temps d'arrêt de Mars + celui de Février ( Février qui est lui même additionné avec celui de Janvier)).



Ma méthode de travail :

-J'ai des heures sous le format hh:mm, que je note sous le format décimal (ex: pour 67:30 je note 67,5) ( que je calcul à la calculatrice, donc perte de temps...) dans ma colonne E.
-J'additionne, aussi à la calculatrice, mois par mois
-J'ai dans ma colonne I (fusionné avec la J) une formule qui correspond à un dédommagement financier. Je me sert donc de ma colonne E (avec les heures sous format décimal) pour le calcul.



Ce que je voudrais:

-Pouvoir noté les heures dans ma colonne E sous le format hh:mm, sans que cela ne gêne la formule en colonne I pour le dédommagement.
-Si cela peut être fait, il me faudrait donc pouvoir additionner les heures format hh:mm du mois de Février par exemple, avec les heures format hh:mm du mois de Mars.


Cela m'éviterai de sortir ma calculette , et surtout par soucis d'esthétisme pour le format des heures.



Merci d'avance,



A voir également:

5 réponses

Messages postés
16547
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
19 janvier 2022
3 260
pour voir le nombre d'heures ' met au format personnalisé [hh]:mm

en fait [hh]:mm est le format d'un nombr que tu peut voir en te mettant au format standard
Par ex 72:45 te renvoie en standard 3,03125 3 étant ici le nombre de jours et 0,03125 une portion de jour (24h)
en heure 3*24=72

en en 1/100 d'heure 0,03125*24 soient 0,75

Dans excel A1 indique 72:45
=A1*24 te renvoie 72,75
à mettre au format standard
Michel
1
Messages postés
2501
Date d'inscription
mercredi 3 février 2010
Statut
Membre
Dernière intervention
16 janvier 2022
1 012
Bonjour,
Une autre façon d'exprimer la même chose.
Testez une méthode plus conventionnelle:
les heures sont saisies sous la forme 17:30 dans des cellules au format personnalisé [h]:mm. Elles peuvent ainsi s'additionner simplement même au-delà de 24 h.
Les heures sont en A2 le taux horaire en B2 le produit en C2.
C2= A2*B2*24 avec la cellule C2 au format nombre ou au format monétaire avec le nombre de décimales choisi.
Il faut multiplier par 24 parce que si Excel veut bien afficher des heures et/ou des minutes mais il compte toujours en jours quand il reconnait des dates ou des heures.
0
Messages postés
26409
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
24 janvier 2022
6 187
Bonsoir

si on ne sait pas ce que représente vos 175,2 on ne pourra pas vous répondre
s'il s'agit d'heure il faut placer dans votre formule:
175,2/24 et laisser E64 en heure ou en format standard , ça ne changera rien
car sinon Excel vous compte 175,2 jours

crdlmnt

ne sommes nous pas seuls à comprendre ce que l'on explique?
0
Messages postés
61
Date d'inscription
vendredi 26 octobre 2012
Statut
Membre
Dernière intervention
17 avril 2015

Les 175,2 représente 2% d'une année, soit 7.33 jours, soit 175,2 heure.
0
Messages postés
61
Date d'inscription
vendredi 26 octobre 2012
Statut
Membre
Dernière intervention
17 avril 2015

Ma colonne I représente un dédommagement, si ma machine dépasse 2% d'inactivité dans l'année, alors je le rembourse avec cette formule:
I64: =SI((E64-175,2)*G64<=0;0;((E64-175,2)*G64)/24)

E64: correspondant aux heures d'inactivité (en H au format standard, mais j'aimerais au format hh:mm par soucis d'esthétisme dans ma colonne E)
175,2: correspondant au 2% annuelle (en H au format standard)
G64: puissance de la machine (en Watt, format standard)
0
Messages postés
16547
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
19 janvier 2022
3 260
Bon, puisque je ne sais pas lire et que je ne suis pas assez pointu pour piroc, je laisse tomber
0
Messages postés
61
Date d'inscription
vendredi 26 octobre 2012
Statut
Membre
Dernière intervention
17 avril 2015

Je voulais pas te vexer ...
0
Messages postés
16547
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
19 janvier 2022
3 260
Mais non , je ne suis pas vexé , grand génie....
tu ne mérites vraiment pas qu'on se vexe pour toi!
0
Messages postés
61
Date d'inscription
vendredi 26 octobre 2012
Statut
Membre
Dernière intervention
17 avril 2015

@tontong @michel_m
Ce n'est pas "précisément" ce que je veux :)
Relisez bien ce que je souhaite, c'est plus pointue

Je sait comment faire sur excel que 10h30 = 10,5 ou inversement.

Pour synthétiser tout mon charabia, je veux pouvoir additionner des heures sous le format hh:mm grâce à une formule.

Ex:

Feuil1:
E64: =39h20
I64: =SI((E64-175,2)*G64<=0;0;((E64-175,2)*G64)/24)

Feuil2:
E64: =Feuil1!E64+577h30
I64: =SI((E64-175,2)*G64<=0;0;((E64-175,2)*G64)/24)

Feuil3:
E64:=Feuil2!E64+5h00
I64: =SI((E64-175,2)*G64<=0;0;((E64-175,2)*G64)/24)

etc
.
.
.
-2