ORA-12560: TNS : erreur d'adaptateur de proto [Fermé]

Signaler
Messages postés
49
Date d'inscription
jeudi 11 août 2005
Statut
Membre
Dernière intervention
1 janvier 2007
-
 naroiyas -
Salut tout le monde !!
Alors je suis bien de retour sur ce Forum génial !! y a rien à dire !!
Mes amis j'ai eu un problème lorque je voulais travailler avec Oracle Froms, plus exactement quand je veux executer la form une erreur s'affiche :

erreur :
ORA-12560: TNS : erreur d'adaptateur de protocole


je porte votre connaissance que le service d'écoute Listener est bien démarré, vraiment je n'arrive pas à surmonter ce problème aprés de longues recherches sur google.

Je compte sur votre aide

cordialement

Matrix++

14 réponses

salamou 3alaikom
j'ai eu le meme probleme
la solution est de verifier si le serveur oracle dans votre machine fonctionne
click droit sur poste de travail -->gere--> Service et application-->Services
puis cherchez et demarrez les services:
-OracleMTS RecoveryService
-OracleServiceXE
35
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 61433 internautes nous ont dit merci ce mois-ci

Merci infiniment slouma ^^
Merci Bien
Merci infiniment..

Merci beaucoup ça marche.
J'ai le même souci avec Oracle Express 10g, le "tnsping xe" passe, et en faisant "lsnrctl status" je n'ai pas de service nommé "xe" dans la liste. La commande "lsnrctl reload listener" ne change rien. Impossible de se connecter avec sqlplus.

Le pb persiste après réinstallation. Je précise que je suis sous Windows XP, et que les deux services OracleServiceXE et OracleTNSListener sont bien démarrés. J'ai vérifié le tnsnames.ora qui est correct.

Un DBA Oracle dans le coin ? Merci !
lsnrctl stop puis lsnrctl start et c'est parti...
merci,ca marche
Salam ALAYKOUM ,

La meilleur solution c'est de faire un Click droit sur post de travail ,gérer, services et applications puis démarrez les deux services :
-OracleMTS RecoveryService
-OracleServiceXE
Bonjour tout le monde,

j ai essayé d'installer oracle 10 sur winxp pro mais lors du lancement de l assistant configuration pour copier les fichiers de la bd, j ai une boite du dialogue qui apparait avec l erreur ora-12560 TNS PROTOCOL ADAPTER ERROR

merci de m aider
C'est encore moi, j'ai trouvé le message suivant sur le site Oracle :

If other Oracle client software is installed on the same computer as Oracle Database XE, ensure that you use the appropriate connect syntax for these clients when trying to connect to Oracle Database XE. If you do not specify the appropriate connect syntax, then an "ORA-12560: TNS: protocol adapter error" message may appear.

J'ai effectivement un client Oracle 10g sur la machine. De quelle syntaxe est-il question ?

J'essaie "sqlplus sys@xe as sysdba" et j'ai l'erreur 12560. Ma syntaxe est-elle correcte ?

J'ai aussi trouvé des informations à propos d'une variable d'environnement "LOCAL", ou encore "ORACLE_SID". Sur une autre machine je n'ai pas ces variables d'environnement et pourtant je me connecte sans pb sur la base XE en local. J'estime donc qu'elles sont inutiles si le serveur est correctement configuré.

Une idée ? Merci !
salem 3alaikom
j'ai le meme problème que vous,
j'essai de faire une migration de BD access vers oracle via le workbench.

lors de l'etape de création de la base oracle je reçois ce message:
"unable to connect to target database
TNS: erreur d'adaptateur de protocole"

j'aime bien avoir une réponse merci
si tu es sosu windows essai de faire un :

set ORACLE_SID=NOM_INSTANCE

car j'avais la meme erreur et ça marchait après
> Rockman018
bonjour tt le monde

svp pourriez m'expliquer plus ou je dois essayer ce "set ORACLE_SID=NOM_INSTANCE" parce q j ai ce pb et je sais quoi faire.
meci.
c'est une commande système et pas sql ;)
J'ai Oracle 10g installer sur nom laptpop,quant je lance oracle apres avoir entre le UESRNAme
et le password Oracle affiche une massege d'erreur (ORA-12560: TNS: protocol adapter error) je veux resoudre ce probleme
Messages postés
1
Date d'inscription
vendredi 21 mars 2014
Statut
Membre
Dernière intervention
22 mars 2014

salem
je veux acceder a ma base de données avec visual basic (visual studio 2008) ( j'ai installé oracle 10g) mais aprés avoir entrer le nom d'utilisateur et le mot de passe ,il m'affiche ORA-12560: TNS: protocol adapter error !!!! les services nécessaires sont bien démarrés ,j'ai écrit la commande
connect
sqlplus /as sysdate ...
aidez moi et merci d'avance :))
essayer tnping sid
Messages postés
1
Date d'inscription
vendredi 14 décembre 2007
Statut
Membre
Dernière intervention
8 janvier 2008

bonjour

essayé la commande tnsping sid , si sa marche verifier le status de la base pour cela lancer la commande : lsnrctl status

si sa marche pas alors tu as le probleme d'adapation entre le service_name et le sid verifer bien le fichier tnsname.ora


bonne chance
salut,
j'ai installé dernièrement oracle developer suite 10g pour travailler sur forms
quand je veux utiliser sql*plus pour me connecter j'entre avec SYSTEM,manager et l'erreur TNS:protocol adapter error s'affiche , g pas compris quoi faire.
sachant que g travaillé auparavant avec oracle 9i, avec ce dernier, on configure la base avec l'assistant database manager.
mais avec oracle developer suite 10g, g pas trouvé cet assistant, svp, je veux votre aide, le plus tot possible.
voilà mon mail: zarrouk_moune@yahoo.fr
Messages postés
41
Date d'inscription
mercredi 10 décembre 2008
Statut
Membre
Dernière intervention
16 octobre 2012
3
Bonjour,
Comment on peut savoir si le listener est bien démarré? On fait quoi pour vérifier? Et comment on s'est si le fichier tnsnames.ora est correct?
En fait, j'ai un problème moi aussi! J'arrive pas à me connecter à la base de données à partir de Oracle forms. Je mets le non de l'utilisateur, le mot de passe et le nom de la base de données mais on me dit qu'il ya un problème d'écoute...
On m'a dit qu'il fallait mettre le tnsnames.ora de product dans celui du devsuitehome mais ça n'a pas marché!
Merci d'éclairer ma lanterne.
merci tu vien de me sauver le vie !!
asselemou 3alaykom

dans la version mozilla il y'a une icone à droite de la fenetre juste en bas qui indique que "you are on line" cliquer dessus pour devenir "off line" puis refraichir la page et puis connecter vous à la base et incha ALLAH ça va marché. J'avais le même problème et c'est résolu :)
merci cette solution marche avec oracle 9 i
J'ai résolu le problème. Vérifie si votre service Oracle orcl is start.
Avec mon server Windows 2003 SP il était en arret. Mettre le service oracle en mode automatique. J'ai rebooter le server Windows 2003. Tous fonctionne OK.

Merci
Mais j'arrive pas à démarrer le service OracleMTS RecoveryService