RechercheV sur plusieurs lignes et dans plusieurs feuilles

Fermé
Chris - Modifié par Chris le 20/01/2017 à 05:35
JvDo Messages postés 1978 Date d'inscription mercredi 27 juillet 2005 Statut Membre Dernière intervention 28 septembre 2020 - 22 janv. 2017 à 06:17
Bonjour, 95
Je suis loin d'être désespérer, mais j'ai besoin d'aide.

Je suis occupé de réaliser un tableau contenant les statistiques d'une année.
J'ai donc 12 feuilles (1 par mois) et une feuille de "Totaux".

Sur chaque feuille, donc pour chaque mois j'ai les données suivantes:
8 Equipes composées de x personnes.
Chaques équipes à 3 colonnes contenant des données comptabilisables.
Un total est calculé par équipe.

Jusque là tout va bien!

Sur ma feuille totale il me suffirait de reprendre un calcul simple additionnant les statistiques sur une adresse (colonne, ligne) précise!
Cependant, une personne peut passer d'une équipe à l'autre d'un mois à l'autre.

Ce qui implique que mes comptes ne seraient plus bon!

J'ai donc besoin pour bien faire d'une formule faisant ceci:
Trouver un nom dans une colonne (seul 2 colonnes reprennent des noms), en sachant qu'un nom peut apparaitre 2x dans une même colonne.
Lorsque ce nom est trouvé, prendre le nombre se trouvant dans la colonne à côté (JU/AC/IR) et réaliser une addition de chaque ligne où se trouverait ce nom pour l'ajouter dans la bonne case sur la feuille "TOTAUX".

J'espère que je suis bien compréhensible.

Pour info, ma formule actuelle est correcte, mais non digérée car... trop importante!
"=SOMME(SIERREUR(RECHERCHEV(B5;'Janvier'!B5:F21;2;FAUX);0);
SIERREUR(RECHERCHEV(B5;'Janvier'!B25:F41;2;FAUX);0);
SIERREUR(RECHERCHEV(B5;'Janvier'!B45:F61;2;FAUX);0);
SIERREUR(RECHERCHEV(B5;'Janvier'!B65:F81;2;FAUX);0);
SIERREUR(RECHERCHEV(B5;'Janvier'!I5:M21;2;FAUX);0);
SIERREUR(RECHERCHEV(B5;'Janvier'!I25:M41;2;FAUX);0);
SIERREUR(RECHERCHEV(B5;'Janvier'!I45:M61;2;FAUX);0);
SIERREUR(RECHERCHEV(B5;'Janvier'!I65:M81;2;FAUX);0);
SIERREUR(RECHERCHEV(B5;'Février'!B5:F21;2;FAUX);0);
SIERREUR(RECHERCHEV(B5;'Février'!B25:F41;2;FAUX);0);
SIERREUR(RECHERCHEV(B5;'Février'!B45:F61;2;FAUX);0);
SIERREUR(RECHERCHEV(B5;'Février'!B65:F81;2;FAUX);0);
SIERREUR(RECHERCHEV(B5;'Février'!I5:M21;2;FAUX);0);
SIERREUR(RECHERCHEV(B5;'Février'!I25:M41;2;FAUX);0);
SIERREUR(RECHERCHEV(B5;'Février'!I45:M61;2;FAUX);0);
SIERREUR(RECHERCHEV(B5;'Février'!I65:M81;2;FAUX);0);
SIERREUR(RECHERCHEV(B5;'Mars'!B5:F21;2;FAUX);0); ....) (Ceci allant jusque décembre...)


J'ai encore 1 contrainte! La formule doit être exécutable/compatible sur Excel 97...


Voici le fichier:
http://www.cjoint.com/c/GAueImVu7o8



Merci d'avance!
A voir également:

5 réponses

michel_m Messages postés 16591 Date d'inscription lundi 12 septembre 2005 Statut Contributeur Dernière intervention 3 février 2023 3 288
20 janv. 2017 à 09:26
Bonjour,

dans ton envoi, BJ n'existe pas...
0