Fonction excel RECHERCHEV incluant une somme

[Fermé]
Signaler
-
 david84 -
Bonjour,

Je voudrait savoir si on peux incluer une fonction somme à l'intérieur d'une fonction recherche V.
Ma formule utilise 2 colonnes + un cumul horizontal en bas de page :
1ère colonne avec des codes par exemple "AD"
4ème colonne avec des nombres
et mon cumul doit rechercher les "AD" de la 1ère colonne avec une rechercheV ça c'est ok pour moi mais elle doit surtout faire la somme de tous les nombres qui ont "AD" dans la 1ère colonne
=SI(ESTERREUR(RECHERCHEV(B192;A:J;5;0));"";RECHERCHEV(B192;A:J;5;0))
En fait au lieu du "5" qui reprend mon numéro de colonne je veux une somme de la colonne 5 pour tous ceux qui sont en "AD"

Si je ne suis pas clair dite le moi mais j'ai besoin de trouver rapidement.
Merci d'avance aux experts qui se pencheront sur ce cas.

Alexandra

1 réponse

Bonjour,
si j'ai bien compris ta demande, place toi dans la cellule où tu veux le résultat et essaie avec sommeprod :
=sommeprod((A:A="AD")*(E:E))
Bonjour,

Merci beaucoup David ça marche trop bien, je ne connaissais pas cette fonction.
Merci pour ta rapidité,
Alexandra
Bonjour,

cette formule fonctionne très bien avec du texte mais est-ce que tu connais par hasard celle qui fonctionne avec des chiffres ou des dates.

j'ai dans ma colonne A des dates classées en jj/mm/aa

et des montants dans ma colonne E

Comment est-ce que je peut additionner dans une cellule la somme des montants correspondant à une certaine période?

Si tu peux m'aider merci d'avance!!!!
> Valérie27
Je pense que cela répond à ta demande concernant les dates.
Formule trouvée sur le site de developpez.com

'Effectuer la somme des valeurs de la plage B1:B10,
'quand la date (plage A1:A10) est comprise entre le 01.01.04 et le 31.12.04
{=SOMME((B1:B10)*(A1:A10>=DATEVAL("01/01/04"))*(A1:A10<=DATEVAL("31/12/04")))}