Mysql cluster [Résolu/Fermé]

Signaler
Messages postés
144
Date d'inscription
vendredi 11 novembre 2011
Statut
Membre
Dernière intervention
30 mai 2017
-
Messages postés
144
Date d'inscription
vendredi 11 novembre 2011
Statut
Membre
Dernière intervention
30 mai 2017
-
Bonjour,
j'ai suivi ces tutoriels pour installer mysql cluster sur ubuntu 11.10 avec le paquet
mysql-cluster-gpl-7.1.19-linux-x86_64-glibc23.tar.gz
https://dev.mysql.com/doc/refman/8.0/en/mysql-cluster-install-configuration.html
http://cyrenity.wordpress.com/2010/08/12/howto-setup-mysql-cluster-beginners-tutorial/

Présentement j'ai réussi à démarrer le serveur manager et à a me connecter avec le data node sur l'autre serveur... Mais je n'arrive pas a démarrer faire la connexion pour mysqld(API)

Voici un aperçu du serveur de manager pour mieux comprendre:
ndb_mgm> show
Cluster Configuration
---------------------
[ndbd(NDB)]    2 node(s)
id=2    @192.168.0.101  (mysql-5.1.56 ndb-7.1.19, starting, Nodegroup: 0)
id=3 (not connected, accepting connect from 192.168.0.102)

[ndb_mgmd(MGM)]    1 node(s)
id=1    @192.168.0.100  (mysql-5.1.56 ndb-7.1.19)

[mysqld(API)]    2 node(s)
id=4 (not connected, accepting connect from 192.168.0.101)
id=5 (not connected, accepting connect from 192.168.0.102)


Bref je n'arrive pas a connecter id=4 (not connected, accepting connect from 192.168.0.101)

sur ce serveur (192.168.0.101) mon mysql est bien démarrer et connecté a data node seulement...

Quelqu'un aurait des pistes pour moi ? Merci!

1 réponse

Messages postés
144
Date d'inscription
vendredi 11 novembre 2011
Statut
Membre
Dernière intervention
30 mai 2017
8
Résolu, mais je ne me souviens plus par contre de la solution exacte car j'ai changer de tutoriel et adapter à mes besoins... maintenant ça fonctionne... Je crois par contre qu'on devais connecter l'id 3 et l'id 2 une premiere fois en même temps... pour qu'il soit bien reconnu...
Messages postés
144
Date d'inscription
vendredi 11 novembre 2011
Statut
Membre
Dernière intervention
30 mai 2017
8
Hum.. comment marquer cette question comme résolu ? L'option semble apparaître seulement lorsqu'il y a une réponse d'une autre personne. Edition: OK avec ce sous-commentaire ça fait apparaître l'option!