Compter nombre de valeurs identiques colonne [Résolu/Fermé]

Signaler
Messages postés
44
Date d'inscription
vendredi 30 juillet 2010
Statut
Membre
Dernière intervention
3 août 2015
-
 Youssef -
Bonjour,

je voudrais compter le nombre d'années de naissance qui sont identiques dans une colonne avec excel2007:

exemple en colonne D

Année de Naissance
1935
1942
1945

1938
1932
1940
1923
1937
1924
1933
1937
1940
1942
1932

1925
1927

il y a des cellules vides et environ 120 valeurs

et écrire le résultat dans 2 autres colonnes E et F sous la forme:

E F

1935 5
1942 4

etc...

merci pour votre aide
cordialement

8 réponses

Messages postés
25318
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
25 septembre 2020
5 495
Bonsoir
ça devrait marcher pourtant.
Ceci dit, à la relecture, je me rend compte qu'en colonne D vous n'avez à priori que des années de naissance.
SOMMEPROD est donc superflu, vous pouvez vous en sortir avec:
=NB.SI(D:D;E1) en F1

......Sauf si vos dates en D sont des textes au lieu de num...!
essayez ceci si la formule ci dessus ne fonctionne pas:
entrez 1 dans une cellule vide hors champ / copier la
sélectionnez votre champ en D, clic droit collage spécial / cochez "multiplication"

si ça ne va toujours pas, faites u n petit modèle avec vos données et déposer le sur:

https://www.cjoint.com/

en revenant ici pour lacer le lien donné par le site.

crdlmnt
2
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60769 internautes nous ont dit merci ce mois-ci

Messages postés
44
Date d'inscription
vendredi 30 juillet 2010
Statut
Membre
Dernière intervention
3 août 2015

Bonsoir Vaucluse,

voici le lien

https://www.cjoint.com/?0Byu6wRzUKc

merci
cordialement
Messages postés
25318
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
25 septembre 2020
5 495
Bonjour
en E la liste des années
en F:
=SOMMEPROD((ANNEE($D$1:$D$100)=E1)*1)
à tirer sur la hauteur de la liste en E
crdlmnt
Messages postés
44
Date d'inscription
vendredi 30 juillet 2010
Statut
Membre
Dernière intervention
3 août 2015

Bonjour Vaucluse,

j'ai essayé, mais il écrit que des 0 (zéro) dans les cellules de la colonne F et rien dans la colonne E.
peut être que je n'ai pas bien compris!!!!
merci
cordialement
Messages postés
17232
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
22 septembre 2020
4 257
Salut,

La formule que ta donné Vaucluse fonctionne très bien, soit tu limite ta plage de recherche A2 à A115 (fin de ta liste)

=NB.SI(A2:A115;E1)

soit tu laisses la possibilité d'ajouter des dates

=NB.SI(A:A;E1)

ou encore avec

=SOMMEPROD((A2:A115=E1)*(A2:A115<>""))

A quoi sert la colonne B Année qui est en doublon avec la colonne A

Messages postés
44
Date d'inscription
vendredi 30 juillet 2010
Statut
Membre
Dernière intervention
3 août 2015

Bonsoir Mike,

je voulais mettre dans la colonne B le résultat, c'est à dire uniquement la liste des années de la plus petite à la plus grande (une fois trié et enlevé les doublons et vides) , je pense qu'il y a 34 années différentes.
et dans la colonne C le nombre de fois que l'année est rencontrée
exemple:
B C
1923 3
1924 3
1925 2
........
........
1972 1

voila ce que je voudrais
merci
cordialement
Messages postés
17232
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
22 septembre 2020
4 257
Re,

Tu veux supprimer les années en doublon et cellules vide,

si c'est cela il est possible de coloriser uniquement les dates en doublons soit les lignes à supprimer

Ou en VBA et dans ce cas à partir d'un bouton en un simple clic les lignes vides et en doublons sont supprimées
Messages postés
44
Date d'inscription
vendredi 30 juillet 2010
Statut
Membre
Dernière intervention
3 août 2015

Re,

ce que je voulais au départ, c'est conserver la colonne A intacte, et créer une colonne B avec uniquement les années sans doublons ni vides et une colonne C avec le nombre de fois que l'on a cette année.
exemple
A..........B.........C
1935...1923...3
1942...1924...3
1938...1925...2
.............1926..1
1955
1972

1949

si tu peux me mettre un lien avec le résultat dans un fichier.
merci
cordialement
Messages postés
52338
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
27 septembre 2020
14 143
C'est bien ce que te proposait Vaucluse au post #3, mais avec les années en colonne E et les calculs en F, comme tu l'as souhaité initialement.
C'est bien la formule =NB.SI(D:D;E1) qu'il faut mettre en F1.

Comme tu viens de changer de colonnes, tu n'as donc qu'à adapter sa formule :
En C2 tu saisis =NB.SI(A:A;B2) à recopier vers le bas.
Et bien entendu ça marche parfaitement !

https://www.cjoint.com/?BByxyqaOGAZ

Saluts cordiaux à vous trois.
Messages postés
17232
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
22 septembre 2020
4 257
Re,

En B formule matricielle validée en cliquant en même temps sur 3 touches (Ctrl, Shift et Entrée) extrait directement une liste sans doublon et sans cellule vide extraite de la colonne A mais il faut impérativement avoir une cellule vide en A1 c'est pour cela que j'ai inséré une ligne qui peut être masquée ou réduite.
En colonne C le nombre de fois que la date en colonne B est rencontrée en colonne A

https://www.cjoint.com/?BByxwAbYBgt
Messages postés
1977
Date d'inscription
mercredi 27 juillet 2005
Statut
Membre
Dernière intervention
2 septembre 2020
812
Bonsoir,

Formule travaillée à partir de http://boisgontierjacques.free.fr/index2.htm

Pour ta liste sans doublon en colonne B, sélectionne la zone B2:B100 puis, dans la zone d'édition de formule, tape :
=SI(ESTERREUR(INDEX(champ,PETITE.VALEUR(SI(SI(ESTNA(EQUIV(champ,champ,0)=LIGNE(INDIRECT("1:"&LIGNES(champ)))),FAUX,EQUIV(champ,champ,0)=LIGNE(INDIRECT("1:"&LIGNES(champ)))),EQUIV(champ,champ,0),""),LIGNE(INDIRECT("1:"&LIGNES(champ)))))),"",INDEX(champ,PETITE.VALEUR(SI(SI(ESTNA(EQUIV(champ,champ,0)=LIGNE(INDIRECT("1:"&LIGNES(champ)))),FAUX,EQUIV(champ,champ,0)=LIGNE(INDIRECT("1:"&LIGNES(champ)))),EQUIV(champ,champ,0),""),LIGNE(INDIRECT("1:"&LIGNES(champ))))))

Tu valides par CTRL+MAJ+ENTER.
En regard, tu utilises une formule à base de NB.SI() pour avoir le nombre d'occurrences.
Champ désigne la zone de tes données : A2:A115
Il faut bien sûr mettre des ";" à la place de mes ",".

Cordialement

PS : Waouhhh ! 3 réponses en 6mn! bonsoir messieurs.
Je viens de regarder ta formule, Mike-31. Elle est nettement plus simple et claire que mon rafistolage!
Messages postés
17232
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
22 septembre 2020
4 257
Oui je sens que ce soir on est chaud comme la braise
A+
Mike-31
Messages postés
44
Date d'inscription
vendredi 30 juillet 2010
Statut
Membre
Dernière intervention
3 août 2015

Re,

merci à tous de m'avoir aidé rapidement.

Cordialement
Bonjour,

On peux faire plus simple

=NB.SI(B$3:B$300;D3)


Collone Breprésente la collone contenant l'ensemble des valeur et D représente le repért pour chaque valeur

en fin on sertrouve avec le nombre de chaque existe dans la collone B