Nombre compris entre x et y

Résolu/Fermé
Flo - 23 janv. 2012 à 11:49
 Flo - 23 janv. 2012 à 13:13
Bonjour,

Je possède des nombres entiers allant de 1 à 1000 (ce sont des secondes) et j'aimerais, pour chacun d'entre eux, savoir dans quelle tranche de 20 secondes il est situé.

Par exemple :

11 est compris entre 0 et 20 secondes (0-20).
86 est compris entre 80 et 100 secondes (80-100)
115 est compris entre etc...

Pour ça j'ai effectué une longue formule remplie d'opérateurs SI et ET :

=SI(ET(H2>K$2;H2<=K$3);L$3;
SI(ET(H2>K$3;H2<=K$4);L$4;
SI(ET(H2>K$4;H2<=K$5);L$5;
SI(ET(H2>K$5;H2<=K$6);L$6;
SI(ET(H2>K$6;H2<=K$7);L$7;
SI(ET(H2>K$7;H2<=K$8);L$8;
SI(ET(H2>K$8;H2<=K$9);L$9;
..
SI(ET(H2>K$35;H2<=K$36);L$36;
SI(ET(H2>K$36;H2<=K$37);L$37;))

Avec :

K$2 = 0

K$3 = 20
K$4 = 40

L$3 = "0-20"
L$4 = "20-40"

Mon problème est que je suis limité à 9 "boucles" car au delà il me trouve une erreur dans ma formule... Y at-il un moyen plus simple de faire celà ?

Merci,
Florent

A voir également:

3 réponses

Patrice33740 Messages postés 8553 Date d'inscription dimanche 13 juin 2010 Statut Membre Dernière intervention 24 octobre 2022 1 758
23 janv. 2012 à 11:56
si les valeurs sont dans la colonne H, en I2 :
=ENT(H2/20)*20 & "-" & (ENT(H2/20)+1)*20
à tirer vers le bas
1
chossette9 Messages postés 4239 Date d'inscription lundi 20 avril 2009 Statut Contributeur Dernière intervention 12 septembre 2014 1 306
23 janv. 2012 à 11:59
du coup, en suivant ton exemple, ma formule devient
=CONCATENER(ARRONDI.INF(A2*5;-2)/5;"-";ARRONDI.SUP(A2*5+1;-2)/5)


Cordialement.
0
chossette9 Messages postés 4239 Date d'inscription lundi 20 avril 2009 Statut Contributeur Dernière intervention 12 septembre 2014 1 306
Modifié par chossette9 le 23/01/2012 à 11:54
bonjour,

avec le nombre en A1, voici une formule qui fonctionne presque :
=CONCATENER(ARRONDI.INF(A2*5;-2)/5;"-";ARRONDI.SUP(A2*5;-2)/5)
Le presque vient du fait que par exemple si vous inscrivez 80, vous aurez la tranche 80-80.

Cordialement.
Ce mec la n'était pas une lumière, car il était niais.
0
Merci beaucoup à tous les 2.
Ça marche du tonnerre ! :-)
0