Commande su ne fonctionne plus [Résolu/Fermé]

Signaler
Messages postés
89
Date d'inscription
mardi 12 avril 2011
Statut
Membre
Dernière intervention
13 septembre 2011
-
Messages postés
89
Date d'inscription
mardi 12 avril 2011
Statut
Membre
Dernière intervention
13 septembre 2011
-
Bonjour,

c'est horrible : depuis quelques heures sous ma gentoo je ne peux plus (sous un utilisateur normal $user) utiliser su : cette commande MEME SI LE MDP EST CORRECTE me met que je n'ai pas les droits necessaires ... Je ne peux plus passer en root ... Le seul moyen que je trouve c'est de me loguer (avec une tty) directement en root, je n'ai pas pu reboot pour voir si ça reglerait le pb car la je compile (et j'en ai pour des heures)

Jai besoin daide et je ne sais pas dou ca pourrait venir, merci davance.

6 réponses

Messages postés
18240
Date d'inscription
lundi 15 janvier 2007
Statut
Contributeur
Dernière intervention
30 novembre 2020
5 257
hello
que répond
ls -l /bin/su
Messages postés
89
Date d'inscription
mardi 12 avril 2011
Statut
Membre
Dernière intervention
13 septembre 2011
1
Re, je pensais (esperait) que ça passerait tout seul mais non ! Voilà le résultat (désolé du retard).

ls -l /bin/su 
-rws--x--x 1 root root 36680 Jul 14 14:23 /bin/su



EDIT : j'insiste bien sur le fait qu'avant je navais pas le problème te que maintenant ça pose de gros pb de securite. (travailler uniquement en root).
Bonjour,

Tu as fait des modifications dans la configuration de PAM ?
Ou à l'utilisateur depuis lequel tu fais un su ? (je pense à la suppression d'un groupe)
Messages postés
89
Date d'inscription
mardi 12 avril 2011
Statut
Membre
Dernière intervention
13 septembre 2011
1
Re, PAM ? Je ne sais pas ce que c'est, j'ai juste crée mon utilisateur il ya un mois et ça fonctionnait mais là ça ne marche plus :(, voilà les options données lors de la création, au pir je peux toujours essayer de supprimer et recréer l'user.


useradd -m -s /bin/bash $users  
passwd $user  
usermod -G users,wheel,audio,optical,lp,scanner,log,power,floppy,
storage,video $user 
Vérifie que ton compte appartient toujours au groupe wheel.

http://www.gentoo.org/doc/fr/faq.xml
L'option wheel ajoute l'utilisateur au groupe wheel qui lui permettra de passer en mode superutilisateur avec la commande su. 
Messages postés
89
Date d'inscription
mardi 12 avril 2011
Statut
Membre
Dernière intervention
13 septembre 2011
1
Re, ok je tente désolé de répondre de manière irrégulière je m'y perd un peu car j'ai 4 pc et ça fait - sys dexploitation, oui tu dois avoir bon, pour une raison ou une autre wheel a du etre enlever, je tente la commande :

localhost ~ # usermod -aG wheel virgile
localhost ~ # env-update && . /etc/profile && su $user


Et en effet ça fonctionne ! Merci à toi !