ESTNA(RECHERCHEV recherche de droite a gauche

Résolu/Fermé
Signaler
-
Messages postés
733
Date d'inscription
dimanche 4 janvier 2009
Statut
Membre
Dernière intervention
15 janvier 2021
-
Bonjour,

J'ai une formule excel comme ceci:

=RECHERCHEV(B8;a201:C348;2;FAUX)
qui me va chercher le contenu d'une liste vers la droite et me le reporte sur une cellule qui contient cette formule.

Je souhaiterais non pas qu'il fasse une recherche de gauche à droite mais plutot de droite à gauche!

Si par exemple dans c5 j'ai italie je voudrais qu'il me reporte B5 sur une autre cellule.

Pas facile a expliquer.j'espère que vous avez compris.

1 réponse

Messages postés
733
Date d'inscription
dimanche 4 janvier 2009
Statut
Membre
Dernière intervention
15 janvier 2021
32
Il faut bien comprendre ce que "recherche de gauche à droite" signifie...

Cela est valable pour Excel qui parcours le tableau de gauche à droite, mais toi, tu peux récupérer la valeur que tu veux.

Prenons un tableau :

ref | produits
---------------
1 | play 3
2 | wii

Par exemple, avec les cellulles A1:B2

RECHERCHEV(valeur recherchée, dans quel tableau, la colonne à afficher, je sais plus ce que c'est le faux: valeur si faux je crois).

Imaginons que tu veux obtenir le produit en fonction de la ref

Soient D1 est la cellule ou on entre la ref et E1 la cellule avec la formule.

=recherchev(D1;A1:B1;2;FAUX)

C'est le "2" qui est important là dedans, si on avait encore une troisième colonne "prix" il aurait fallut mettre 3 pour afficher le prix / 2 pour afficher le produit...

A noter que "2" c'est la 2e ligne du tableau sélectionné. Même si la réponse que tu cherches est à la colonne D, mais que c'est la deuxième colonne de ton tableau de référence, il faudra que tu mettes "2" (compter manuellement).

Je ne sais pas si c'est ça la question, sinon tu peux aussi regarder RECHERCHEH, ça marche pareil, sauf que ça marche à l'horizontale (rechechev pour vertical et rechercheh pour horizontal), dans ce cas le "2" sera le numéro de la ligne...
Je souhaites utiliser RECHERCHEV mais "2" va afficher le produit.Moi je souhaiterais qu'a partir de "Produit" qu'il me trouve la référence!
Messages postés
26303
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
28 novembre 2021
6 127
Bonjour
pour rechercher dans n'importe quelle colonne et en éditer une autre:
=INDEX(champ à éditer;EQUIV(Valeur cherchée; colonne de recherche;0);N ° de la colonne du champ à éditer)
soit dans un champ A1:B100 pour chercher "Paul" dans la ,colonne C et éditer le B de la colonne correspondante:
=INDEX(A1:B100;EQUIV(3Paul";C1:C100;0);2)
(la colonne de l'item EQUI n'est pas forcément incluses dans le champ de INDEX)
La base de la formule est:
=INDEX(champ;N° de ligne; n°de colonne)
et EQUIV édite le N° de ligne ou se trouve la valeur cherchée.
crdlmnt
Messages postés
733
Date d'inscription
dimanche 4 janvier 2009
Statut
Membre
Dernière intervention
15 janvier 2021
32
Ou il suffit de faire l'inverse (à partir de la valeur saisie, tu cherches la colonne contenant la ref...