Remplir cellule excel en vba

Résolu/Fermé
zino - 12 janv. 2011 à 12:32
ccm81 Messages postés 10507 Date d'inscription lundi 18 octobre 2010 Statut Membre Dernière intervention 28 novembre 2022 - 12 janv. 2011 à 18:48
Bonjour,

J'aurais besoin de votre aide. J'aimerais remplir en vba les cellules excel de la colonne A2 à A(variable) selon A2 = 13/02/10 alors remplir cellule A2 à A? (fin du mois)
et tous les mois la date en A2 change.
Exemple fevrier : A2=13 / A3=14 jusqu'à A17=28
Merci

Zino

3 réponses

michel_m Messages postés 16582 Date d'inscription lundi 12 septembre 2005 Statut Contributeur Dernière intervention 27 novembre 2022 3 283
12 janv. 2011 à 17:26
Ce n'est pas forcément aider zino que de lui filer quand m^me une macro...
les demandes du mercredi, ca sent le devoir d'école et zino attend peut-^tre que d'autres lui fassent

allons y quand m^me

formule en A3 à tirer jusqu'à 32
=SI(OU(A2="";MOIS(A2+1)>MOIS(A2));"";A2+1)


et si on tient à une macro
peut-^tre plus simple
Sub ecrire_mois()
Dim depart As Date

depart = Range("A2")
For cptr = 3 To 32
    Cells(cptr, 1) = Cells(cptr - 1, 1) + 1
   If Month(Cells(cptr, 1)) > Month(Cells(cptr - 1, 1)) Then
        Cells(cptr, 1) = ""
        Exit For
   End If
  Next
    
End Sub
3
ccm81 Messages postés 10507 Date d'inscription lundi 18 octobre 2010 Statut Membre Dernière intervention 28 novembre 2022 2 330
12 janv. 2011 à 18:48
re,

décidement, j'ai beaucoup de mal avec la gestion des dates !!!!

cordialement
0