Excel-comparer une cellule avec un ensemble

Résolu/Fermé
Flambi.wan Messages postés 8 Date d'inscription lundi 8 novembre 2010 Statut Membre Dernière intervention 10 novembre 2010 - 8 nov. 2010 à 14:07
Flambi.wan Messages postés 8 Date d'inscription lundi 8 novembre 2010 Statut Membre Dernière intervention 10 novembre 2010 - 10 nov. 2010 à 08:43
Bonjour,
J'ai défini un ensemble en nommant une plage de texte
Je souhaiterais comparer une cellule (texte) avec chaque élément de mon ensemble, et afficher 1 si le contenu de ma cellule est dans la liste, sinon afficher 2. Quelqu'un saurait faire ça SVP?


4 réponses

michel_m Messages postés 16589 Date d'inscription lundi 12 septembre 2005 Statut Contributeur Dernière intervention 12 janvier 2023 3 289
8 nov. 2010 à 17:29
bonjour

la liste dans A1:A200
la valeur en B1
le résultat en C1
=SI(NB.SI(A1:A200;C1)=0;2;1)
si le mot cherché est mêlé avec d'autre mots dans la cellule
=SI(NB.SI(A1:A200;"* "&C1&" *")=0;2;1)
par ex on cherche "pas" dans "papoux papas à poux pas papas" renvoie 1 mais "papoux papas à poux papas" renvoie 2
3