/bin/sh: /etc/init.d/xprint: Permission denie

[Résolu/Fermé]
Signaler
Messages postés
536
Date d'inscription
samedi 3 janvier 2004
Statut
Membre
Dernière intervention
14 janvier 2013
-
Messages postés
536
Date d'inscription
samedi 3 janvier 2004
Statut
Membre
Dernière intervention
14 janvier 2013
-
Bonjour à tous,

Sous Mandrake 10.2 j'ai toujours ce message
/bin/sh: /etc/init.d/xprint: Permission denied
au démarrage d'une console et en allant dans les tty1...6

Quelqu'un a une idée pour régler ce problème?

Je n'ai rien fait de particulier et je ne comprend pourquoi ce message maintenant.

Merci

6 réponses

Messages postés
908
Date d'inscription
lundi 18 avril 2005
Statut
Membre
Dernière intervention
3 août 2008
502
Salut,
Est-ce que /etc/init.d/xprint à les droits d'exécution ?
sinon chmod u+x /etc/init.d/xprint

A+, Crabs
Messages postés
30211
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
20 octobre 2021
7 194
Qu'est ce qui declenche ton xprint ?
Si c'est toi, est tu en root pour le lancer, et à tu les droits en exécution comme le demande crabs ?
Messages postés
536
Date d'inscription
samedi 3 janvier 2004
Statut
Membre
Dernière intervention
14 janvier 2013
10
Salut,

Oui crabs j'ai les droits d'exécution et j'ai aussi essayer la commande que tu m'as proposé(chmod u+x /etc/init.d/xprint) et ça n'a rien changé.

J'ignore mamiemando ce qui déclenche ce xprint, c'est apparu comme ça sans que j'ai fait quoi que ce soit de particulier. Si je lance une konsole en root il n'y a pas ce message. Je ne comprend pas pourquoi c'est comme ça maintenant.

Merci à vous deux!
Messages postés
536
Date d'inscription
samedi 3 janvier 2004
Statut
Membre
Dernière intervention
14 janvier 2013
10
Finalement je vient de changer dans les propriétés de /etc/init.d/xprint les droit d'accès pour mon nom d'utilisateur dans la section "Appartenance", dans Utilisateur et Groupe, il y avait d'inscrit "root" alors j'ai changé tous ça pour mon nom d'utilisateur.

Maintenant je n'ai plus ce message de refus de permission.

Je ne sais pas si je commet une erreur en faisant mais bon... si vous en savez plus.

Merci
Messages postés
30211
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
20 octobre 2021
7 194
Heu alors là ce que tu as fait c'est mal. En gros c'est comme si ton profil utilisateur était maintenant root (à peu de chose près), autant dire que tu as un linux windowsien.

Peux tu me dire dans quelle condition l'erreur apparait pour le xprint ? UT lances un programme, c'est au demarrage, à l'extinction ? C'est toi qui a installé xprint, et si oui pour quoi faire ?
Messages postés
536
Date d'inscription
samedi 3 janvier 2004
Statut
Membre
Dernière intervention
14 janvier 2013
10
Je ne peut faire autrement car en le laissant en root j'ai toujours le message de premission refusé.

Ça se lance au démarrage dans les tty1...6 et lorsque je suis sous mon interface graphique(xfce4, gnome, kde, etc...) et que je lance une konsole alors j'ai le message en premier ligne.

Je n'ai pas installé xprint, il a toujours été là.

C'est quoi aujuste xprint?

Merci
Messages postés
536
Date d'inscription
samedi 3 janvier 2004
Statut
Membre
Dernière intervention
14 janvier 2013
10
Finalement j'ai supprimer le paquetage "xprt"(xprint), il s'était peut être installer lors de l'installation d'un autre paquetage.

Je n'ai pas d'imprimante et de toute façon rare sont les imprimantes qui fonctionne sous Linux.

Je vais considérer le problème comme résolu.

Merci