Fonction Si avec texte (excel 2003)

Résolu/Fermé
Dorian - 26 mars 2010 à 15:11
chossette9
Messages postés
4239
Date d'inscription
lundi 20 avril 2009
Statut
Contributeur
Dernière intervention
12 septembre 2014
- 26 mars 2010 à 15:29
Bonjour à tous,

Un petit problème qui j'espère trouvera une solution.
Je souhaite utiliser une fonction si de la forme suivante :

=SI(telle case se termine par "01"; telle valeur; sinon telle autre valeur)

cependant en tapent une formule de la forme ; =SI(A2="*01";....;....)
cela ne fonctionne pas.
Le texte contenu dans la case A2 est complexe et variable selon la situation, et je ne peux pas le prévoir, je sais juste qu'il terminera par 01 jusqu'à 16 et donc je souhaite utiliser ce critère pour déterminer les valeurs à afficher dans mon tableau.
Sachant que la fonction MAX.SI semble ne pas exister dans ma version d'excel et que la fonction BDMAX ne m'apporte pas la solution (car elle nécessite une mise en forme préalable des données) je n'ai à ce jour aucun moyen de discriminer mes données de manière automatique.

Merci beaucoup pour votre aide, j'espère avoir été suffisamment précis dans mes explications du problème.

Dorian

3 réponses

pijaku
Messages postés
12257
Date d'inscription
jeudi 15 mai 2008
Statut
Modérateur
Dernière intervention
3 septembre 2021
2 695
26 mars 2010 à 15:19
Salut,
=SI(DROITE(A1;2)="01";"telle valeur";"sinon telle autre valeur")
1
chossette9
Messages postés
4239
Date d'inscription
lundi 20 avril 2009
Statut
Contributeur
Dernière intervention
12 septembre 2014
1 310
Modifié par chossette9 le 26/03/2010 à 15:21
Bonjour,

je pense que tu devrais essayer ceci (un peu long mais ça doit fonctionner) :
=SI(OU(DROITE(A2;2)="01"; DROITE(A2;2)="02";DROITE(A2;2)="03";DROITE(A2;2)="04";DROITE(A2;2)="05";DROITE(A2;2)="06";DROITE(A2;2)="07";DROITE(A2;2)="08";DROITE(A2;2)="09";DROITE(A2;2)="10";DROITE(A2;2)="11";DROITE(A2;2)="12";DROITE(A2;2)="13";DROITE(A2;2)="14";DROITE(A2;2)="15";DROITE(A2;2)="16");...;...)


Cordialement.

P.S : il y a plus simple :

=SI(DROITE(A2;2)<"17";...;...)
0
Youpi! c'est génial! ça marche!
Merci beaucoup génies que vous êtes tous!
à bientôt!

Dorian
0
chossette9
Messages postés
4239
Date d'inscription
lundi 20 avril 2009
Statut
Contributeur
Dernière intervention
12 septembre 2014
1 310
26 mars 2010 à 15:29
J'ai encore une petite réserve à émettre sur ma 2e réponse (c'est ça de coder en direct !) : le problème est que quand la cellule est vide, il mettre la valeur si vrai, alors qu'il devrait mettre la valeur si faux. La formule devrait donc être :
=SI(A2<>"";SI(DROITE(A2;2)<"17";...);...)
0