Fct SOMMEPROD

Fermé
Signaler
-
Messages postés
10622
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
3 décembre 2021
-
Bonjour,

J'utilise régulièrement la formule sommeprod pour faire la somme d'une colonne sous conditions. Cependant, je tatonne toujours un peu avant de définir la vraie formule.

Ici, par exemple:

=SOMMEPROD((Annn!$B$2:$B$5000='DR Annuel'!B10)*(Annn!$E$2:$E$5000="JudoTatami")*(Annn!$G$2:$G$5000))

J'essaie de renvoyer, dans la feuille "DR Annuel", la somme de la colonne G de la feuille "Annn", sous conditions que les lignes renvoient la valeur B10 de la feuille DR Annuel en colonne B, et la valeur "JudoTatami" en colonne E.

Il me renvoie VALEUR.

Je finis toujours par y arriver normalement, mais où peut être l'erreur? Je pense qu'elle est liée au calcul sur une autre feuille, car pas de problèmes quand je travaille sur une seule feuille.

Merci à tous d'avance de votre aide.

4 réponses

Messages postés
10622
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
3 décembre 2021
1 239
Bonjour,
Juste au passage, essayez cette écriture :
=SOMMEPROD((Annn!$B$2:$B$5000='DR Annuel'!B10)*(Annn!$E$2:$E$5000="JudoTatami");Annn!$G$2:$G$5000)

2
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41989 internautes nous ont dit merci ce mois-ci

Messages postés
4804
Date d'inscription
dimanche 22 juillet 2007
Statut
Contributeur
Dernière intervention
7 octobre 2021
4 346
Bonsoir Jean Pierre

Parfait le tout petit ;
Je connaissais pas dans un sommeprod
et avec une valeur texte dans G, y'a plus l'erreur VALEUR
Messages postés
26309
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
3 décembre 2021
6 131
Bonjour
si la formule vous renvoie Valeur, c'est à priori qu'elle est correcte, mais qu'il y a dans la colonne G des entrées textes ou autres qui ne sont pas sommables.
Vérifiez s'il n'y a pas quelques valeurs textes, comme par exemple, ce qui est fréquent, une formule conditionnelle donnant en G un résultat ou bien "" (qu'il faudra alors remplacer par 0)?
Crdlmnt
Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 566
bonsoir à tous,

Je tombe par hasard sur ce sujet qui me surprend un peu car il suffit de lire l'aide :

SOMMEPROD : Multiplie les valeurs correspondantes des matrices spécifiées et calcule la somme de ces produits.

Syntaxe : SOMMEPROD(matrice1;matrice2;matrice3,...)

matrice1, matrice2, matrice3, ... représentent de 2 à 30 matrices dont vous voulez multiplier les valeurs pour ensuite additionner leur produit.

Notes :
- Les matrices spécifiées comme arguments doivent avoir la même dimension. Si tel n'est pas le cas, SOMMEPROD renvoie la valeur d'erreur #VALEUR!.
- SOMMEPROD affecte aux entrées de matrice non numériques la valeur zéro.


La tentation d'internet fait oublier que l'on a la réponse dans le logiciel comme l'a vu Le Pingou.
Messages postés
10622
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
3 décembre 2021
1 239
Merci gbinforme,
C'est aussi grâce à vos conseils d'il y a ......