SOMMEPROD SI avec condition

Résolu/Fermé
Alexandre99987 Messages postés 2 Date d'inscription vendredi 5 mai 2017 Statut Membre Dernière intervention 5 mai 2017 - 5 mai 2017 à 12:08
Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 - 5 mai 2017 à 14:02
Bonjour,

J'ai un problème avec une formule que je ne trouve pas...
J'ai des dates en colonne A, des pommes et des poires en colonne B et des prix en colonne C.
Je voudrais avoir la somme des prix par pommes et poires vendues mais par mois.

Est-ce possible ?

1 réponse

Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 6 289
Modifié le 5 mai 2017 à 12:21
Bonjour
pour une plage de ligne 2 à ligne 1000 à adapter
Date en A, produit en B, montant en C
pour janvier

=SOMMEPROD((MOIS($A$2:$A$1000)=1)*($B$2:$B$1000="poire")*($C$2:$C$1000))

;1) dans le 1° item étant le N° calendaire du mois cherché
(peut être remplacé par;LIGNE($A1) pour incrémenter automatiquement la formule sur 12 mois en tirant vers le bas

et bien sur, "poire" peut être remplacé par l'adresse d'une cellule qui contient le produit cherché


N° de ligne recommandés pour limiter les champs (plutôt A2:A1000 que A:A)


crdlmnt

La qualité de la réponse dépend surtout de la clarté de la question, merci!
1
Alexandre99987 Messages postés 2 Date d'inscription vendredi 5 mai 2017 Statut Membre Dernière intervention 5 mai 2017
5 mai 2017 à 13:48
Super! Merci beaucoup !
En fait je cherchais la complication mais cette formule est nickel !
0
Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 6 289 > Alexandre99987 Messages postés 2 Date d'inscription vendredi 5 mai 2017 Statut Membre Dernière intervention 5 mai 2017
Modifié le 5 mai 2017 à 14:03
Pas de quoi
je passe le sujet en résolu
Bonne route
crdlmnt
0