SOMMEPROD SI avec condition [Résolu/Fermé]

Signaler
Messages postés
2
Date d'inscription
vendredi 5 mai 2017
Statut
Membre
Dernière intervention
5 mai 2017
-
Messages postés
26101
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
20 juillet 2021
-
Bonjour,

J'ai un problème avec une formule que je ne trouve pas...
J'ai des dates en colonne A, des pommes et des poires en colonne B et des prix en colonne C.
Je voudrais avoir la somme des prix par pommes et poires vendues mais par mois.

Est-ce possible ?
A voir également:

1 réponse

Messages postés
26101
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
20 juillet 2021
5 987
Bonjour
pour une plage de ligne 2 à ligne 1000 à adapter
Date en A, produit en B, montant en C
pour janvier

=SOMMEPROD((MOIS($A$2:$A$1000)=1)*($B$2:$B$1000="poire")*($C$2:$C$1000))

;1) dans le 1° item étant le N° calendaire du mois cherché
(peut être remplacé par;LIGNE($A1) pour incrémenter automatiquement la formule sur 12 mois en tirant vers le bas

et bien sur, "poire" peut être remplacé par l'adresse d'une cellule qui contient le produit cherché


N° de ligne recommandés pour limiter les champs (plutôt A2:A1000 que A:A)


crdlmnt

La qualité de la réponse dépend surtout de la clarté de la question, merci!
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
2
Date d'inscription
vendredi 5 mai 2017
Statut
Membre
Dernière intervention
5 mai 2017

Super! Merci beaucoup !
En fait je cherchais la complication mais cette formule est nickel !
Messages postés
26101
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
20 juillet 2021
5 987 >
Messages postés
2
Date d'inscription
vendredi 5 mai 2017
Statut
Membre
Dernière intervention
5 mai 2017

Pas de quoi
je passe le sujet en résolu
Bonne route
crdlmnt