Utiliser le module Apachemod_rewrite Joomla

Résolu/Fermé
Signaler
Messages postés
27
Date d'inscription
samedi 27 février 2010
Statut
Membre
Dernière intervention
28 février 2010
-
 guillaume7272 -
Bonjour,

Je tente depuis deux heures d'tiliser le module Apachemod_rewrite (réécriture au 'vol' des URLs) de Joomla 1.5. J'ai bien renommé le fichier htaccess.txt en .htaccess mais j'ai toujours une erreur 500. Voici mon fichier :

##
# @version $Id: htaccess.txt 13415 2009-11-03 15:53:25Z ian $
# @package Joomla
# @copyright Copyright (C) 2005 - 2008 Open Source Matters. All rights reserved.
# @license http://www.gnu.org/licenses/gpl-3.0.html GNU/GPL
# Joomla! is Free Software
##


#####################################################
# READ THIS COMPLETELY IF YOU CHOOSE TO USE THIS FILE
#
# The line just below this section: 'Options +FollowSymLinks' may cause problems
# with some server configurations. It is required for use of mod_rewrite, but may already
# be set by your server administrator in a way that dissallows changing it in
# your .htaccess file. If using it causes your server to error out, comment it out (add # to
# beginning of line), reload your site in your browser and test your sef url's. If they work,
# it has been set by your server administrator and you do not need it set here.
#
#####################################################

## Can be commented out if causes errors, see notes above.
Options +FollowSymLinks

#
# mod_rewrite in use

RewriteEngine On

########## Begin - Rewrite rules to block out some common exploits
## If you experience problems on your site block out the operations listed below
## This attempts to block the most common type of exploit `attempts` to Joomla!
#
## Deny access to extension xml files (uncomment out to activate)
#<Files ~ "\.xml$">
#Order allow,deny
#Deny from all
#Satisfy all
#</Files>
## End of deny access to extension xml files
RewriteCond %{QUERY_STRING} mosConfig_[a-zA-Z_]{1,21}(=|\%3D) [OR]
# Block out any script trying to base64_encode crap to send via URL
RewriteCond %{QUERY_STRING} base64_encode.*\(.*\) [OR]
# Block out any script that includes a <script> tag in URL
RewriteCond %{QUERY_STRING} (\<|%3C).*script.*(\>|%3E) [NC,OR]
# Block out any script trying to set a PHP GLOBALS variable via URL
RewriteCond %{QUERY_STRING} GLOBALS(=|\[|\%[0-9A-Z]{0,2}) [OR]
# Block out any script trying to modify a _REQUEST variable via URL
RewriteCond %{QUERY_STRING} _REQUEST(=|\[|\%[0-9A-Z]{0,2})
# Send all blocked request to homepage with 403 Forbidden error!
RewriteRule ^(.*)$ index.php [F,L]
#
########## End - Rewrite rules to block out some common exploits

# Uncomment following line if your webserver's URL
# is not directly related to physical file paths.
# Update Your Joomla! Directory (just / for root)

# RewriteBase /


########## Begin - Joomla! core SEF Section
#
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !^/index.php
RewriteCond %{REQUEST_URI} (/|\.php|\.html|\.htm|\.feed|\.pdf|\.raw|/[^.]*)$ [NC]
RewriteRule (.*) index.php
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]
#
########## End - Joomla! core SEF Section


Quelqu'un a une idée ?? Merci de votre aide

10 réponses

Messages postés
27
Date d'inscription
samedi 27 février 2010
Statut
Membre
Dernière intervention
28 février 2010
4
Réglé, voici ce qu'il faut mettre dans le htaccess :

Options +followsymlinks
RewriteEngine On
RewriteCond %{REQUEST_FILENAME} !\.(jpg|jpeg|gif|png|css|js|pl|txt)$
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} ^(/component/option,com) [NC,OR]
RewriteCond %{REQUEST_URI} (/|\.htm|\.php|\.html|/[^.]*)$ [NC]
RewriteRule ^(.*) index.php [L]
3
Messages postés
1573
Date d'inscription
lundi 8 février 2010
Statut
Membre
Dernière intervention
17 octobre 2015
774
Bonjour, quel est votre hébergeur?
0
Messages postés
27
Date d'inscription
samedi 27 février 2010
Statut
Membre
Dernière intervention
28 février 2010
4
Bonjour,

Mon hébergeur est 1and1, je suis sous un serveur dédié avec Plesk... Merci
0
Messages postés
27
Date d'inscription
samedi 27 février 2010
Statut
Membre
Dernière intervention
28 février 2010
4
Petite relance... Quelqu'un peut m'aider svp ??
0
Messages postés
27
Date d'inscription
samedi 27 février 2010
Statut
Membre
Dernière intervention
28 février 2010
4
Personne n'a de connaissance sur mon problème ???
0
Messages postés
2
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
18 octobre 2010

Bonjour à tous,

je suis désespéré.. j'ai fouillé tous les forums et ca ne fonctionne tjs pas.

J'ai modifier le fichier htaccess.txt en .htaccess , j'ai remplacer ce qu'il contient par ce qui est ci-dessus.

Dans la configuration générale, j'ai mis "oui" aux trois configurations concernant le SEO.

Et ca m'affiche tjs une erreur 404..

que puis-je faire?

Merci d'avance de votre aide!!!!!

Vincent

PS: je suis tjs en local
0
Messages postés
2
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
18 octobre 2010

et en plus mtn j'ai plus qu'une page blanche qui s'affiche... à n'y plus rien comprendre...

SOS!! aidez-moi s'il vous plait!!!!
0
J'ai eu la même erreur que toi.
Faut remettre ton ancien htaccess.txt.
Enlever rewrite
Vide ton cache et hot cela refonctionne
0

Merci bcp pour ta réponse! mais je me suis débrouillé autrement!

Mais comme ca je saurai pour la prochaine fois!

Merci encore!!
0
Nombreux sont les forums où les gens trouvent la reponse et ne la donnent pas à ceux qui ont essayé de les aider .. :(
0
t'a raison LouRavi
0

Nous on a le droit savoir c'etait quoi ta manip? J'ai le meme problème !!
0

en fait je n'ai pas fait de manip moi-même!! j'ai demandé à un pote informaticien de me faire un 'reset' sauf en gardant quelques modifs de mon templates... donc pas de résolution direct!! sorry les gars!! autrement, j'aurais quand meme pris la peine de poster le réponse!!!
0
Salut à tous :)

La solution est donc ( mieux vaut tard que jamais :p ) :

1) Dans le fichier "htaccess.txt" (celui fourni avec joomla), à la ligne "# RewriteBase /" il faut enlever le # pour obtenir "RewriteBase /".

2) Renomer le fichier "htaccess.txt" en ".htaccess".

Et en pricipe, le problème est résolu (pour ceux qui sont chez 1and1).
0

Merci merci merci merci !!!!!!!!!!!!!!!!!!!!!!!
0