Excel condition si virgule

Résolu/Fermé
informatifien Messages postés 741 Date d'inscription lundi 18 mai 2009 Statut Membre Dernière intervention 10 janvier 2016 - 5 nov. 2009 à 08:17
informatifien Messages postés 741 Date d'inscription lundi 18 mai 2009 Statut Membre Dernière intervention 10 janvier 2016 - 5 nov. 2009 à 09:24
Bonjour bonjour,

Voilà juste une petite question, y-a t'il une formule pour dire si A1 a un chiffre après la virgule afficher 1 ?

En gros j'affiche des chiffres qui seront ou en virgule 5 ou pas si oui je voudrai 1 en A2 si non je voudrai 0, j'ai essayé ça : =SI(A1="#,5";1;0) mais ça m'affiche 0, je pense que c'est un problème de synthaxe au niveau du 0.5 . . .

Si quelqu'un a une idée . .

Merci d'avance

A voir également:

2 réponses

gbinforme Messages postés 14935 Date d'inscription lundi 18 octobre 2004 Statut Contributeur Dernière intervention 24 juin 2020 4 628
5 nov. 2009 à 09:13
bonjour

Tu ne peux pas le faire avec ta formule car tu utilises un format et non une valeur par contre tu as bien d'autres possibilités.

=SI( A1-ENT(A1)=0;0;1)
ou
=SI(MOD(A1;1)=0;0;1)
ou
=SI( A1=ENT(A1);0;1)
ou
=SI(MOD(A1;1);1;0)

par exemple

Tu n'as peut-être pas besoin de ta colonne car tu peux ensuite écrire

=SI(MOD(A1;1);"décimale";"entier")
1
informatifien Messages postés 741 Date d'inscription lundi 18 mai 2009 Statut Membre Dernière intervention 10 janvier 2016 93
5 nov. 2009 à 09:24
Merci ben je m'apprétai à reposer mieux ma question car en faite c'est si A1 entier afficher 0 sinon 1, et j'était justement en train de tester des formule avec ent j'y étais presque mais tu viens de me faire gagner du temps ;)

Merci beaucoup
0