EXCEL FORMULE FORMAT DATE [Résolu/Fermé]

Signaler
Messages postés
226
Date d'inscription
mardi 24 juillet 2007
Statut
Membre
Dernière intervention
10 janvier 2017
-
Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
-
Bonjour à toutes et tous,

Je fais appel à vous car je ne m'en sors pas avec le format date dans excel.
Je m'explique:
Je dois vérifier la compatibilité d'une date de naissance avec un n° de sécu (exemple ci-dessous)
J'arrive à récupérer les données date de naissance du numéro de sécu grâce à la formule DROITE et GAUCHE
Par contre je ne m'en sors pas avec la date de naissance, à cause des formats que je maîtrise mal, j'ai essayé d'utiliser les formules année et mois mais ces données semblent être obligatoirement de format aaaa et m.
Quelqu'un peut-il m'éclairer sur ce point?
D'avance merci (j'ai également mis un lien cjoint vers l'exemple)

naissance n°INSEE ANNEE DND MOIS DND CONCA DND 5 1ers INSEE DND INSEE
27/03/80 2800394075053 1980 3 28003 8003
29/08/75 1750875115183 1975 8 17508 7508
12/03/06 1851178158056 2006 3 18511 8511


https://www.cjoint.com/?kBh4t2ecB7
A voir également:

6 réponses

Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 349
bonjour

Pour obtenir l'année du numéro INSEE tu peux utiliser :
=(SI(STXT(B2;2;2)<"09";20;19)&STXT(B2;2;2))*1



Pour obtenir le mois du numéro INSEE tu peux utiliser :
=STXT(B2;4;2)*1


Messages postés
226
Date d'inscription
mardi 24 juillet 2007
Statut
Membre
Dernière intervention
10 janvier 2017
184
Mon souci n'est pas pour récupérer l'INSEE mais la date de naissance
Je ne peux pas utiliser la fonction DROITE car ca ne fonctionne pas avec le format date
En fait, il faudrait qe je puisse à partir de la date au format date 01/01/1900 récupérer une donnée 01011900 en format standard
Je ne sais pas si c'est très clair....

En tout cas merci de ton aide
Messages postés
12247
Date d'inscription
jeudi 15 mai 2008
Statut
Modérateur
Dernière intervention
10 février 2021
2 573 >
Messages postés
226
Date d'inscription
mardi 24 juillet 2007
Statut
Membre
Dernière intervention
10 janvier 2017

Salut,
Excusez l'incruste. Tu trouveras ci-joint ton fichier avec la formule qui va bien en colonne E, le test 1 en colonne H et un deuxième test sous forme d'une mise en forme conditionnelle qui colorie la cellule colonne B lorsque le n° INSEE ne correspond pas à la date de naissance.
C'est un premier jet, il est possible de simplifier ton tableau pour n'avoir que 3 (ou 2) colonnes. A toi de bricoler un peu et de revenir si tu as d'autres questions.
Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 349
bonjour

il faudrait qe je puisse à partir de la date au format date 01/01/1900 récupérer une donnée 01011900 en format standard

Pour avoir ta date sous ce format jjmmaaaa tu peux utiliser :
=TEXTE(JOUR(A2);"00")&TEXTE(MOIS(A2);"00")&TEXTE(ANNEE(A2);"0000")
que puis je faire? en entrant cette formule pour que ca prend automatiquement la date du jour
Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 349 > Dave
Bonjour,

Ainsi tu prends automatiquement la date du jour :
=TEXTE(JOUR(AUJOURDHUI());"00")&TEXTE(MOIS(AUJOURDHUI());"00")&TEXTE(ANNEE(AUJOURDHUI());"0000")

mais ta date changera tous les jours bien sûr !
bonsoir, et si je ne veux pas que ca change tous les jours, qu'elle reste statique
Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 349 > Dave
bonsoir,
Dans ce cas il faut soit la saisir manuellement (ctrl+; par exemple) soit passer par une petite macro qui sauvegarde la valeur.
Messages postés
226
Date d'inscription
mardi 24 juillet 2007
Statut
Membre
Dernière intervention
10 janvier 2017
184
Merci beaucoup pour votre aide,

Je m'en suis sortie en rajoutant juste un zéro pour trouver le mois ="0"&MOIS(A2) et en concaténant le résultat
https://www.cjoint.com/?kBi1lMnMnx

Par contre, sans vouloir abuser de votre gentillesse, ça m'arrangerait pas mal d'avoir moins de colonnes, n'est-il pas possible de passer de 15/06/1980 à 8006 en une seule formule?

Encore merci...
Messages postés
226
Date d'inscription
mardi 24 juillet 2007
Statut
Membre
Dernière intervention
10 janvier 2017
184
genre avec la formule de gbinforme
=TEXTE(JOUR(A2);"00")&TEXTE(MOIS(A2);"00")&TEXTE(ANNEE(A2);"0000")
Je l'ai modifié en :
=TEXTE(MOIS(A2);"00")&TEXTE(ANNEE(A2);"00")
mais il me sort une donnée mmaaaa
Comment faire pour n'avoir que les 2 derniers chiffres de l'année?
Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 349
bonjour

La formule peut être :

=DROITE(ANNEE(A2);2)&TEXTE(MOIS(A2);"00")


voici ton exemple avec la formule complète dans la mise en forme conditionnelle et tu peux donc supprimer les deux colonnes test qui ne sont que de la figuration :

http://www.cijoint.fr/cjlink.php?file=cj200910/cijnCxv1Cc.xls
Messages postés
226
Date d'inscription
mardi 24 juillet 2007
Statut
Membre
Dernière intervention
10 janvier 2017
184
merci beaucoup c'est exactement ce que je voulais et puis j'aurais solutionné le problème très rapidement
Vous souhaite une excellente journée

klr