Extraire des données d'un tableau sous Excel

[Résolu/Fermé]
Signaler
Messages postés
1
Date d'inscription
lundi 5 octobre 2009
Statut
Membre
Dernière intervention
5 octobre 2009
-
Messages postés
26192
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 septembre 2021
-
Bonjour,
J'aimerais extraire des lignes de donnée de la feuille 2 en rentrant un numéro dans la cellule A1 de la feuille 1.

Exemple : je tape « A08180 » dans la cellule A1 de la feuille1, je voudrais en A2 de la même feuille, extraire dans la feuille2 la ligne de mon tableau qui correspond à ce numéro dans la colonne A.

Merci pour votre aide.

Franck.

PS EXCEL 2003 sp3

1 réponse

Messages postés
26192
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 septembre 2021
6 062
Bonsoir
Si votre champ initial va de A1 à Z 100par exemple, sélectionnez le et nommez le, c'est plus simple ensuite pour ecrire les formules:
donc sur la feuille d'entrée (pour l'exemple):
sélectionnez le champ (A1:Z100) et
Barre d'outil / Insertion / Nom/ Définir et entrez un nom pour ex: CHAMP
sur votre feuille de résultat:
en A1: le code cherché
en B1 la formule:
=SI($A1=0;"";RECHERCHEV($A1;CHAMP;COLONNE(B:B);0))et tirez cette formule sur la longueur de la ligne à remplir
pour descendre ensuite le tableau, si besoin, en dessous de A1:
sélectionnez cette ligne de formule et tirez le tout vers le bas:
Un conseil:
pour remplir votre colonne A vous pouvez avoir un menu déroulant issu de la colonne A d'entrée (ça évite les fautes de frappes):
sur la feuille entrée, nommée la colonne : par ex "CODE"
sur la feuille résultat:
sélectionnez la colonne A sur la hauteur du tableau:
données / validation/ dans la fenêtre, en bas, entrez :
=CODE
bon courage
Crdlmnt



1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 42674 internautes nous ont dit merci ce mois-ci