Probleme reseau ss linux mandrake

Fermé
comperta - 28 sept. 2004 à 08:17
 Medi_** - 23 déc. 2004 à 05:53
Bonjour,

j'ai actuellement trois pc :

un sous linux (appelons le mdk)
et deux sous XP (appelons les xp1 et xp2)

je souhaite que mdk soit relié à internet via mon modem USB sagem fast 908
et qu'il partage la connection au reseau local pour que mes pc xp1 et xp2 puissent aussi y acceder.

j'arrive à configurer mon reseau local , mais une fois que je configure internet, plus rien ne marche.

inversement si je commence par configurer internet, cela fonctionne (la preuve je suis sur mdk) mais des que je veux configurer mon reseau plus rien ne marche.

j'ai essayer de pinger mes machines une fois que plus rien en marche resultat 100 % des paquets perdu

j'ai taper ifconfig en etant root et le pc mdk me reconnait bien PPP0(adsl) et eth0 avec chacun une adresse iP

lorsque je tente de pinger ces adresses : 100 % des paquets perdu

de plus je viens de changer de version de linux , n'y arrivant pas ss madrake 10.0 j'ai installer mandrake 10.1

Sinon j'ai aussi un probleme de carte reseau inexistante :
linux me trouve un eth1 qui semble etre une copie conforme de eth0,
le probleme c'est que eth1 n'est pas dans ma config materiel (centre de controle mandrake linux => materiel)
je me demande si eth1 n'est pas la prise ethernet du modem .

merci d'avance pour votre aide

Comperta

73 réponses

jipicy
Messages postés
40805
Date d'inscription
jeudi 28 août 2003
Statut
Modérateur
Dernière intervention
10 août 2020
4 898
28 sept. 2004 à 08:35
Salut,

je me demande si eth1 n'est pas la prise ethernet du modem .
Si. Les modems USB sont émulés comme des cartes réseau.

Que renvoie la commande :
ifconfig
en root, ou
/sbin/ifconfig
en tant qu'utilisateur ?

La doc de Mandrake 10 est sortie, fais-y un tour pour ta connexion et ton partage, tout est expliqué là :
http://doc.mandrakelinux.com/MandrakeLinux/100/fr/Starter.html/mcc-network.html

;-))

Z'@+...che.
JP : Zen, my Nuggets ! ;-)
0
Merci pour cette reponse rapide !!

j'ai deja parcourue la doc, et je suis à la lettre les instructions sans grand succes :-(

actuellement en tant que root ou utilisateur j'obtient :

eth1      Lien encap:Ethernet  HWaddr 00:60:4C:3F:13:49
          adr inet6: fe80::260:4cff:fe3f:1349/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:65535  Metric:1
          RX packets:7784 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6601 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000
          RX bytes:5741798 (5.4 Mb)  TX bytes:1094129 (1.0 Mb)

lo        Lien encap:Boucle locale
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:373 errors:0 dropped:0 overruns:0 frame:0
          TX packets:373 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0
          RX bytes:33146 (32.3 Kb)  TX bytes:33146 (32.3 Kb)

ppp0      Lien encap:Protocole Point-à-Point
          inet adr:62.147.147.177  P-t-P:192.168.254.254  Masque:255.255.255.255          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1492  Metric:1
          RX packets:5311 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4597 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:3
          RX bytes:4011006 (3.8 Mb)  TX bytes:679883 (663.9 Kb)


eth0 n'apparait pas car je ne l'ai pas configuré (sinon je perd ma connection)
mais si tu veux je peux volontairement planter ma connection et te copier/coller ifconfig ?

Comperta
0
comperta > comperta
28 sept. 2004 à 09:05
voila j'ai pris un peu d'avance ;-)

j'ai configurer mon reseau local puis j'ai partagé ma connection et enfin j'ai fai un ifconfig :

eth0      Lien encap:Ethernet  HWaddr 00:02:B3:29:22:0E
          inet adr:192.168.1.1  Bcast:192.168.1.255  Masque:255.255.255.0
          adr inet6: fe80::202:b3ff:fe29:220e/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:149 errors:0 dropped:0 overruns:0 frame:0
          TX packets:74 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000
          RX bytes:9606 (9.3 Kb)  TX bytes:10403 (10.1 Kb)
          Interruption:5 Adresse de base:0x8000

eth1      Lien encap:Ethernet  HWaddr 00:60:4C:3F:13:49
          adr inet6: fe80::260:4cff:fe3f:1349/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:65535  Metric:1
          RX packets:8592 errors:0 dropped:0 overruns:0 frame:0
          TX packets:7241 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000
          RX bytes:6557750 (6.2 Mb)  TX bytes:1171321 (1.1 Mb)

lo        Lien encap:Boucle locale
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:398 errors:0 dropped:0 overruns:0 frame:0
          TX packets:398 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0
          RX bytes:36030 (35.1 Kb)  TX bytes:36030 (35.1 Kb)

ppp0      Lien encap:Protocole Point-à-Point
          inet adr:82.65.64.21  P-t-P:212.27.32.170  Masque:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1492  Metric:1
          RX packets:3 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:3
          RX bytes:54 (54.0 b)  TX bytes:54 (54.0 b)


une fois que j'ai fait ça, impossible de pinger mes autres machines ni mm www.google.fr

par contre j'arrive à pinger mes deux adresses (reseau local (192.168.1.1) et internet (82.65.64.21) )

pour retrouver internet j'ai du supprimer les deux connections et reconfigurer l'adsl.

Comperta
0
jipicy
Messages postés
40805
Date d'inscription
jeudi 28 août 2003
Statut
Modérateur
Dernière intervention
10 août 2020
4 898
28 sept. 2004 à 11:36
Re-

par contre j'arrive à pinger mes deux adresses (reseau local (192.168.1.1) et internet (82.65.64.21) )
Si tu pinges le Net c'est que ta connexion est bonne, par contre c'est un problème de DNS alors !
Regarde ce que tu as dans le fichier "/etc/resolv.conf". Tu devrais y trouver un truc du genre :
nameserver xxx.xxx.xxx.xxx
nameserver xxx.xxx.xxx.xxx

Ou "xxx.xxx.xxx.xxx" correspond au serveur DNS de ton FAI.

;-))

Z'@+...che.
JP : Zen, my Nuggets ! ;-)
0
re

j'ai donc mis les DNS par defaut donné par free a savoir :

212.27.32.176
212.27.32.177

et la aucun changement

par contre j'ai oublié un petit detail :
je pinge le net effectivement mais mon probleme c'est qu'il me met :
impossible de joindre l'hôte de destination

mais il considerer qu'il y a 0 paquets de perdu

j'aitrouvé un moyen d' eviter ce probleme , mais cela me bloque mon reseau local :


j'utilise la comande suivante :

$ route add default gw yyy.yyy.yyy.yyy ppp0


ou yyy.yyy.yyy.yyy represente mon ip adsl trouvé grace a ifconfig :
inet adress : yyy.yyy.yyy.yyy

je retrouve ma connection internet mais tjs pas ce satané reseau
si je refait un ifconfig j'obtient :

eth0      Lien encap:Ethernet  HWaddr 00:02:B3:29:22:0E
          inet adr:192.168.0.1  Bcast:192.168.0.255  Masque:255.255.255.0
          adr inet6: fe80::202:b3ff:fe29:220e/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:62 errors:0 dropped:0 overruns:0 frame:0
          TX packets:354 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000
          RX bytes:6407 (6.2 Kb)  TX bytes:23236 (22.6 Kb)
          Interruption:12 Adresse de base:0xf000

eth1      Lien encap:Ethernet  HWaddr 00:60:4C:3F:13:49
          adr inet6: fe80::260:4cff:fe3f:1349/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:65535  Metric:1
          RX packets:1642 errors:0 dropped:0 overruns:0 frame:0
          TX packets:306 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000
          RX bytes:311730 (304.4 Kb)  TX bytes:30203 (29.4 Kb)

lo        Lien encap:Boucle locale
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:409 errors:0 dropped:0 overruns:0 frame:0
          TX packets:409 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0
          RX bytes:42692 (41.6 Kb)  TX bytes:42692 (41.6 Kb)

ppp0      Lien encap:Protocole Point-à-Point
          inet adr:82.65.117.42  P-t-P:192.168.254.254  Masque:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1492  Metric:1
          RX packets:1612 errors:0 dropped:0 overruns:0 frame:0
          TX packets:270 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:3
          RX bytes:308071 (300.8 Kb)  TX bytes:23371 (22.8 Kb)



si je fais ping www.google.fr j'obtient :
PING www.google.akadns.net (64.233.161.104) 56(84) bytes of data.
64 bytes from 64.233.161.104: icmp_seq=1 ttl=248 time=143 ms
64 bytes from 64.233.161.104: icmp_seq=2 ttl=248 time=151 ms
64 bytes from 64.233.161.104: icmp_seq=3 ttl=248 time=143 ms

--- www.google.akadns.net ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2001ms
rtt min/avg/max/mdev = 143.443/146.271/151.583/3.784 ms


PING 212.227.127.73 (212.227.127.73) 56(84) bytes of data.
64 bytes from 212.227.127.73: icmp_seq=1 ttl=52 time=74.5 ms
64 bytes from 212.227.127.73: icmp_seq=2 ttl=52 time=66.3 ms

--- 212.227.127.73 ping statistics ---
3 packets transmitted, 2 received, 33% packet loss, time 2002ms
rtt min/avg/max/mdev = 66.352/70.462/74.573/4.119 ms


j'en deduis donc que niveau adsl ma connection est ok, avec les dns bien renseigné !!

par contre niveau reseau local :
je pinge ma machine xp et j'obtient :

PING 192.168.0.4 (192.168.0.4) 56(84) bytes of data.
64 bytes from 192.168.0.4: icmp_seq=1 ttl=128 time=0.352 ms
64 bytes from 192.168.0.4: icmp_seq=2 ttl=128 time=0.229 ms

--- 192.168.0.4 ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1000ms
rtt min/avg/max/mdev = 0.229/0.290/0.352/0.063 ms


mais a partir d'xp vers linux , j'ai tjs le message impossible de joindre l'hôte de destination

de plus en utilisant la fonction smb:/// dans nautilus je devrais voir les pc de mon reseau local ,et la je vois rien ...

si vous avez une idée ....

merci encore jipicy du temps que tu passe pour mon probleme

Comperta
0
salut,
j'ai exactement la meme config que toi et les meme soucie.
sauf que moi je n'arrive meme pas a pinger mon xp depuis ma mdk ...
si tu as quelques solution a me donner je suis preneur ...
merci d'avance .
nico.
0
comperta
Messages postés
18
Date d'inscription
mardi 28 septembre 2004
Statut
Membre
Dernière intervention
30 novembre 2004

30 oct. 2004 à 20:00
Si tu veux on peut chercher ensemble , mon probleme n'etant toujours pas resolu ...

pour le moment j'ai virer ma connection reseau local et je cherche sur des revues ou sur le net une solution !!

Comperta
0
passa > comperta
Messages postés
18
Date d'inscription
mardi 28 septembre 2004
Statut
Membre
Dernière intervention
30 novembre 2004

31 oct. 2004 à 11:48
oueh ... je suis en train de devenir fou ...
en désepoire j'ai réinstaller la mandrake avec un niveau de sécurité faible...
mais toujours impossible de faire le moindre ping vers mon xp ou de pinger mon linux ...
tu arrive a creer ton reseau local toi ??
si c'est le cas je suis preneur pour n'importe quel conseil ....
0
comperta
Messages postés
18
Date d'inscription
mardi 28 septembre 2004
Statut
Membre
Dernière intervention
30 novembre 2004
> comperta
Messages postés
18
Date d'inscription
mardi 28 septembre 2004
Statut
Membre
Dernière intervention
30 novembre 2004

31 oct. 2004 à 11:57
en fait j'arrive a faire deux choses :

un reseau local mais le modem n'est pas branché

une connection internet mais la carte reseau n'est pas branché


si j'essai de brancher les deux, j'ai un conflit que j'arrive pas a resoudre, visiblement linux tente de se connecter a internet en passant par ma carte reseau ...


pour mon reseau local j'ai eu un probleme tout con : les deux pc avait la meme adresse IP , verifie tes adresses.

sinon detail moi les etapes que tu as effectué et on verra si je peut t'aider !!


Comperta
0
passa > comperta
Messages postés
18
Date d'inscription
mardi 28 septembre 2004
Statut
Membre
Dernière intervention
30 novembre 2004

31 oct. 2004 à 15:26
je viens enfin de réussir a pinger mon xp .
enfaite j'avais vue dans un poste qu'il conseiller de changer l'ip de xp en ne mettant pas 1 sur la fin .(ex: pas de 192.168.0.1)
j'ai donc tester en .20 et ca ne marchais tjs pas...
entre temps j'ai fait un ptit repas familliale agrémenté de 3 bouteille de
champ et la au final je viens de refaire un test et au miracle ca marche ....
maintenant que j'ai le reseau je vais essayer de cumuler ca avec la connexion internet et je te tiens au courant de l'évolution.
0
Ben... pour moi, ça ressemble tout à fait à un problème de routage, ce qui est confirmé par la manip de Comperta quelques posts plus haut.

Je suis sous la 10.1 et j'ai en effet aussi eu le problème de la table de routage qui ne se met pas à jour... et après recherches, il s'est avéré que la cause en était la configuration de ma carte eth0 pour laquelle j'avais spécifié une adresse de passerelle par défault.

Bref, faites un essaie de modifier vos connexions ethX en supprimant la passerelle par défaut (laisser le champ vide) et pour chaque modification faire "Appliquer" et "OK". (Oui c'est un peu long, mais un autre bug fait qui si on en change plusieurs, seule la dernière est enregistrée!)

Après avoir modifié les ethX, terminer par la reconfiguration de ppp0.

En cas de souci, la premire chose à voir, c'est la commande "route" pour vérifier qu'il a bien pris la route par défaut vers ppp0.

s'il manque des routes, un ifconfig sera toujours utile pour vérifier que toutes les interfaces sont bien démarrées!
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
Durand Daniel
5 nov. 2004 à 12:40
François,

You are the best !

Je partage de nouveau ma connection ADSL entre le PC Mandrake 10.1 et un portable Mandrake 10.0, un PC Win98, un portable Win XP.
Par contre au niveau réseau, je ne vois rien à partir de mon PC central.
Par contre le réseau fonctionne entre mes postes sous windows e tmon portable sous Linux. depuis windows, je peux entre dans ce portable Linux. Par contre de ce portable Linux, configuré en serveur Samba, je vois les postes windows mais nepeux entrer dedans;
Comment configurer avec l'interface graphique de préférence mon poste principal sous Mandrake 10.1 pour faire fonctionner le réseau à partir de lui.
0
comperta
Messages postés
18
Date d'inscription
mardi 28 septembre 2004
Statut
Membre
Dernière intervention
30 novembre 2004

5 nov. 2004 à 14:15
Donc se srait un bete probleme de routage, j'aurais du continuer a explorer cette piste.

Un Grand Merci Pour l'info et pour votre aide


je rentre chez moi et je test ça, peut etre apres avoir reinstallé mandrake (histoire de repartir d'une version propre, car là mon adsl 2048 ressemble presque à une connection bas debit)



Comperta
0
Durand Daniel
5 nov. 2004 à 18:29
Bonjour,

je reposte car mon message précédent était confus.
1/ j'ai réglé le problème de partage de connexion
2/ je n'ia pas réglé mon problème de réseau : impossible de pinguer les autres postes et vis de versa
3/ j'ai toujours un problème bizarre :
impossible de me connecter au site hébergeur d emon nom de domaine ni de relever le courrier (alors que je peux le faire sous windows) :
si je pingue le site, voici le résultat :
bash-2.05b$ ping citeglobe.com
PING citeglobe.com (216.187.90.69) 56(84) bytes of data.
64 bytes from www.citeglobe.com (216.187.90.69): icmp_seq=1 ttl=234 time=156 ms
64 bytes from www.citeglobe.com (216.187.90.69): icmp_seq=2 ttl=234 time=152 ms
64 bytes from www.citeglobe.com (216.187.90.69): icmp_seq=3 ttl=234 time=153 ms
64 bytes from www.citeglobe.com (216.187.90.69): icmp_seq=4 ttl=234 time=153 ms
64 bytes from www.citeglobe.com (216.187.90.69): icmp_seq=5 ttl=234 time=153 ms
64 bytes from www.citeglobe.com (216.187.90.69): icmp_seq=6 ttl=234 time=154 ms
64 bytes from www.citeglobe.com (216.187.90.69): icmp_seq=7 ttl=234 time=154 ms

--- citeglobe.com ping statistics ---
7 packets transmitted, 7 received, 0% packet loss, time 6004ms
rtt min/avg/max/mdev = 152.884/154.113/156.169/1.020 ms

Ou est l'erreur ?

Daniel
0
Firewall... (enfin, je pense!)

Si tes window$ passent et que ton ping passe depuis linux, ben... alors ta connexion est bonne et la tables de routage et bonne. Je ne vois donc plus que je firewall.

(Idem pour tes problèmes internes : n'y a-t-il pas un firewall XP qui traîne par là...?!)

Si tu as iptables sur ton linux (je suppose si tu partage ta connexion), alors un petit "iptables -L" devrait donner un bon résumé.
0
Durand Daniel
5 nov. 2004 à 22:55
Effectivement, il semble y avoir un problème. J'ai l'impression que l'outil firewall de Mandrake ne garde pas les exceptions que l'on rentre et bloque tout.
Est-ce cela ?

[root@pucs-4ak8@9onlineadsl512 durand_gnome]# iptables -L
Chain INPUT (policy DROP)
target prot opt source destination
ACCEPT all -- anywhere anywhere
DROP !icmp -- anywhere anywhere state INVALID
ppp_in all -- anywhere anywhere
eth0_in all -- anywhere anywhere
eth1_in all -- anywhere anywhere
Reject all -- anywhere anywhere
LOG all -- anywhere anywhere LOG level info prefix `Shorewall:INPUT:REJECT:'
reject all -- anywhere anywhere

Chain FORWARD (policy DROP)
target prot opt source destination
DROP !icmp -- anywhere anywhere state INVALID
ppp_fwd all -- anywhere anywhere
eth0_fwd all -- anywhere anywhere
eth1_fwd all -- anywhere anywhere
Reject all -- anywhere anywhere
LOG all -- anywhere anywhere LOG level info prefix `Shorewall:FORWARD:REJECT:'
reject all -- anywhere anywhere

Chain OUTPUT (policy DROP)
target prot opt source destination
ACCEPT all -- anywhere anywhere
DROP !icmp -- anywhere anywhere state INVALID
fw2net all -- anywhere anywhere
fw2loc all -- anywhere anywhere
fw2loc all -- anywhere anywhere
Reject all -- anywhere anywhere
LOG all -- anywhere anywhere LOG level info prefix `Shorewall:OUTPUT:REJECT:'
reject all -- anywhere anywhere

Chain Drop (1 references)
target prot opt source destination
RejectAuth all -- anywhere anywhere
dropBcast all -- anywhere anywhere
dropInvalid all -- anywhere anywhere
DropSMB all -- anywhere anywhere
DropUPnP all -- anywhere anywhere
dropNotSyn all -- anywhere anywhere
DropDNSrep all -- anywhere anywhere

Chain DropDNSrep (2 references)
target prot opt source destination
DROP udp -- anywhere anywhere udp spt:domain

Chain DropSMB (1 references)
target prot opt source destination
DROP udp -- anywhere anywhere udp dpt:135
DROP udp -- anywhere anywhere udp dpts:netbios-ns:netbios-ssn
DROP udp -- anywhere anywhere udp dpt:microsoft-ds
DROP tcp -- anywhere anywhere tcp dpt:135
DROP tcp -- anywhere anywhere tcp dpt:netbios-ssn
DROP tcp -- anywhere anywhere tcp dpt:microsoft-ds

Chain DropUPnP (2 references)
target prot opt source destination
DROP udp -- anywhere anywhere udp dpt:1900

Chain Reject (4 references)
target prot opt source destination
RejectAuth all -- anywhere anywhere
dropBcast all -- anywhere anywhere
dropInvalid all -- anywhere anywhere
RejectSMB all -- anywhere anywhere
DropUPnP all -- anywhere anywhere
dropNotSyn all -- anywhere anywhere
DropDNSrep all -- anywhere anywhere

Chain RejectAuth (2 references)
target prot opt source destination
reject tcp -- anywhere anywhere tcp dpt:auth

Chain RejectSMB (1 references)
target prot opt source destination
reject udp -- anywhere anywhere udp dpt:135
reject udp -- anywhere anywhere udp dpts:netbios-ns:netbios-ssn
reject udp -- anywhere anywhere udp dpt:microsoft-ds
reject tcp -- anywhere anywhere tcp dpt:135
reject tcp -- anywhere anywhere tcp dpt:netbios-ssn
reject tcp -- anywhere anywhere tcp dpt:microsoft-ds

Chain all2all (1 references)
target prot opt source destination
ACCEPT all -- anywhere anywhere state RELATED,ESTABLISHED
Reject all -- anywhere anywhere
LOG all -- anywhere anywhere LOG level info prefix `Shorewall:all2all:REJECT:'
reject all -- anywhere anywhere

Chain dropBcast (2 references)
target prot opt source destination
DROP all -- anywhere anywhere PKTTYPE = broadcast
DROP all -- anywhere anywhere PKTTYPE = multicast

Chain dropInvalid (2 references)
target prot opt source destination
DROP all -- anywhere anywhere state INVALID

Chain dropNotSyn (2 references)
target prot opt source destination
DROP tcp -- anywhere anywhere tcp flags:!SYN,RST,ACK/SYN

Chain dynamic (6 references)
target prot opt source destination

Chain eth0_fwd (1 references)
target prot opt source destination
dynamic all -- anywhere anywhere state INVALID,NEW
loc2net all -- anywhere anywhere
ACCEPT all -- anywhere anywhere

Chain eth0_in (1 references)
target prot opt source destination
dynamic all -- anywhere anywhere state INVALID,NEW
loc2fw all -- anywhere anywhere

Chain eth1_fwd (1 references)
target prot opt source destination
dynamic all -- anywhere anywhere state INVALID,NEW
loc2net all -- anywhere anywhere
ACCEPT all -- anywhere anywhere

Chain eth1_in (1 references)
target prot opt source destination
dynamic all -- anywhere anywhere state INVALID,NEW
loc2fw all -- anywhere anywhere

Chain fw2loc (2 references)
target prot opt source destination
ACCEPT all -- anywhere anywhere state RELATED,ESTABLISHED
ACCEPT all -- anywhere anywhere

Chain fw2net (1 references)
target prot opt source destination
ACCEPT all -- anywhere anywhere state RELATED,ESTABLISHED
ACCEPT tcp -- anywhere anywhere tcp dpt:http
ACCEPT tcp -- anywhere anywhere tcp dpt:http
ACCEPT all -- anywhere anywhere

Chain icmpdef (0 references)
target prot opt source destination

Chain loc2fw (2 references)
target prot opt source destination
ACCEPT all -- anywhere anywhere state RELATED,ESTABLISHED
ACCEPT tcp -- anywhere anywhere tcp dpt:squid
ACCEPT tcp -- anywhere anywhere tcp dpt:squid
all2all all -- anywhere anywhere

Chain loc2net (2 references)
target prot opt source destination
ACCEPT all -- anywhere anywhere state RELATED,ESTABLISHED
ACCEPT all -- anywhere anywhere

Chain net2all (3 references)
target prot opt source destination
ACCEPT all -- anywhere anywhere state RELATED,ESTABLISHED
Drop all -- anywhere anywhere
LOG all -- anywhere anywhere LOG level info prefix `Shorewall:net2all:DROP:'
DROP all -- anywhere anywhere

Chain ppp_fwd (1 references)
target prot opt source destination
dynamic all -- anywhere anywhere state INVALID,NEW
net2all all -- anywhere anywhere
net2all all -- anywhere anywhere

Chain ppp_in (1 references)
target prot opt source destination
dynamic all -- anywhere anywhere state INVALID,NEW
net2all all -- anywhere anywhere

Chain reject (11 references)
target prot opt source destination
DROP all -- anywhere anywhere PKTTYPE = broadcast
DROP all -- anywhere anywhere PKTTYPE = multicast
DROP all -- 192.168.1.255 anywhere
DROP all -- 255.255.255.255 anywhere
DROP all -- BASE-ADDRESS.MCAST.NET/4 anywhere
REJECT tcp -- anywhere anywhere reject-with tcp-reset
REJECT udp -- anywhere anywhere reject-with icmp-port-unreachable
REJECT icmp -- anywhere anywhere reject-with icmp-host-unreachable
REJECT all -- anywhere anywhere reject-with icmp-host-prohibited

Chain shorewall (0 references)
target prot opt source destination

Chain smurfs (0 references)
target prot opt source destination
LOG all -- 192.168.1.255 anywhere LOG level info prefix `Shorewall:smurfs:DROP:'
DROP all -- 192.168.1.255 anywhere
LOG all -- 255.255.255.255 anywhere LOG level info prefix `Shorewall:smurfs:DROP:'
DROP all -- 255.255.255.255 anywhere
LOG all -- BASE-ADDRESS.MCAST.NET/4 anywhere LOG level info prefix `Shorewall:smurfs:DROP:'
DROP all -- BASE-ADDRESS.MCAST.NET/4 anywhere
[root@pucs-4ak8@9onlineadsl512 durand_gnome]#
0
comperta
Messages postés
18
Date d'inscription
mardi 28 septembre 2004
Statut
Membre
Dernière intervention
30 novembre 2004

6 nov. 2004 à 12:03
Moi j'ai toujours pas resolu mon probleme de partage et de reseau local !!

là je viens de reinstaller linux completement, pour repartir sur une base propre de toute manipulation, j'ai donc seulement configurer mon accés internet.

Pour le reseau local, je dois bien aller dans "configurer votre ordinateur"
=> reseau et internet=>nouvelle connexion ?

Car si je fais ça, et que je choisi LAN , je plante tous et je me retrouve de nouveau avec mon probleme !!


Comperta
0
comperta
Messages postés
18
Date d'inscription
mardi 28 septembre 2004
Statut
Membre
Dernière intervention
30 novembre 2004

6 nov. 2004 à 12:44
bon j'ai configuere mon reseau, puis j'ai configuré le partage de connection (toujours dans le CCM (centre de controle mandrake) )

j'arrive maintenant a avoir internet sur mon pc linux , mais pas sur les autres pc , de plus le reseau local ne marche pas non plus :

voici ce que donne ifconfig :
eth0      Lien encap:Ethernet  HWaddr 00:02:B3:29:22:0E
          inet adr:192.168.1.1  Bcast:192.168.1.255  Masque:255.255.255.0
          adr inet6: fe80::202:b3ff:fe29:220e/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:63 errors:0 dropped:0 overruns:0 frame:0
          TX packets:57 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000
          RX bytes:8610 (8.4 Kb)  TX bytes:5716 (5.5 Kb)
          Interruption:12 Adresse de base:0x4000

eth1      Lien encap:Ethernet  HWaddr 00:60:4C:3F:13:49
          adr inet6: fe80::260:4cff:fe3f:1349/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:65535  Metric:1
          RX packets:559 errors:0 dropped:0 overruns:0 frame:0
          TX packets:452 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000
          RX bytes:378438 (369.5 Kb)  TX bytes:31894 (31.1 Kb)

lo        Lien encap:Boucle locale
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:210 errors:0 dropped:0 overruns:0 frame:0
          TX packets:210 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0
          RX bytes:16858 (16.4 Kb)  TX bytes:16858 (16.4 Kb)

ppp0      Lien encap:Protocole Point-à-Point
          inet adr:82.65.194.65  P-t-P:10.64.64.64  Masque:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1492  Metric:1
          RX packets:123 errors:0 dropped:0 overruns:0 frame:0
          TX packets:68 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:3
          RX bytes:64801 (63.2 Kb)  TX bytes:3799 (3.7 Kb)


et voici ce que donne la commande route :

Table de routage IP du noyau
Destination     Passerelle      Genmask         Indic Metric Ref    Use Iface
10.64.64.64     *               255.255.255.255 UH    0      0        0 ppp0
192.168.1.0     *               255.255.255.0   U     0      0        0 eth0
default         10.64.64.64     0.0.0.0         UG    0      0        0 ppp0



je suis allé dans gerer mes connections, et Eth0 ne possede pas de passerel .



Pour mon Pc sous Xp ,j'aimerais savoir s'il y a une configuration specifique pour avoir acces a internet du pc linux ?


Comperta
0
Pour comperta :

Là ton linux semble être bon... ta connexion se fait bien et la table de routage est bonne. Tant que çà marche, profites-en pour faire une mise à jour, car ils ont déjà corrigé une série de bugs.

Normalement, si le partage via l'interface graphique n'est pas buggé, ça devrait passer...
Il te reste à vérifier tes machines XP : dans les options d'internet explorer, tu vires toutes les connexions, ou au moins cocher la puce "Ne jamais établir de connexion". Dans la partie "LAN", tu décoches tout. Normalement il devrait de lui même chercher la passerelle 192.168.0.1, mais comme ton linux est avec 192.168.1.1, vérifie que ton XP est bien dans la classe 192.168.1. et dans la config de ta carte réseau, mets la passerelle par défault à 192.168.1.1.



Pour Daniel :

Heu... là évidemment c'est shorewall et c'est nettement plus confus, comme tu peux t'en rendre compte toi-même.
Personellement, j'aime pas du tout shorewall... dumoins sous mandrake car il m'a déjà fait des sales coups!

Bref, comme tu as iptables sur ta machine, on va s'en servir...
Mais d'abord, pour ne pas tout virer à l'aveugle: via le panneau de contrôl, désactive le firewall.
Evidemment, il faut pas rester des heures comme çà... mais juste le temps de voir si çà marche ou pas.
Si après avoir désactivé le firewall çà passe, alors on te fera une petite config avec iptables.

Après avoir désactivé le firewall... tu testes juste ta machine linux, à fond pour être sûr que tout marche (si c'est le cas biens sûr!)

Si çà passe, tu testes ton réseau et tu reviens me dire quoi... là on avisera en fonction des résultats.
0
Durand Daniel
6 nov. 2004 à 13:38
Ok, je vais désactiver le firewall mais normalement, alors le partage de connexion ne doit plus fonctionner ?
Je te dis.
DD
0
Durand Daniel
6 nov. 2004 à 13:52
Firewall désactivé.
La connection fonctionne toujours mais le partage non.
Pas de changement pour le réseau.
DD

Nb : je réactive le firewall
0
Ouvre un shell et tape la commande "cat /proc/sys/net/ipv4/ip_forward".

Si il met 0, la connexion n'est pas partagée. S'il met 1, alors le problème vient d'ailleurs...

Question stupide, mais je préfère la poser maintenant... tes machines window$ sont bien sur le même réseau (à savoir 192.168.1.0), et non sur le réseau par défault 192.168.0.0 ???

Est-ce que tu as fait la manip décrite au post 23 pour comperta, à savoir la config de internet explorer sur les window$?
0
comperta
Messages postés
18
Date d'inscription
mardi 28 septembre 2004
Statut
Membre
Dernière intervention
30 novembre 2004

6 nov. 2004 à 14:58
pour la mise a jour, il me dis que le media est mal configurer, dois obligatoirement configurer les paquetages via le site suite suivant :


http://easyurpmi.zarb.org/


Comperta qui s'occupe de xp pour la configuration
0
pour ajouter un media de mise à jour :

urpmi.addmedia update_source http://ftp.belnet.be/linux/mandrake/official/updates/10.1/main_updates with media_info/hdlist.cz

(tu peux évidemment le faire pointer vers un serveur plus proche de chez toi...)

et pour faire la mise à jour :

urpmi --auto-select
0
comperta
Messages postés
18
Date d'inscription
mardi 28 septembre 2004
Statut
Membre
Dernière intervention
30 novembre 2004

6 nov. 2004 à 16:30
ok merci de ton aide François



sinon pour le partage de la connection , cela ne marche pas,
quand j'essai PING , de linux vers xp ca ne marche pas et de wondows vers linux non plus !!


Comperta
0
Bon en relisant la dernière table de routage que tu as posté, elle ne semble pas se mettre à jour automatiquement... la passerelle par défault nbe correspond plus à ta ppp0.

De plus, as-tu 2 cartes réseaux sur ton PC? c'est quoi ce eth1???
Dans le doute, vas dans le ccm et vire toutes les interfaces, enregistre les changement, ferme le ccm et redémarre le pour vérifier qu'il a bien tout viré. Un fois que tu t'es assuré de çà, refais tes connexions en commençant par l'adsl, et ensuite eth0 (avec une adresse valide et compatible avec tes window$ bien sûr).

Si tu as un doute, reposte ton ifconfig+table de routage. Dans tous les cas, ta table de routage doit se mettre à jour automatiquement à chaque connexion de ppp0.
0
je suis pas chez moi la, je test des que possible ce que tu m'as dit , eth1 est lié a mon modem sagem fast 908 qui possede une connection ethernet !!!



Comperta

Ps : merci pour le temps que tu nous consacre !!
0
comperta
Messages postés
18
Date d'inscription
mardi 28 septembre 2004
Statut
Membre
Dernière intervention
30 novembre 2004
> comperta
6 nov. 2004 à 22:17
bon j'ai fais ce que tu m'as dis a savoir :
supprimer les connections reseau internet et local
fermer CCM
Rouvrir CCM
reconfigurer ADSL
reconfigurer Reseau local
reconfigurer le partage connection

resultat :
sous linux :
internet fonctionne
reseau local toujours pas

par contre j'arrive a pinger mon windows :

[root@lifetec comperta]# ping 192.168.1.4
PING 192.168.1.4 (192.168.1.4) 56(84) bytes of data.
64 bytes from 192.168.1.4: icmp_seq=1 ttl=128 time=0.424 ms
64 bytes from 192.168.1.4: icmp_seq=2 ttl=128 time=0.293 ms
64 bytes from 192.168.1.4: icmp_seq=3 ttl=128 time=0.293 ms

--- 192.168.1.4 ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2000ms
rtt min/avg/max/mdev = 0.293/0.336/0.424/0.065 ms


donc une toute petite amelioration.

sous windows :

rien de changer , toujours pas d'internet et toujours pas de reseau
au niveau ping :

reponse de 192.168.1.1 : impossible de joindre l'hote de destination
reponse de 192.168.1.1 : impossible de joindre l'hote de destination
reponse de 192.168.1.1 : impossible de joindre l'hote de destination
reponse de 192.168.1.1 : impossible de joindre l'hote de destination
Statistiques :
paquets : envoyés= 4 recus = 4 perdus =0



retour sous linux : un ifconfig me donne :

eth0      Lien encap:Ethernet  HWaddr 00:02:B3:29:22:0E
          inet adr:192.168.1.1  Bcast:192.168.1.255  Masque:255.255.255.0
          adr inet6: fe80::202:b3ff:fe29:220e/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:80 errors:0 dropped:0 overruns:0 frame:0
          TX packets:99 errors:0 dropped:0 overruns:61 carrier:0
          collisions:0 lg file transmission:1000
          RX bytes:10031 (9.7 Kb)  TX bytes:10238 (9.9 Kb)
          Interruption:12 Adresse de base:0x4000

eth1      Lien encap:Ethernet  HWaddr 00:60:4C:3F:13:49
          adr inet6: fe80::260:4cff:fe3f:1349/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:65535  Metric:1
          RX packets:2947 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2491 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000
          RX bytes:1734511 (1.6 Mb)  TX bytes:234516 (229.0 Kb)

lo        Lien encap:Boucle locale
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:238 errors:0 dropped:0 overruns:0 frame:0
          TX packets:238 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0
          RX bytes:19337 (18.8 Kb)  TX bytes:19337 (18.8 Kb)

ppp0      Lien encap:Protocole Point-à-Point
          inet adr:82.65.90.72  P-t-P:192.168.254.254  Masque:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1492  Metric:1
          RX packets:1422 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1057 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:3
          RX bytes:1018708 (994.8 Kb)  TX bytes:67138 (65.5 Kb)



et un route :

Table de routage IP du noyau
Destination     Passerelle      Genmask         Indic Metric Ref    Use Iface
192.168.254.254 *               255.255.255.255 UH    0      0        0 ppp0
192.168.1.0     *               255.255.255.0   U     0      0        0 eth0
default         192.168.254.254 0.0.0.0         UG    0      0        0 ppp0


donc si j'ai bien suivi, il semblerais qu'il n'y est pas du tout de routage c'est bien ca ?


comperta
0
Durand Daniel
14 nov. 2004 à 10:35
Bonjour,

J'ai eu une semaine chargée en déplacements divers d'où mon silence radio. j'ai lu avec intérêt les échanges. J'ai envie aussi de virer shorewall et d'installer iptables.
Quel fichier iptables dois-je installer : quelles différences avec celui donné à Compera ?
ma config est la suivante :
- connexion ADSL sur un poste LInux : ppp0 sur carte eth0
- lien avec une deuxième carte eth1 à mon réseau comprenant un poste windows et un poste linux (portables)
- donc beoin de partage de connexion, de communication réseau entre postes Linux et Windows.

Merci d'avance pour la patience et l'attention, Françaois.

Daniel
0
Salut...

Je saisis pas bien l'histoire du ppp0 sur eth0, pour moi c'est deux conecteurs réseaux séparés, donc soit tu te coinnectes via un ppp0 soit via un eth0. D'après ce que j'ai relu en début de cette série de posts, tu te connectes au net via eth0 et en local via eth1.

Dans cette configuration, les règles à mettre dans iptables sont les suivantes:

#on nettoie tout:
iptables -F INPUT
iptables -F OUTPUT
iptables -F FORWARD

#on règle ce qui peut entrer depuis internet:
iptables -A INPUT -i eth0 -m state --state ESTABLISHED,RELATED -j ACCEPT

#pour permette aux applications de communiquer entre-elle sur le linux:
iptables -A INPUT -i lo -j ACCEPT

#il faut permettre aux machines internes de passer:
iptables -A INPUT -i eth1 -j ACCEPT

#il faut faire du "masquerading" (NAT) pour partager la conexion:
iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE

#pour pouvoir faire un ping depuis le réseau interne:
iptables -A INPUT -i eth1 -p icmp -j ACCEPT

#enfin, il faut bloquer le reste:
iptables -P INPUT DROP
iptables -P OUTPUT ACCEPT
iptables -P FORWARD ACCEPT



Si tout semble fonctionner avec çà, il faut penser à enregistrer pour le prochain démarrage : "iptables-save > /etc/sysconfig/iptables".
Il faudra également virer shorewall car il se démarre après iptables et donc effacera tout s'il est installé.

Je pense qu'avec çà ça devrait aller... mais sans garantie selon la config que tu as (eth0/ppp0). Si jamais çà ne passe pas, essaie en remplaçant tous les eth0 par ppp0.

autre truc utile : "iptables -L " pour lister les règles actuellement en vigueur. (histoire voir s'il y a accumulation de règles contradictoires)


ATTENTION : comme sur la carte eth1 tu n'as pas de protection, fais gaffe à ne pas intervertir les deux câbles sinon c'est "journée portes ouvertes" chez toi! ;-)
0
Durand Daniel
14 nov. 2004 à 18:28
En fait,

après essai, iptables fonctionne seulement avec ppp0 et eth1.
************************************************
Voici le resultat de iptables -L

[root@pucs-4ak8@9onlineadsl512 durand_gnome]# iptables -L Chain INPUT (policy DROP)
target prot opt source destination
ACCEPT all -- anywhere anywhere state RELATED,ESTABLISHED
ACCEPT all -- anywhere anywhere
ACCEPT all -- anywhere anywhere
ACCEPT icmp -- anywhere anywhere

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination

*********************************************************
voici ifocnfig
[root@pucs-4ak8@9onlineadsl512 durand_gnome]# ifconfig
eth0 Lien encap:Ethernet HWaddr 00:E0:7D:8E:38:54
adr inet6: fe80::2e0:7dff:fe8e:3854/64 Scope:Lien
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:55298 errors:0 dropped:0 overruns:0 frame:0
TX packets:44209 errors:0 dropped:0 overruns:0 carrier:0
collisions:36 lg file transmission:1000
RX bytes:38924256 (37.1 Mb) TX bytes:5051251 (4.8 Mb)
Interruption:11

eth1 Lien encap:Ethernet HWaddr 00:50:FC:53:59:38
inet adr:192.168.1.1 Bcast:192.168.1.255 Masque:255.255.255.0
adr inet6: fe80::250:fcff:fe53:5938/64 Scope:Lien
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:37959 errors:0 dropped:0 overruns:0 frame:0
TX packets:30296 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
RX bytes:4126031 (3.9 Mb) TX bytes:32102627 (30.6 Mb)
Interruption:10 Adresse de base:0x2000

lo Lien encap:Boucle locale
inet adr:127.0.0.1 Masque:255.0.0.0
adr inet6: ::1/128 Scope:Hôte
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:379 errors:0 dropped:0 overruns:0 frame:0
TX packets:379 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:0
RX bytes:30296 (29.5 Kb) TX bytes:30296 (29.5 Kb)

ppp0 Lien encap:Protocole Point-à-Point
inet adr:84.97.65.3 P-t-P:84.97.65.1 Masque:255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1492 Metric:1
RX packets:52606 errors:0 dropped:0 overruns:0 frame:0
TX packets:41513 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:3
RX bytes:37605041 (35.8 Mb) TX bytes:3976053 (3.7 Mb)
***************************************************************************
1/ le partage de connection fonctionne mais comment pinguer les ordinateurs windows puisque ceux-ci n'ont pas de d'IP fixes ?
2/ j'ai toujours un problème avec un site : citeglobe.com qui héberge mon nom de domaine (durand-amd.net).
Impossible de le contacter par internet et impossible d'utiliser mes adresses email sur ce nom de domaine.
Je ping l'adresse pourtant
bash-2.05b$ ping durand-amd.net
PING durand-amd.net (66.199.139.31) 56(84) bytes of data.
64 bytes from host0-cite.citeglobe.com (66.199.139.31): icmp_seq=1 ttl=41 time=158 ms
64 bytes from host0-cite.citeglobe.com (66.199.139.31): icmp_seq=2 ttl=41 time=157 ms

merci d'avance

Daniel
0
Bon, là fais gaffe : tu n'as plus de firewall! ...les premières règles ne sont pas bonnes : elles permettent à tout de passer.

OK... donc ta connexion se fait bien par ppp0 donc revoici les commandes que tu vas faire (copie-colle!):

#on nettoie tout:
iptables -F INPUT
iptables -F OUTPUT
iptables -F FORWARD

#on règle ce qui peut entrer depuis internet:
iptables -A INPUT -i ppp0 -m state --state ESTABLISHED,RELATED -j ACCEPT

#pour permette aux applications de communiquer entre-elles sur le linux:
iptables -A INPUT -i lo -j ACCEPT

#il faut permettre aux machines internes de passer:
iptables -A INPUT -i eth1 -j ACCEPT

#il faut faire du "masquerading" (NAT) pour partager la conexion:
iptables -t nat -A POSTROUTING -o ppp0 -j MASQUERADE

#pour pouvoir faire un ping depuis le réseau interne:
iptables -A INPUT -i eth1 -p icmp -j ACCEPT

#enfin, il faut bloquer le reste:
iptables -P INPUT DROP
iptables -P OUTPUT ACCEPT
iptables -P FORWARD ACCEPT



Ensuite tu enregistres de nouveau avec "ipatbles-save > /etc/sysconfig/iptables".

Et assure-toi que le forwarding est bien activé par "echo 1 > /proc/sys/net/ipv4/ip_forward"

Quand tu auras fait tt çà... un petit "iptables -L" pour s'assurer que tt est OK, car là tu n'as plus de firewall, et je sais pas comment t'as fait çà!

réponse 1 : mets une adresse IP fixe à chaque PC entre 192.168.1.2 et 192.168.1.254 (avec masque de sousréseau par défaut = 255.255.255.0 et passerelle par défaut = 192.168.1.1 )

réponse 2 : probablement dû aux problèmes d'adresses car le site est OK. Donc ça sera peut-être résolu avec les étapes ci-dessus.


Assure toi bien que shorewall ne vient pas mettre son grain de sel! (urpme shorewall).
0
Durand Daniel
14 nov. 2004 à 20:33
Bonjour,

J'ai modifié et sauvé iptables. désinstallé shorewall

j'ai redonné une IP fixe aux deux autres ordis du réseau sous windows (192.168.1.5 et 192.168.1.9).
J'ai tout arrté et tout redémarré.
Voila la situation :
- connection internet sur post eprincipal : OK
- pas de partage de connection sur les deux autres postes pourtant la commande de forwarding renvoie bien 1
- réseau : les postes windows sont atteints sous Nautilus avec un partage Samba
- le poste principal Linux n'est pas visible depuis les postes windows.
- toujours pas possible d'atteindre le site durand-amd.net et de relever le courrier alors qu'il est pingué

donc en remettant des IP fixes su rles deux postes clients, je n'ai pas de partages mais ils sont vus en réseau ??

Daniel
voci iptables -L
[root@pucs-4ak8@9onlineadsl512 durand_gnome]# iptables -L
Chain INPUT (policy DROP)
target prot opt source destination
ACCEPT all -- anywhere anywhere state RELATED,ESTABLISHED
ACCEPT all -- anywhere anywhere
ACCEPT all -- anywhere anywhere
ACCEPT icmp -- anywhere anywhere

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination
****************************************************************
voici ifconfig
[root@pucs-4ak8@9onlineadsl512 durand_gnome]# ifconfig
eth0 Lien encap:Ethernet HWaddr 00:E0:7D:8E:38:54
adr inet6: fe80::2e0:7dff:fe8e:3854/64 Scope:Lien
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:2378 errors:0 dropped:0 overruns:0 frame:0
TX packets:1747 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
RX bytes:871814 (851.3 Kb) TX bytes:156633 (152.9 Kb)
Interruption:11

eth1 Lien encap:Ethernet HWaddr 00:50:FC:53:59:38
inet adr:192.168.1.1 Bcast:192.168.1.255 Masque:255.255.255.0
adr inet6: fe80::250:fcff:fe53:5938/64 Scope:Lien
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1107 errors:0 dropped:0 overruns:0 frame:0
TX packets:459 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
RX bytes:137661 (134.4 Kb) TX bytes:54398 (53.1 Kb)
Interruption:10 Adresse de base:0x2000

lo Lien encap:Boucle locale
inet adr:127.0.0.1 Masque:255.0.0.0
adr inet6: ::1/128 Scope:Hôte
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:188 errors:0 dropped:0 overruns:0 frame:0
TX packets:188 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:0
RX bytes:14130 (13.7 Kb) TX bytes:14130 (13.7 Kb)

ppp0 Lien encap:Protocole Point-à-Point
inet adr:84.97.72.193 P-t-P:84.97.72.1 Masque:255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1492 Metric:1
RX packets:2200 errors:0 dropped:0 overruns:0 frame:0
TX packets:1565 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:3
RX bytes:812660 (793.6 Kb) TX bytes:111131 (108.5 Kb)
*************************************************************************

la commande route
[root@pucs-4ak8@9onlineadsl512 durand_gnome]# route
Table de routage IP du noyau
Destination Passerelle Genmask Indic Metric Ref Use Iface
84.97.72.1 * 255.255.255.255 UH 0 0 0 ppp0
192.168.1.0 * 255.255.255.0 U 0 0 0 eth1
127.0.0.0 * 255.0.0.0 U 0 0 0 lo
default 84.97.72.1 0.0.0.0 UG 0 0 0 ppp0
******************************************************************
0
Ben dis... j'sais pas comment t'arrives à çà mais... chapeau bas! j'voudrais que j'y arriverais pas!

bon, sérieusement : tout à l'air pourtant correct. Es-tu sûr de tes cablâges? et de la config des clients?
A priori, si tu sais te connecter dans un sens, tu sais aussi dans l'autre (en local dumoins).

le poste principal Linux n'est pas visible depuis les postes windows
Que veux-tu dire par là? tu parles du ping, ou du 'voisinage réseau'?

En tout cas, ta table de routage du linux est bonne et le firewall laisse passer tout ce qu'il faut. (enfin... c'est la config habituelle que je fais et qui ne m'a jamais posé problème)

C'est vraiment comme si le forwarding ne passait pas. je sais que tu l'as certainement déjà fait, mais... vérifie encore que "cat /proc/sys/net/ipv4/ip_forward" te répond 1 (fais bien attention au chemin... une leetre différente et c'est loupé!)

Essaie également de mettre l'adresse du serveur DNS de ton provider dans les machines clientes. (DNS primaire dans les paramètres des connexions réseaux sur les stations windows).
0
Et puis si tu peux aussi faire un "cat /etc/sysconfig/iptables" et poster le résultat pour être tout à fait sûr du firewall.
0
Bon... j'réfléchis encore et je me dis que si le ping passe et en plus sur le nom DNS, c'est que ton linux est bon.

J'dirais que ça vient plutôt des clients...
As-tu bien désactivé les autres connexions dans Internet Explorer? (dans les options, supprimer toutes les connexions ou cocher "ne jamais établir de connexion" en-dessous).
Et dans "Paramètres réseaux", tout décocher.
0
Durand Daniel
14 nov. 2004 à 22:24
On progresse :

1/ - j'ai mis les DNS de mon provider sur mes deux postes windows. Le partage internet refonctionne de nouveau : bravo !

2/ - question réseau : depuis windows XP et windows 98, je peux pinguer le poste Linux par "exécuter..." mais je n'ai rien dans les deux voisinages réseau

3/ toujours impossible de me connecter sur durand-amd.net et d'avoir le courrier de cette boite en Pop3

Voci
[root@pucs-4ak8@9onlineadsl512 durand_gnome]# cat /etc/sysconfig/iptables
# Generated by iptables-save v1.2.9 on Sun Nov 14 19:29:19 2004
*mangle
:PREROUTING ACCEPT [132104:66800972]
:INPUT ACCEPT [57483:29650462]
:FORWARD ACCEPT [74503:37134636]
:OUTPUT ACCEPT [31708:19506224]
:POSTROUTING ACCEPT [107664:56853454]
COMMIT
# Completed on Sun Nov 14 19:29:19 2004
# Generated by iptables-save v1.2.9 on Sun Nov 14 19:29:19 2004
*nat
:PREROUTING ACCEPT [26848:1358961]
:POSTROUTING ACCEPT [2044:250824]
:OUTPUT ACCEPT [3222:325260]
-A POSTROUTING -o ppp0 -j MASQUERADE
-A POSTROUTING -o eth0 -j MASQUERADE
-A POSTROUTING -o ppp0 -j MASQUERADE
-A POSTROUTING -o ppp0 -j MASQUERADE
COMMIT
# Completed on Sun Nov 14 19:29:19 2004
# Generated by iptables-save v1.2.9 on Sun Nov 14 19:29:19 2004
*filter
:INPUT DROP [218:10545]
:FORWARD ACCEPT [232:13934]
:OUTPUT ACCEPT [86:5649]
-A INPUT -i ppp0 -m state --state RELATED,ESTABLISHED -j ACCEPT
-A INPUT -i lo -j ACCEPT
-A INPUT -i eth1 -j ACCEPT
-A INPUT -i eth1 -p icmp -j ACCEPT
COMMIT
# Completed on Sun Nov 14 19:29:19 2004
*********************************************************
A suivre

Daniel
0
2 > c'est normal si tu n'as pas installé le serveur SAMBA sur ton linux. L'as-tu installé et configuré?

3> si le ping passe et internet passe, alors le problème ne se situe pas sur le linux passerelle, mais bien sur le client. Revois ta config du serveur pop dans les logiciels mails de tes clients (Outlook express...).
(exemple : pop.durand-amd.net pour le serveur pop)


Pour le reste, c'est parfait du côté de la passerelle linux, le dernier cat m'a rassuré sur un doute que j'avais.
0
Durand Daniel
14 nov. 2004 à 22:37
Correction,

Sur le poste XP, je viens dans Internet explorer de décocher une case dans réseaus.
Du coup avec "exécuter \\192.168.1.1" 'obtiens une feêtre de connection me demandant un nom d'utilisateur et un mot de passe.
Est-ce le même qu'à l'ouverture de Windows ? je ne m'en souviens plus et dans XP je suis nul pour aller le retrouver...

Par contre sous Win 98 pas de changement, je peux pinger par "exécuter" mais pas de lancement avec l'adresse IP du serveur et rien dans le partage de connection.
Je ne pense qu'il y ait qq chose de cocher dans IE, je n'ai rien vu mais..
DD
0