PHP session_start bug

Résolu
Bonjour,

J'ai envoyé un sript php (File Thingie) sur deux sites (serveur Apache). Sur le premier, il marche bien, mais quand j'ai voulu l'envoyer sur le second, le programme a bloqué au niveau de session_start. Je pense que c'est un problème de mémorisation de la variable $_Session, ou de cookie qui n'est pas remis à jour. J'ai éliminé les cookies sur mon navigateur IE, mais ça n'a rien fait. D'ailleurs les cookies sont peut-être mémorisés sur le serveur. Il y a parait-il quelque part sur le serveur un fichier sessions où les sessions sont enregistrées et c'est sans doute là où il faudrait aller...
Enfin je suppose, parce-que en fait je ne connais rien au php. Voilà les messages erreur :

Warning: session_start() [function.session-start]: open(/mnt/128/sdb/3/5/yurugu/sessions/sess_78598a064e63d9eb427e62d3482fb413, O_RDWR) failed: No such file or directory (2) in /mnt/128/sdb/3/5/yurugu/data/ft2.php on line 951

Warning: session_start() [function.session-start]: Cannot send session cookie - headers already sent by (output started at /mnt/128/sdb/3/5/yurugu/data/ft2.php:951) in /mnt/128/sdb/3/5/yurugu/data/ft2.php on line 951

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /mnt/128/sdb/3/5/yurugu/data/ft2.php:951) in /mnt/128/sdb/3/5/yurugu/data/ft2.php on line 951

Warning: Cannot modify header information - headers already sent by (output started at /mnt/128/sdb/3/5/yurugu/data/ft2.php:951) in /mnt/128/sdb/3/5/yurugu/data/ft2.php on line 952

Quelle horreur !
Quelqu'un(e) aurait-il une idée voire une solution sur ce problème ?

Merci
Darkon
Configuration: Windows XP
Internet Explorer 7.0

8 réponses

  1. Merci Chuch, c'est bien ça !
    Sur Free.fr, Il suffit de créer un répertoire nommé "sessions" à la racine du site perso pour que les programmes PHP employant cette fonction fonctionnent...
    1. sur certain serveur (free notament) il te faut cree un repertoire sessions ou va se stocker le N° de session

      et c 'est ce qu'il dit dans la 1ere erreur

      failed: No such file or directory
      essaye deja ca
      1. Merci beaucoup ça marche pour moi aussi
    2. Ben si c'est sur free le plus simple c'est de télécharger FileZilla et de te connecter à ton serveur puis il t'afficheras tous les répertoires que contient ton site/serveur et tu ferra dans cette zone clic droit puis nouveau dossier et puis le tour est joué tu as un nouveau répertoire !
      1. merci à toi,
        tu m'as bien aidé ca fait deux jours que je galérais....
        super conseil...

        ciao ciao
    3. cela fait plusieurs heures que je cherche une solution, un dossier session et hop, tout est réglé!!!!!!
      merci beaucoup!!!!!!!!!!!!
      1. moi il me met sa quan je me connect sur le site
        Forbidden
        You don't have permission to access /sessions/karim on this server.

        Apache/ProXad [Aug 9 2008 02:45:07] Server at abidjautoluxe.free.fr Port 80
        1. tous fonctionne au niveau site web mais comment je recupre les fichiers