Url rewriting
Résolu
Bonjour,
Je viens de changer d'hébergeur et celui que j'ai actuellement me permet d'utiliser l'url rewriting. J'ai donc fais des tests. Toutefois ça ne semble pas fonctionner.
Les même tests en local fonctionne pourtant.
Mon htaccess est le suivant:
En local j'ai aucun souci.
En distant j'ai une erreur 404.
Mon hébergeur actuel est 1and1. Si vous avez des idées à me suggérer.
Merci d'avance.
--
« La recherche commence là où s'arrête la connaissance. »
Je viens de changer d'hébergeur et celui que j'ai actuellement me permet d'utiliser l'url rewriting. J'ai donc fais des tests. Toutefois ça ne semble pas fonctionner.
Les même tests en local fonctionne pourtant.
Mon htaccess est le suivant:
Options +FollowSymlinks RewriteEngine on RewriteRule ^article-([0-9]+)-([0-9]+)\.html$ article.php?id=$1&rubrique=$2 [L]
En local j'ai aucun souci.
En distant j'ai une erreur 404.
Mon hébergeur actuel est 1and1. Si vous avez des idées à me suggérer.
Merci d'avance.
--
« La recherche commence là où s'arrête la connaissance. »
Configuration: Ubuntu 9.04 Jaunty Jackalope :) Firefox 3.0.10 Bluefish 1.0.7
2 réponses
-
Contributeursalut,
dixit la FAQ 1&1 :Les trois instructions ci-dessous sont impératives afin de faire fonctionner l'URL Rewriting. Options +FollowSymLinks RewriteEngine On RewriteBase / -
Merci beaucoup pour ton aide. En fait j'ai trouvé la solution entre temps. Ayant un sous répertoire je devais rajouter le chemin dans cette troisième ligne.
RewriteBase /Sous répertoire
Problème résolu donc. ça marche parfaitement maintenant.