Tftp natif

Résolu
Bonjour,
J'ai vu que dans /etc/services il y a bien le tftp port 69 en udp. Cependant, je n'arrive pas à l'activer...
quelqu'un saurait comment je peux faire pour faire de ma bécane un serveur tftp?
Merci d'avance.

6 réponses

  1. Modérateur
    Salut,

    Surement faut-il installer le paquet serveur/client et ensuite configurer le tout et en fonction de ta distrib l'activer via inet ou xinet...
    1. Bonjour Jipicy,

      j'ai fait :
      apt-get install tftpd
      apt-get install tftpd-hpa //la version serveur d'après ce que j'ai lu sur le site de Debian

      Puis dans inetd.conf j'ai :
      <service_name> <sock_type> <proto> <flags> <user> <server_path> <args>
      tftp dgram udp wait nobody /usr/sbin/tcpd /usr/sbin/in.tftpd /srv/tftp

      est-ce que cela signifie que le service est actif?
    2. @jipicyquand je fais un copy running-config tftp://@ip_debian sur matos cisco, il n'arrive pas à l'atteindre. Pourtant, je le "ping" bien ...
    3. @dubcekj'ai fait ta commande, puis un inetd, et toujours rien... :-(
  2. Contributeur
    voir d'éventuels messages dans /var/adm/<fichier log>
    voir si tftp est autorisé dans hosts_access
    1. dans les log, j'ai :

      in.tftpd[23921]: cannot set groups for user nobody

      et sur mon switch j'ai ce message :

      switch#copy running-config tftp://10.2.0.37
      Address or name of remote host [10.2.0.37]?
      Destination filename switch-confg]?
      TFTP: error code 2 received - 20334

      %Error opening tftp://10.2.0.37/aix15019-confg (Permission denied)
  3. Contributeur
    les droits dans /srv/tftp doivent être 777
    voir man tftpd
    Due to the lack of authentication information, tftpd will allow only publicly readable files (o+r) to be accessed, unless the -p option is specified. Files may be written only if they already exist and are publicly writable, unless the -c option is specified.
    1. est-ce à moi de créer ce dossier ou fichier /srv/tftp ? car je ne l'ai pas actuellement.
    2. @dubcekj'ai créé ce dossier, et j'ai fait un chmod 777 dessus.
      sinon, je suis allée voir le contenu de /usr/sbin/in.tftpd et /usr/sbin/tftpd . C'est illisible... pleins de caractères spéciaux... (Lecture de 77 lignes. converties du format mac .

      maintenant quand je fais un copy running-config tftp://@ip sur mon matos cisco j'ai un time out ...
  4. Contributeur
    /usr/sbin/in.tftpd et /usr/sbin/tftpd sont les exécutable du tftp daemon
    essayer tftp 10.2.0.37 depuis une autre mnachine
    1. ça marche pas
  5. Il n'y en a pas...
    je pense que je devrai tout reprendre depuis le début... Je pense que j'ai trop fait n'importe quoi avec les fichiers de conf... je vais tout refaire sur une VM.
    1. J'ai fini par réussir à le faire fonctionner ce serveur TFTP! j'ai desinstallé les 2 packages et je n'ai ré-installé que tftpd-hpa. Et au premier test, ça a fonctionné!
      RESOLU!