Droits d'administration phpmyadmin

Résolu
Bonjour,
bonsoir à tous.

voici mon problème :

je tourne sur un debian etch avec un serveur apache2, mysql, php4 et phpmyadmin pour l administration en mode graphique de mysql..

tout à l'heure, j ai modifié par erreur les droits du dossier phpmyadmin contenu dans /var/www/phpmyadmin.

en effet j'ai effectué un chmod -R 777 /var/www car un ami voulait uploader des fichiers dans un sous dossier de /www pour remettre a jour les scripts..

grosse erreur de ma part car en ayant modifié les droits de /www, j ai aussi modifié les droits de /www/phpmyadmin.

résultat : impossibilité totale de se reconnecter a phpmyamin via le navigateur web car phpmyadmin n'accepte qu'un seul type de droits..

n'arrivant pas a retrouver les droits d'origine, es ce qu'une bonne ame pourrait me dire quels sont ses droits sur le dossier /var/www/phpmyadmin chez lui et si ces droits sont récursifs dans le dossier de phpmyadmin?

voici l'erreur que me donne l'interface de phpmyadmin :

Erreur

MySQL a répondu:Documentation
#1045 - Access denied for user 'root'@'localhost' (using password: NO)
phpMyAdmin n'a pu lire votre fichier de configuration!
Il est possible qu'il contienne une erreur de syntaxe, ou que PHP soit incapable de le trouver
À l'aide du lien suivant, vous pouvez vérifier le message d'erreur généré par PHP;
la plupart du temps, un apostrophe ou un point-virgule sont manquants.
Si vous recevez une page blanche, aucune erreur n'a été détectée.

merci d'avance pour votre aide :)
Configuration: Linux Debian
Mozilla 1.8.1.12

6 réponses

  1. salut à tous, en fait j'ai réussi à résoudre le problème.

    voici en quelques lignes mon résultat :

    le fait d'utiliser dpkg --purge ne désinstalle pas tous les paquets, en effet il reste certains paquets dits communs qui resteront en place, et comme phpmyadmin créé des liens vers Mysql, il faudra aussi prévoir de retirer les paquets de ce dernier.

    la méthode la plus simple que j'ai pu trouver est d'utiliser le sinopsys de débian avec l'interface graphique de gnome, il permet de retirer radicalement les paquets installés et les paquets liés.

    il suffit de réinstaller le tout à nouveau et le tour est joué..

    remarque : pour ceux qui veulent modifier config.inc.php de phpmyadmin, il ne faut pas (sous version debian avec php4) décocher les parametres des quotes magiques, en effet cela produit un bug au niveau de phpmyadmin qui ne nous donne plus accès à la fenetre de login et nous dit que l'utilisateur root@'localhost' ne peut se connecter car il ne peut lire le fichier config.inc.php

    voilà, j'espère avoir pu éclairer certains d'entre nous qui ont le meme soucis, et étant en BTS administration de réseaux je pense venir fréquement essayer de répondre à certaines questions..

    merci encore :)
    1. Modérateur
      dpkg --purge et aptitude --purge ne font pas tout à fait la même chose, la première méthode est plus radicale. Essaye vraiment ce que je t'ai mis dans <1>.

      Bonne chance
      1. j avais déja désinstallé les paquets phpmyadmin avec :

        aptitude purge phpmyadmin

        et réinstallé ensuite :

        aptitude install phpmyadmin

        mais rien à faire, il revient à état, meme en stoppant le serveur apache et en rédamarant le système.

        j'ai mis les droits que tu m as envoyé, mais la encore rien à faire, il ne veut rien savoir..

        merci pour votre aide, en espérant qu'une solution est proche.. avant la désinstallation complète de tout le toutim :'(
        1. Contributeur
          Mais non mais non, du calme..
          Si tu maitrises l'anglais, tu vas sur irc.freenode.net, tu rejoins le chan #debian, tu poses ta question poliment et en 5 min t'auras la réponse des Maîtres, et tu viens la poster ici.
          Sinon j'y jetterai un oeil ce W.E.
      2. Contributeur
        Chez moi j'ai ceci dans /var/www :
        lrwxrwxrwx 1 root root 21 2008-02-18 16:41 phpmyadmin -> /usr/share/phpmyadmin

        et dans /usr/share :

        drwxr-xr-x 9 root root 4096 2008-02-18 16:54 phpmyadmin

        En espérant que cela puisse t'aider..
        1. Modérateur
          Essaye de purger et reinstaller phpmyadmin
          dpkg --purge phpmyadmin
          aptitude install phpmyadmin

          Bonne chance